Black screen with cursor after installing NVIDIA proprietary drivers

I installed Manjaro! Installed Minecraft to play but noticed terrible frames. Installed NVIDIA proprietary drivers using the command:
sudo mhwd --install pci video-nvidia
Restarted PC to only see a black screen with my movable cursor. I was able to get into tty2 and remove ‘quiet’ from the grub config. All this has really done has added some text to my black screen with a cursor. Now I’m stuck.

I have an output for the inxi command with my PC info but I have no idea how to post it on here, because I only have access to the command line.

That should help you pipe the output to a paste and share it here.
(I should update that … but the first one still works)

1 Like

When I run some commands that bring up graphical interfaces I get the follow errors:

For the command:


I get:

ERROR: The control display is undefined; please run 'nvidia-settings --help' for more information.

For the command:


I get:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix the problem.```

Currently trying this but I’m getting the following error:

curl: (26) Failed to open/read local data from file/application

Okay I figured out the curl command after trial and error. Here’s my output:

  Kernel: 6.1.21-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=2b841e3a-c675-46f9-9a1c-9244fec65e29 rw splash
  Console: tty 2 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: B450 Steel Legend
    serial: <superuser required> UEFI: American Megatrends v: P3.20
    date: 11/27/2019
  Message: No system battery data found. Is one present?
  RAM: total: 15.55 GiB used: 691.6 MiB (4.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2587 high: 3600 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3600 2: 2200
    3: 2200 4: 2200 5: 3600 6: 2200 7: 3600 8: 2053 9: 2800 10: 2200 11: 2200
    12: 2200 bogomips: 86271
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1402
    class-ID: 0300
  Device-2: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: ASUSTeK driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.0 chip-ID: 10de:1380
    class-ID: 0300
  Device-3: Generic HD camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-1:2 chip-ID: 1903:8328 class-ID: 0102
  Display: x11 server: v: driver: X: loaded: nvidia
    gpu: nvidia,nvidia tty: 170x48
  API: OpenGL Message: GL data unavailable in console. Try -G --display
  Device-1: NVIDIA GM206 High Definition Audio vendor:
    driver: snd_hda_intel v: kernel bus-ID: 3-1:2 pcie: chip-ID: 1903:8328 gen: 1
    class-ID: 0102 speed: 2.5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fba class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.1 chip-ID: 10de:0fbc
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-4: Generic HD camera type: USB driver: snd-usb-audio,uvcvideo
  API: ALSA v: k6.1.21-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.67 status: off with: wireplumber status: off
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: off tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: c000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 232.89 GiB used: 44.47 GiB (19.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 750 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 44.47 GiB (19.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 2b841e3a-c675-46f9-9a1c-9244fec65e29
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 9011-19E8
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    chip-ID: 0a12:0001 class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Generic HD camera type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 1.1 speed: 480 Mb/s
    power: 256mA chip-ID: 1903:8328 class-ID: 0102
  Device-2: 3-3:3 info: Razer USA Cynosa Chroma type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 1532:022a class-ID: 0300
  Device-3: 3-4:4 info: Razer USA DeathAdder Essential type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 1532:006e class-ID: 0300
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 45.4 C mobo: N/A gpu: nvidia temp: 40 C
  Fan Speeds (RPM): N/A
  Processes: 215 Uptime: 15m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1167 libs: 337 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Bash (login)
  v: 5.1.16 running-in: tty 2 inxi: 3.3.26```

The BIOS is rather out of date.
This could be a problem with the latest graphics stack from nvidia.

Im guessing this appearance of 2 cards is in error?

1 Like

I do indeed have two cards in my system. A GTX 750 and a GTX 950. I have one monitor plugged into each.

Do you think updating the BIOS could help? Or is it just a note for me?

And how could I fix the issue so I can at least get my desktop back in the meantime?

Its possible.

But realizing the age of the cards … you likely should not have tried to install the latest nvidia driver.

If we are to assume its the outcome of installing video-nvidia profile then you can remove it and/or (re)install the open video-linux profile.

1 Like

I feel like it has to be, considering it’s the only thing I really did before rebooting. How would I remove the video-nvidia profile?

The reverse of what you did.

sudo mhwd -r pci video-nvidia

Once you’ve done that … reboot. It may work ok.

Then look at what mhwd suggests:

mhwd -l

There are multiple nvidia series that manjaro provides. Likely your older card(s) want one of them.
[video-nvidia-390, video-nvidia-470, etc]


Okay, I rebooted and got the same thing but slightly different. Now my black screen has some nouveau error codes. They are:

[ 4.307302] nouveau 0000:01:00.0: bus: MMIO write of 80000122 FAULT at 10eb14
[ 5.481859 ] nouveau 0000:0a:00.0: bus: MMIO read of 00000000 FAULT at 3e6684 [ PRIVRING]

I still have access to tty2, but it shows up on my other monitor now, the one connected to the GTX 950 (before it was on the GTX 750 Ti monitor)

What am I looking for in the output of mhwd -l?

With two Nvidia GPUs and your Monitors setup like that you will have to set Multihead as described in NVIDIA - ArchWiki

The problem that might happen in your case is that i’m not sure if the GTX 750 is supported by the latest Nvidia driver. The GTX 950 is, but you might have to go back to the video-nvidia-470xx and then set the Multihead part as described in the Arch wiki link mentioned above.

With Nouveau drivers aka video-linux the gaming will suffer greatly in performance …

1 Like

I won’t swear to it but I believe the 530 driver starts it’s support at the nvidia 650 card and up. My previous card to this one was the 750 and I know I was on newer than 470 driver.

1 Like

I just need to get my desktop back first… then I can try getting the NVIDIA drivers to work. But right now I don’t have an accessible desktop! How can I at least fix it to get a desktop?

When I plug in my live USB and boot with proprietary drivers I get the same thing, with the black screen.

Hi, i had a simaler problem. But I fixed it.
Mayber my thread will help you (see link).

Short answer:
at my system it was about all about the nvedia driver that wouldnt work with the intel drivers.
(i know you have an amd system, but maybe it’s the same solution (?))

In the end i had to take “ibt=off”. (search it on the search engine of your choice)
It will stop some boot option that will the system make more secure. (i am not an it expert)

How do you get there? (aks ChatGPT for a more detailed answer)


in the grub data you look for


and ad ibt=off

at the end it should look like this

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash resume=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx resume_offset=xxxx ibt=off”

save the grub data

than go the command line and write

sudo update-grub

it should update the real grub

restart your computer

everything should work fine

(hope i could help)
(for myself i cant find any option to save my data on my computer, so i hat to start from the bottom :confused: )

best regard from germany

1 Like

maybe open suse will help or the grub menu

(you can get to the grub menu by choosing it on the bootloader - at my system it was just an empty line, but that was the grub menu)

1 Like

no. this is an AMD cpu not a Intel pu

1 Like

can you add on boot kernel
even with USB live manjaro or on screen boot Grub ( Press Esc or F8 to appears )

1 Like


yes you have to

1 Like