Black screen on boot Surface Pro 6

I have followed a couple of the other suggestions in the wiki that say to login to a terminal window and update the packages, and this still did not work. Running startx results in an error, rebooting I come back to the same issue, computer powers on with no display until I hit ctrl alt f3.

Any help is greatly appreciated, otherwise a re-install will be in order…


To help here we need the output of some commands l, since copy pasting would be suboptimal in your situation and posting images is not so usefull please fill in the blanks below.
inxi --graphics


Graphics: Device-1: NVIDIA GM206 [GeForce GTX 950] driver: nvidia v: 455.45.01
Display: x11 server: 1.20.10 driver: nvidia resolution: <missing: xdpyinfo>
OpenGL: renderer: GeForce GTX 950/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01

Device-x: ________ driver: ___________
Display: ________ driver: ___________


> 0000:07:00.0 (0300:10de:1402) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
                  NAME               VERSION          FREEDRIVER           TYPE

After you logged in have you tried :point_down: command and tried to fix something yourself?

journalctl -p 3 -xb

It will display errors from the current boot and might give you clue as to what is wrong.

My apologies, I tried to include information but it would have taken a while to type out the startx error message.

As for the info you are asking for, here we go:

Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: 1.20.10 driver: vesa tty: 171x57

And the following command:

video-linux     2018.05.04     true      PCI
video-modesetting    2020.01.13    true    PCI
video-vesa      2017.03.12     true     PCI

I also ran that final command and it spat out an amount of errors which to me look unrecognizable… I am not super adept in this, this is my first real bad hang up in linux, although I can see it’s mostly kernel errors and some are errors with sddm. Could this mean it has something to do with my x or sddm config files? Sorry if these are stupid questions, I am new to this.

1 Like

Thanks for the info, nicely formatted to :+1:

X & sddm make sure there is a nice graphical shell yes so if they give lots of errors that is indeed a pointer to some driver issues.

What error does the update command give? (what command are you using btw?)
Any chance you can post the error of the startx command?

I am not sure what command you are referring to when you say you want the error from the update command. I am trying to include a link to show my errors as typing them out on mobile will take ages, yet the forum will not allow me to include links or photos, even though I am using the tools at the top to do this. Is there an easy way I can get these errors to you without painstakingly typing them out on mobile?

Excuse me for being vague I was referring to your comment in italics above :point_up:

Have you seen this excellent guide btw:

I guess you reached the graphical target.To narrow down your problem we need at least the xorg logs.

This will collect all xorg logs and upload them:

for x in $(ls /var/log/Xorg*); do echo -e "---$x---\n\n $(cat $x)\n"; done | curl -F'file=@-'

A link will appear. Please post this link here. :wink:

1 Like

Sorry for the late response, it seems to run everything but the curl, I get:

curl: (6) Could not resolve host:

Of course you need a internet connection… otherwise it will not upload.

Try the given command by booting a manjaro boot disk, ensuring you have a internet connection and running manjaro-chroot -a in terminal first.

1 Like

When I went to update packages (with pacman and mhwd), all of the packages seemed to update and re-install fine yet I was still getting black screened on boot, and this is somewhat similar to one of the forum posts I had found but I’ll try some things out and get back to you.
I still cannot post links so I omitted the https://
Apologies for the gaps in response

@cmarland00 no problem… at least you made no stupid space between the link text. :slight_smile:

ok well what i see is this:

[     8.074] (II) VESA: driver for VESA chipsets: vesa
[     8.117] vesa: Refusing to run on UEFI
[     8.117] vesa: Refusing to run on UEFI
[     8.117] (EE) No devices detected.
[     8.117] (EE) 
Fatal server error:
[     8.117] (EE) no screens found(EE) 
[     8.117] (EE) 

and this on the last working Xorg log:

962840.444] (II) LoadModule: "vesa"
[962840.445] (WW) Warning, couldn't open module vesa
[962840.445] (EE) Failed to load module "vesa" (module does not exist, 0)
[962840.445] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[962840.445] (II) intel: Driver for Intel(R) HD Graphics
[962840.445] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[962840.445] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[962840.445] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[962840.853] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20200515
[962840.853] (II) intel(0): SNA compiled from 2.99.917-913-g9236c582
[962840.870] (WW) Falling back to old probe method for modesetting
[962840.871] (--) intel(0): gen9 engineering sample
[962840.871] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[962840.871] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[962840.872] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[962840.872] (==) intel(0): RGB weight 888
[962840.872] (==) intel(0): Default visual is TrueColor
[962840.874] (II) intel(0): Output eDP1 has no monitor section
[962840.874] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[962840.874] (II) intel(0): Enabled output eDP1
[962840.875] (II) intel(0): Output DP1 has no monitor section
[962840.875] (II) intel(0): Enabled output DP1
[962840.875] (II) intel(0): Output HDMI1 has no monitor section
[962840.876] (II) intel(0): Enabled output HDMI1
[962840.876] (II) intel(0): Output DP2 has no monitor section
[962840.876] (II) intel(0): Enabled output DP2
[962840.876] (II) intel(0): Output HDMI2 has no monitor section
[962840.877] (II) intel(0): Enabled output HDMI2
[962840.877] (II) intel(0): Output DP2-1 has no monitor section
[962840.878] (II) intel(0): Enabled output DP2-1
[962840.878] (II) intel(0): Output DP2-2 has no monitor section
[962840.878] (II) intel(0): Enabled output DP2-2
[962840.878] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[962840.879] (II) intel(0): Output VIRTUAL1 has no monitor section
[962840.879] (II) intel(0): Enabled output VIRTUAL1
[962840.879] (--) intel(0): Output eDP1 using initial mode 2736x1824 on pipe 0
[962840.879] (--) intel(0): Output DP2-1 using initial mode 1920x1080 on pipe 1
[962840.879] (--) intel(0): Output DP2-2 using initial mode 1920x1080 on pipe 2
[962840.880] (==) intel(0): TearFree enabled
[962840.880] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[962840.880] (==) intel(0): DPI set to (96, 96)

I guess you installed video-vesa with video-linux together by the mhwd tool. Therefore it loads the vesa driver (in general only basic video output for the terminal) and not the intel driver.

Keep sure you have ONLY installed video-linux.

This shows the installed configs:

mhwd -li

Thank you so much! Currently replying from my machine, I was trying to interpret those logs but it is hard without ever having done it before.