Black screen except for mouse?

Hi all. Having some kind of weird problem with my video… I think. But then again maybe not. I restarted my Manjaro kde computer because it had an issue playing Half Life 2. I was playing hl2 and it crashed. It wouldn’t reopen using the desktop icon that I had for it, so I decided to restart Steam. Steam didn’t seem to want to restart.

When I’m having trouble like this, I find that it often helps to restart the computer. Usually this works fine. But this time, all I get after the motherboard flash screen is a black screen, with the oem KDE mouse. I’ve set it to a different mouse, and a different size too. But I get a tiny mouse that is not the cursor skin I selected. And a black screen that I can’t do anything with. I’m having to use another computer to post this.

Has anyone else had this kind of trouble? I’m using an AMD RX 560 card. If my installation is somehow ruined, I do run timeshyft regularly so I have a backup that I can load. But I need to be able to get to it somehow. Kind of a catch 22.

Edit: I am able to get a command line interface by pressing Ctrl Alt F2. I read that ctrl alt F7 is supposed to load the desktop, but the screen goes completely dark when I try that. No backlight, no mouse, nothing. This makes me think that given the way these problems started, I may be having an issue with the AMD drivers somehow. I will try reinstalling them.

Using the command “mhwd -li” I was able to determine that the driver I’m using is called “video-linux”. It’s “free” and it’s version is “2018-05-04”. That last one sounds like a date, and if it’s that old, maybe that is why I’m having a problem. Need to force and update. Or better start using the real foss AMD drivers that AMD made for that card. Instead of just the stock linux blanket drivers. Sound like a good idea? One would think they’d be better all the way around.

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:+1:

P.S. That output will also clear up this bit of confusion:

GPU Driver: Don’t know, there’s too many confusing names and the whole thing is too convoluted. It’s open source, if that helps

:wink:

Thank you for the reply, but this is a work/production machine so I didn’t have time to figure out the malfunction. So I just copied the home folder and firefox bookmarks and reinstalled. Problem solved

There is one other thing that I found to be kind of odd though…

Timeshift failed. I didn’t start having the issue until 10-25-2020. So naturally, in an attempt to fix the problem I used Timeshift and loaded up 10-24-2020. Still just a black screen with a mouse, and command line access. So to be 100% certain that I wasn’t going to load up the same problem, the next time I used Timeshift, I told it to give me the one from 10-20-2020. Days before I started having this problem.

The problem remained. Timeshift always gave the “Job done” message (however it says it) and asked to reboot, which I did. After you perform that reboot, you assume that the process will be finalized and you’ll load the system snapshot that you selected, and you will have traveled back in time to before the problem started. And then you’ll just not do that bad thing you did. So in my case, I’ll uninstall Half Life 2 and add some more system RAM for watching youtube videos, which has been a problem for me.

Didn’t happen, couldn’t get any help from Timeshift. I’ve always had good luck with that type of method in the past, so I was puzzled as to why it didn’t work this time. Although that was on other operating systems, but still. Should’ve worked.

Read this:

as Timeshift is using warm backups and the above uses cold backups…

1 Like