Black Screen at Boot with blinking cursor - again

My issue of this post (at least the laptop part) repeated itself today: No Boot after update 2022-12-20

This time it happened after a suspend event (laptop lid closed). I rebooted after a while. I saw a kernel module error popping up, followed by a message, that the hardware database was being updated. That happened only at the first boot. After that, the machine went through GRUB, which I could not get to respond to my keyboard. It again went to the blinking cursor. I rebooted two times. Both times it went to the blinking cursor - only the cursor on a black screen. The cursor does not respond to any key presses. A reboot happened suddenly happened about two minutes after I had pressed Ctrl-Alt-Backspace.

Again, the laptop revived itself, this time after only a few minutes. And I got a log! Yay.

This log has another lid-closed event shortly before the end of the log. The computer came back quickly, as it should.

It took the machine about 3 minutes or so until it suddenly continued the boot process to the point where I could log in.

Last time this happened, it took between two and three hours.

Edit: The blinking cursor happened in the few minutes where the log repeats these three lines over and over:

Jan 10 17:55:45 [-computername-] kernel: kauditd_printk_skb: 2 callbacks suppressed
Jan 10 17:55:47 [-computername-] systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jan 10 17:55:50 [-computername-] systemd[1]: lightdm.service: Failed with result 'exit-code'.

There are many errors in the log and I am trying to work through them. Even if there is something not related to my issue, i would be happy to hear about it and possibly how I could make my system healthier :smiley:

@Brahma: We talked about this, last time I couldn’t capture a log. Could you help me again? Thanks!

Jan 10 18:00:58 [-computername-] lightdm[5468]: Could not create user data directory /var/lib/lightdm-data/lightdm: Error creating directory /var/lib/lightdm-data/lightdm: No space left on device

Your hard drive is full.

No. Sadly that’s not it. On the boot partition, there are 173MB, on the system partition 20GB, on the home disk ~12GB of unused space. There are no other partitions (except swap with a size of 20GB).

Would you like to give a different DM a try?

I am thinking about switching to KDE anyway. The weird part is, that it boots fine, now. It just didn’t boot that one time.

Well, and that one time in december. And that one time in october…

Edit: Maybe it is time to do a fresh install. This one is about five years old by now.

Before reinstalling you can try to migrate to SDDM. There are manjaro wiki articles about switching DMs.

… and then you tell us how much is still free where …

all the while the fact remains - and should be addressed:

Jan 10 18:00:58 [-computername-] lightdm[5468]: Could not create user data directory /var/lib/lightdm-data/lightdm: Error creating directory /var/lib/lightdm-data/lightdm: No space left on device

there is no space left on the device

not space available to the user “lightdm” anyway

perhaps there is still space for root - but not for others

Did you know that 5% of space is reserved to root by default on an ext4 filesystem?

How big is your system partition?

That directory is owned by the user lightdm - not the root user
It cannot use root’s reserved capacity.

1 Like

System partition has a size of 120GB. Of those, 20GB are unused. That’s about 16%.

And, no, I did not know that 5% are reserved to root.

I agree that the issue should be addressed. What would you suggest?

not sure - since there seems to be enough space, yet the failure is about there being not enough space
I’d start with a review of some basic information:
inxi -Fazy
lsblk -f

Exactly. Yeah, that did not bring me any further. The NVM’s status is good, space is plenty…

I will look out for applications which might excessively write to my partitions. Weird.

ok - if you wanna solve it on your own, that’s fine
else - share the results :grinning:

without them, there is only speculation - and no one here seriously want’s to engage in that

Nah, I think I will do it on my own.

OK, it has been solved. Probably.

Timeshift was running amok. I really cannot remember having it set up, as it does not make sense on my machine. There was simply no space for snapshots…

It was set up to do hourly a daily snapshot. Location was my home partition. Every hour, regarding to its log, it was starting a snapshot, but there never was enough free space to begin with. So, it looks like it did fill up the free space and then, when running into the obvious, it reverted and cleaned up again, freeing the space up again.

My best guess is, that I rebooted (last time) or suspended (this case) my machine while timeshift had the partition filled up. That at least is my preliminary result.

I cannot remember setting up Timeshift on my machine and really cannot understand why it would run a daily snapshot, but, hey, sometimes we do weird stuff. Maybe I thought I was on my desktop while remote controlling my laptop or so…

Hopefully that’s it, I will return to this if I run into that again. The solution, hopefully, is, to disable Timeshift on a system with low disk space…

Still: I think timeshift should somehow have told me that it did that. And: The blinking cursor/black screen: I do not understand why there was never an issue mentioned anywhere on the screen. A no free space error could have been printed out if there was a cursor visible.

1 Like

Timeshift is a computer program - not an intelligent human being.

Computer programs tend to do what they are expected to do - the user on the other hand is the one in charge of what the computer program does or does not.

You are the one that put the timeshifted snapshot in your home and created an hourly snapshot. They wasn’t of any use - so place you timeshifts on a removable device - this way your root won’t run out of space due to snapshots.


Did I blame anyone? No.

Sorry to say that: […] Redacted.

All that I said was, that timeshift should see that the disk will not have enough space before it fills it up to the brim. And simply not do that. It reverted everything anyway. The disk-full state could simply be avoided. Any program handling larger data quantities should behave like that in my mind.

Might be worth a feature request to the developers of Timeshift.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.