No Boot after update 2022-12-20

I just run the update 2022-12-20 from konsole and everything went fine, no error message. I tried to reboot but after the vendor’s logo (LENOVO) only a black screen shows up. The system has been setup with KDE desktop and Kernel 5.15.84-1.

I switched to Kernel 5.10.160-1 and the system is running.

What should I do?

so if it works on 5.10, maybe the update got interrupted, so rerun the update again:
sudo pacman -Syu
if there are no errors, and you are up to date, reinstall the 5.15 kernel:
sudo pacman -S linux515
if there are no errors, reboot and try booting with the 5.15 kernel

1 Like

Thank you @brahma! Perfect description: I did exactly whta you proposed and the system is fine again with kernel 5.15. Thanks a lot!

Same hapened to me. I will try the update when I find someone to make a bootable USB stick - both may machines are down with this.

@docphees: I dont see a need for a bootable USB stick, unless you don’t have an older kernel on your system. I had the 5.10 which had no issue after the update. Running this kernel, I strictly followed @brahma instructions and everything was fine again.

And how exactly should I have entered anything in a black screen? There was just a black screen. No input possible, no TTY to switch to, no grub to do things.

The really weird thing:

By the way: Witchcraft happened: I let the laptop unattended for about three hours - turned on, ready to do something but children came into the planning… Well. I last saw it about an hour ago, still the same, black screen. Now it showed the graphical log-in. The only difference is that the battery apparently has run down to 20% in between. (Not plugged in for some reason)

I really would like to find out what has happened in between! Any ideas what to look for?

I am on kernel 6.0.14-1, by the way. If anyone will give me some command to run for information I will happily provide that, if not, I probably just won’t find the time these days to dig myself.

(My other machine is still on a black screen.)

This is really, really bad. I’m scared to reboot!

if you didnt rebooted yet, rerun update again:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

if you are up to date and there are no errors, provide output from:
mhwd-kernel -li
mhwd -l -li

[Here was a totally unfair reply which I decided to delete.]


I have tried to connect via ssh. The machine is not booted enough to run the network device. I see the MAC, I cannot ping the machine.

I will have access to a bootable USB drive in half an hour or so, maybe that will allow restoring a Timeshift backup.

no im not, you were saying that after few hours you were able to log in:

and you were asking for commands to run:

Oh, you were talking about the laptop that has been revived. I’m so sorry!

It is just that the laptop is chugging away somehow, my main concern is that wretched desktop.

Sorry, sorry, sorry, sorry. My priorities were mixed up!!!

Edit: Do you think there is some way to find out what happened for three hours?

Edit2: Taking the leap of faith. Laptop has created a good boot USB. Let’s update it!!

did you run timeshift on the laptop?
on the desktop, boot into live usb, connect to internet and chroot:
manjaro-chroot -a
and do this:

you can check logs on the laptop if it was not yet rebooted:
journalctl -b0 -p4 --no-pager

Laptop was rebooted once…

[x] Yay. Laptop works.
[ ] Desktop not so much.

I have booted into a live image, chrooted, reinstalled grub etc. and now I get back to the login screen. After that: Blackness. No way to switch to a TTY (!) but: ssh access. Nice.

OK. Via ssh run the usual update again etc. (screens still black). Rebooted. System hung up. After waiting for while and trying to get access again decided to cycle the power for a reboot. Now I am back to a totally black screen, no login, no network, no TTY, nothing at all.

[x] Desktop works now.

After chrooting I uninstalled all kernels > 5.15 and the machine is fine again (on linux515).

The laptop is a mystery to me, though.

do you have issues with the laptop?

Not yet. I am scared a bit, I rely on that machine. Disk is healthy, RAM has been checked, battery is fine… I really don’t have any idea what happened there.

I have put it through its paces, rebooting, running the battery low, suspending etc. Like nothing happened.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.