Black screen after update on both Gnome and KDE

After updating to 21.2.1 on 2 different laptops, one Gnome and one KDE, both boot to a black screen. I have had this problem before on the KDE laptop and my solution was to switch to the 5.4.x kernel. Unfortunately, that is no longer a solution as the problem now persists with 5.4, 5.10, and 5.14 kernels and is also now affecting both Gnome and KDE.

I’ve read tons of posts, lots of Wiki pages, and have attempted to fix this on the KDE system by reinstalling SDDM, switching to LightDM, and back again to SDDM.

Both systems have nivida and I strongly suspect that’s the culprit.

I’m out of ideas and must ask for help. Thank you.

I might not be the one able to solve the problem, but providing the output of

inxi -Fazy

would be helpful.

Exactly right, I forgot after hitting my head against this for the last several hours :joy:
Here’s the inxi, and this is from after restoring from Timeshift. If I need to re-apply the update that causes the issue then I can fetch this again from TTY.

irish@irish-sager:~$ inxi --full --admin --filter --width 80 --color=0
  Kernel: 5.14.21-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
    root=UUID=c13b38e0-636f-486d-a482-7b4398f5bf63 rw quiet apparmor=1
    security=apparmor resume=UUID=f4c64cf4-9ccb-4798-94fd-3cc66d24e5d7
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Notebook product: N85_N87,HJ,HJ1,HK1 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Notebook model: N85_N87,HJ,HJ1,HK1 serial: <superuser required>
    UEFI: American Megatrends v: 1.05.22RLS1 date: 03/27/2018
  ID-1: BAT0 charge: 28.6 Wh (100.0%) condition: 28.6/59.9 Wh (47.7%)
    volts: 12.7 min: 11.1 model: Notebook BAT type: Li-ion serial: <filter>
    status: Full
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 900 min/max: 800/3800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900
    8: 900 bogomips: 44817
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: CLEVO/KAPOK driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: CLEVO/KAPOK
    driver: nvidia v: 470.86 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1c8c class-ID: 0302
  Device-3: Chicony Chicony USB 2.0 Camera type: USB driver: uvcvideo
    bus-ID: 1-2:3 chip-ID: 04f2:b5a7 class-ID: 0e02
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142
    size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.86 direct render: Yes
  Device-1: Intel CM238 HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Intel
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9
    class-ID: 0403
  Sound Server-1: ALSA v: k5.14.21-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel port: d000 bus-ID: 03:00.1
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0f1 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 04:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-3:4 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 1.16 TiB used: 580.41 GiB (49.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS256G1X0C-00ENX0 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: B35900WD temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 033 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Glide
    size: 14.32 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 206.67 GiB size: 202.36 GiB (97.92%)
    used: 37.38 GiB (18.5%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 2 GiB size: 2 GiB (99.80%) used: 288 KiB (0.0%)
    fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.51 GiB size: 915.89 GiB (98.32%)
    used: 543.03 GiB (59.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 29.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 47.0 C pch: 52.5 C mobo: N/A gpu: nvidia
    temp: 46 C
  Fan Speeds (RPM): N/A
  Processes: 273 Uptime: 30m wakeups: 1 Memory: 15.52 GiB
  used: 3.23 GiB (20.8%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1530 pacman: 1478 lib: 430 flatpak: 45
  snap: 7 Shell: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11```

5.14 is eol. Switch to a supported kernel:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
sudo mhwd-kernel -i linux515

Then reboot into 5.15 (tap Esc during boot to show grub)
Double check your running kernel is not 5.14 then remove it:

uname -r
sudo mhwd-kernel -r linux514
1 Like

Since 5.4 and 5.10 have the issues maybe try 5.15 kernel…
Settings ManagerKernels Install linux515

Tried this exactly but still, black screen. Live booting and restoring from Timeshift again, something in the update is not playing well with me I guess.

I’m running Manjaro 5.10.141quad core Intel ,7 and got a failed password attempt and black screen after reboot. TTY works and I attempted to update and reboot and got a black screen with login page black , and then black after typing password. Tried startx but didn’t do much .must’ve been something in the update … please help