Black screen after logging in

Last time I was on I tried to install

yay -S opencl-amd-polaris

But was unable to due to it conflicting with some amd ROCm

Things I already tried

Searching for solution


yay -R opencl-amd-polaris Its output “error: target not found: opencl-amd-polaris”

inxi -Fxz

 Kernel: 5.10.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
 Desktop: KDE Plasma 5.21.3 Distro: Manjaro Linux base: Arch Linux 
 Type: Desktop System: MSI product: Z1-7641 v: 4.0 serial: <filter> 
 Mobo: MSI model: 760GM-P34(FX) (MS-7641) v: 4.0 serial: <filter> 
 BIOS: American Megatrends v: 17.18B3 date: 03/13/2014 
 Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
 charge: 55% (should be ignored) status: Discharging 
 Info: 8-Core model: AMD FX-8320 bits: 64 type: MCP arch: Bulldozer 
 rev: 0 cache: L2: 2 MiB 
 flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
 bogomips: 56017 
 Speed: 2068 MHz min/max: 1400/3500 MHz boost: enabled 
 Core speeds (MHz): 1: 2068 2: 2119 3: 1399 4: 1394 5: 1400 6: 1399 
 7: 1399 8: 1400 
 Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
 vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 01:00.0 
 Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati 
 unloaded: modesetting,radeon resolution: 1920x1080~60Hz 
 OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 
 5.10.23-1-MANJARO LLVM 11.1.0) 
 v: 4.6 Mesa 20.3.4 direct render: Yes 
 Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI 
 driver: snd_hda_intel v: kernel bus-ID: 00:14.2 
 Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
 vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
 Sound Server-1: ALSA v: k5.10.23-1-MANJARO running: yes 
 Sound Server-2: JACK v: 0.125.0 running: no 
 Sound Server-3: PulseAudio v: 14.2 running: yes 
 Sound Server-4: PipeWire v: 0.3.23 running: no 
 Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
 vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 
 bus-ID: 02:00.0 
 IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
 Device-2: Ralink RT2561/RT61 802.11g PCI vendor: Linksys WMP54G v4.1 
 driver: rt61pci v: 2.3.0 port: e800 bus-ID: 03:02.0 
 IF: wlp3s2 state: down mac: <filter> 
 Local Storage: total: 2.73 TiB used: 26.55 GiB (1.0%) 
 ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB 
 ID-2: /dev/sdb vendor: Toshiba model: DT01ACA200 size: 1.82 TiB 
 ID-1: / size: 907.23 GiB used: 26.55 GiB (2.9%) fs: ext4 
 dev: /dev/sda1 
 ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) 
 dev: /dev/sda2 
 System Temperatures: cpu: 19.8 C mobo: N/A gpu: amdgpu temp: 23.0 C 
 Fan Speeds (RPM): N/A gpu: amdgpu fan: 1296 
 Processes: 236 Uptime: 33m Memory: 15.63 GiB used: 2.29 GiB (14.6%) 
 Init: systemd Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1430 
 Shell: Bash v: 5.1.0 inxi: 3.3.03 ```

I assume you checked these for help…

The problem is not that I cannot login it’s that When I login its just a black screen
I can get access to the terminal and firefox But all my gui and everything is gone it seem like it has nothing to do with the ROCm or opencl

I have the exact same problem. It happened after some update but i don’t know which because i didn’t reboot for a week or so.

Odd This just happened to me today. It was working fine yesterday and the day before

maybe that’s a problem with plasmashell because when i try to launch it through terminal it segfaults. Or is it normal?

Hi all,
Please, read the comments on the AUR package repository in order to find an answer.
AUR (en) - opencl-amd-polaris

You can search in the forum with the words POLARIS10 DRM 3.4.0 in order to find more help.
For example, this post: ‘eGPU issues with external monitor - #28 by pobrn

Hope this help, regards

the thing is, in my case i didn’t do anything with this package and i have the same problem, black screen after logging in, no desktop, no bottom panel. ctrl+alt+t works and brings up my terminal. Animations are working so i suppose that kwin is running. Is that something to do with plasmashell? where can i find the logs to check that?

when i run startx in TTY2 I get: Couldn’t exec startkde: No such file or directory. Not sure if that’s something to do with my problem

I managed to solve the issue! Yay! the problem was with the “eventcalendar” plasma extention. The solution was to delete line: “plugin=org.kde.plasma.eventcalendar” in the ~/.config/plasma-org.kde.plasma.desktop-appletsrc file. I hope this solves your issue too @EmynFuin

Great to hear! I just reinstalled as I was to impatient so sadly i cannot test to see if this will work
form now on I’m going to try to backup with Timeshift

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.