eGPU issues with external monitor

That was expected.

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 35 (RRSetProviderOutputSource)
Value in failed request: 0xb6
Serial number of failed request: 16
Current serial number in output stream: 17

I see. Running xrandr --setprovideroutputsource "Radeon RX 580 Series @ pci:0000:09:00.0" Intel should restore the external monitor. In any case, I suggest you try Wayland.

Interesting. Most of my research made it seem like epgu wouldnt work with wayland

I guess it’s worth a try.

wayland definetly fixed my monitor issue I’ll see what happens now when I run a few games

sorry this took forever but after trying a few games which were still playing very choppily I decided to try shadow of the tomb raider which interestingly enough recognized the amd card but still played super choppy at 30 fps on low and high settings. so now I’m really confused what could be causing this

What’s the output of

glxinfo -B | grep renderer
DRI_PRIME=1 glxinfo -B | grep renderer


Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel® UHD Graphics 620 (KBL GT2)
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Radeon RX 580 Series (POLARIS10, DRM 3.40.0, 5.10.2-2-MANJARO, LLVM 11.0.0)

Are you back on X11? You ran the games with DRI_PRIME=1 right?

still on wayland. guess I could give x11 a try and see what happens

You’ve already tried X, I don’t see why the situation would be different. How did you run the games? With DRI_PRIME=1? Can you rule out other things like CPU, etc. that could result in the lowered performance?

Yeah I check htop while it was running and my cpu was barely running. I also tried with both DRI_PRIME=1 and not with the same result

Can you install intel-gpu-tools, then run sudo intel_gpu_top to check if the games are running on the intel GPU by any chance?

Wait I just thought of something. Isnt there something about thunderbolt being throttled or something in the bios settings?

I have no idea, so I cannot help you with that.

RIP. Well I’ve been trying and failing to capture the output of the Intel gpu test and it’s not really running that high from I can tell

Can you install radeontop from the AUR, and see if that could confirm that the games are indeed running on the AMD GPU?

Okay. Yep it’s running alright and everything is in the 50% except graphics pipe which makes me wonder if the issue that its bottlenecking