Black screen after kernel update

I flashed manjaro kde on to my Pi4 yesterday and switched to unstable branch. I updated everything rebooted and everything was fine. I then installed kernel 5.12rc and rc-header 5.12. After rebooting I went straight to black screen and no tty, did I miss something? Do I have to update the bootloader or anything else when switching to the rc kernel? Tried Google but couldn’t find anything . I’m running the pi on microsd no other modifications apart from switching to unstable. I just reflashed the sd card while it was a fresh install but would like to know if I missed anything

Yeah it’s weird bug. I’ve got pi4 and having the back screen.

Anyway to get out of it without reflashing the sd card? Never messed with the pi before, I’ve installed timeshift and made a backup now. Can you .ssh into it or boot from a USB drive to restore a backup?

I tried the factory reset image. (in the raspberry pi image writer) It only worked of one or two updates.

If you updated everything in the unstable branch then the bootloader packages would have upgraded to the latest. I do not use kde but had no issue here on the stable branch with the latest kernel 5.12 with xfce. I know @0n0w1c uses kde and tested the latest 5.12 kernel and he usually uses the stable branch.

1 Like

Thanks for the reply. So when upgrading kernels its just the 2 packages to install, the kernel and the headers? I’ve never used arm before so wasn’t 100%sure on the differences.

Excellent work BTW, really impressed with what you’ve done to the pi

You should always do a system update, since some changes in some packages, might depend on certain changes in another package.

You should be up to date with all packages if you did what you said. I am not a fan of kde so I rarely install it. Seems like lately though there has been some issues with plasma and video. Usually the black screen has to do with the video not getting properly loaded when it tries to go in graphics mode.

1 Like

I am burning a new plasma SD now. I will try to recreate the black screen issue and find a solution if I can recreate the issue.

1 Like
  1. I installed 21.04 to a SD card.
  2. On 2 subsequent reboots, I logged in with 4K monitor, plasmashell crashed - seg faults with a code of 11.
  3. Still usable, so I then upgraded to arm-unstable (no kernel upgrade yet)
  4. On reboot, after sddm login, a black screen with a mouse pointer.
  5. I switched tty and peeked at Xorg.0.log, modeset error: Failed to make 3840x2160x32bpp GBM bo
  6. I then shutdown and switched to a 1080p monitor, no modeset error on reboot.
  7. I then upgraded the kernel to RC, no change noticed at 1080p.

So my guess is they are hitting an EDID issue.

Help you with what?

This is the manjaro arm fourms.

Please make your own thread regarding this.

  1. This thread is about “Black screen after kernel update”, whereas your issue is nothing related to that
  2. This is an ARM thread, and you aren’t using an ARM CPU

Please remember to always put ``` before and after your output OR highlight your output and click on the </> button.

Edit: Actually noticed that you already have a thread… don’t piggy back on other unrelated threads please


I’ve just downloaded xfce so I’ll put that on a different sd card and recreate my steps I took with that. Anything at all I can do to help please just ping me

@sawdoctor I also downloaded the latest kde image and upgrade on the unstable branch. I have always had to specify my Vizio tv monitor setting as it does not provide the correct EDID info needed or I get a black screen. Everything went smooth here.

I do not have a higher resolution monitor to test with but I do tend to agree with @0n0w1c assessment that your monitor is not properly providing the correct EDID info. Upstream is constantly changing things and the RPi folks are constantly trying to change their tree to keep up. You have to remember the -rc kernel is going to have issues that have to be straightend out from time to time.

If your monitor is capable of 1080p put this in your /boot/config.txt and reboot and test.

1 Like

Thanks. It was just a tv (1080p) I had it plugged into. The main reason for my post was just to double check I’d done everything correctly installing the 2 kernel packages (didn’t think there would be anything else)