Black screen after choose manjaro in GRUB

Hi community, today i have started my day with a problem.
I’m using Manjaro and Windows (GRUB). This week I updated stuff and all was OK.
Even yesterday I have used the computer without having problems but today when I choosed Manjaro on GRUB, showed me black screen and nothing more.

I restarted. Then i choosed “Advanced Options” --> SAME KERNEL but fallback initramfs and worked perfectly!

I restarted again, i tried with the “normal option” and i had the same problem, black screen.

  • Manjaro Linux ( Kernel: 5.4.77-1-MANJARO X64) SHOW BLACK SCREEN
  • Manjaro Linux ( Kernel: 5.4.77-1-MANJARO X64 - fallback initramfs) WORKS PERFECTLY

(Sorry i don’t know why i can’t upload images)

How can i solved my problem and start manjaro with the “normal option” like before?

THANKS FOR READ!!

then check in journal log what wrong

sudo journalctl -b -1 ( can be -2 , etc..) 
sudo journalctl -b0   ( boot with fallback )

Thanks for your reply.
The first command show this:

The second command show this:

Can you help me to fix? I don’t understand nothing :frowning:

New updates to Manjaro, Kernel 5.4.78-1 have appeared to me and that has solved the problem luckily.
Thank you all!

trouble on conf /etc/pam.d
check this point

Thanks @stephane for your solution.
I thinked that i solved the problem but i was wrong.
I continue enter to my system with fallback initramfs

I read this:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

but i don’t understand the last step.
Can you help me, step by step to solve the problem?

THanks!

can you returns

inxi -Fza --no-host

sudo cat /etc/pam.d/system-login
 diego@diego-pc  ~  inxi -Fza --no-host
System:    Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=f79998ef-e959-4629-ad0d-371340de1ba3 rw quiet 
           resume=UUID=7bd1055a-b8e3-437b-a6c7-8b6250281ccf 
           Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X556UJ v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X556UJ v: 1.0 serial: <filter> UEFI: American Megatrends v: X556UJ.403 date: 04/13/2016 
Battery:   ID-1: BAT0 charge: 27.4 Wh condition: 28.7/38.0 Wh (75%) volts: 7.6/7.6 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: N/A status: Not charging cycles: 499 
CPU:       Info: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake family: 6 model-id: 4E (78) 
           stepping: 3 microcode: 74 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20810 
           Speed: 2400 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 2400 2: 2400 3: 2400 4: 2400 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:1916 
           Device-2: NVIDIA GK208BM [GeForce 920M] driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 
           chip ID: 10de:1299 
           Device-3: Realtek USB Camera type: USB driver: uvcvideo bus ID: 1-6:4 chip ID: 0bda:57b5 serial: <filter> 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus ID: 00:1f.3 chip ID: 8086:9d70 
           Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
           Sound Server: ALSA v: k5.4.80-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI 
           modules: r8169 port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave driver: ath9k v: kernel 
           port: d000 bus ID: 03:00.0 chip ID: 168c:0036 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.52 GiB used: 440.38 GiB (47.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 023 scheme: GPT 
           ID-2: /dev/sdb vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 3J scheme: GPT 
Partition: ID-1: / raw size: 40.00 GiB size: 39.12 GiB (97.81%) used: 32.83 GiB (83.9%) fs: ext4 dev: /dev/sda5 
           ID-2: /home raw size: 157.95 GiB size: 154.47 GiB (97.80%) used: 96.28 GiB (62.3%) fs: ext4 dev: /dev/sda6 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2600 
Info:      Processes: 204 Uptime: 8h 56m Memory: 11.57 GiB used: 2.50 GiB (21.6%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1454 lib: 386 flatpak: 0 Shell: Zsh v: 5.8 running in: konsole inxi: 3.1.08 



 diego@diego-pc  ~  sudo cat /etc/pam.d/system-login
[sudo] password for diego: 
#%PAM-1.0

auth       required   pam_shells.so
auth       requisite  pam_nologin.so
auth       include    system-auth

account    required   pam_access.so
account    required   pam_nologin.so
account    include    system-auth

password   include    system-auth

session    optional   pam_loginuid.so
session    optional   pam_keyinit.so       force revoke
session    include    system-auth
session    optional   pam_motd.so          motd=/etc/motd
session    optional   pam_mail.so          dir=/var/spool/mail standard quiet
-session   optional   pam_systemd.so
session    required   pam_env.so           user_readenv=1

Thanks again! =)