Avahi disabled by default, is it intentional?

Recently, I had to reinstall Manjaro because of failing hardware (old SSD and hard drive). I did a fresh install of Manjaro KDE and I was wondering why it asked for elevated privileges when I was launching Simple Scan (an application for scanning documents).

After doing some research (thanks for this forum thread for giving me the clue I needed: Remove prompting for user password when scanning? [SOLVED] / Pacman & Package Upgrade Issues / Arch Linux Forums), I noticed that it was actually trying to start the Avahi daemon. I was surprised by that because I thought it was a given and as far as I know, it used to be enabled by default.

I was wondering if it was intentional or if it is actually just a bug/an oversight, as I didn’t find any official statement on that matter. For people who wonders what Avahi is, it is a piece of software that is more or less equivalent to Bonjour from Apple and that allows service discovery on the LAN; it is notably used by many consumer printers to be able to be used over the network with much more ease.

I am in favor of keeping it enabled by default, but I just want to know if it is disabled by choice or by mistake.

FWIW on two still mostly vanilla and new-ish Manjaro XFCE installs here Avahi is installed and enabled by default.

Interesting, I admit I haven’t checked the other editions. I’ll download the XFCE edition and check it out in a VM later.

There is probably a difference between the minimal editions and the full editions in regard to what services are started by default and which ones are not.

In addition to that, we’ve got just as many members here who hate avahi as members who like it, so apart from any potential differences in configuration between the minimal and full install images — I personally wouldn’t know about that, but it stands to reason — we can never win, because somebody somewhere is always going to throw a hissy fit over the fact that something’s either enabled or disabled by default.

Note that I’m not saying that you’re throwing a hissy fit — on the contrary, you are being very civilized :+1: — but you should see some of the reactions we get from time to time from some of our forum members. :roll_eyes:

Oh yeah, I haven’t specified it, but I used the full ISO image, not the minimal one. I embraced the bloat to the fullest (lol).

I would have made sense for the minimal one I guess, but for the full one, I am more skeptical.

The ISO image I use is actually manjaro-kde-21.3.7-220816-linux515.iso, which was the current one when I downloaded it a few days ago.

No matter what you put by default, there will be people that complains that it either missing something, or that it is bloat and should be removed, or that it should be instead replaced by something else, etc. etc. You will never win on that debate.

Though I would agree that Avahi should be on by default (at least for the full one that is aimed to get a relatively complete system out of the box; by choosing the minimal ISO, you kinda implicitly agree not to have everything in the first place), it maybe got turned off by default by accident, so it would be more a bug to fix than anything else.

1 Like

No fscking use for it whatsoever. If I wasn’t able to mask it, I’d set up a 5 sec timer to continuously kill it.

1 Like

Alright, so I quickly checked in a VM on Manjaro XFCE (with the full ISO you can download at the moment) and indeed, Avahi is enabled by default on this one.

So, hum, oops I guess?

EDIT: Looking at the profiles: for the KDE edition, for some reason, Avahi daemon is explicitly disabled.

# unset defaults to given values
# names must match systemd service names
enable_systemd=('bluetooth' 'cronie' 'ModemManager' 'NetworkManager' 'cups' 'tlp' 'haveged' 'fstrim.timer' 'pkgfile-update.timer')
disable_systemd=('avahi-daemon' 'pacman-init')

It isn’t the case for XFCE and GNOME.

Why? I dunno. I opened an issue on the Gitlab to get it at least consistent.

@Aragorn I guess this thread can be closed now, as I conclude now that it is more a bug to fix than a feature request at that point.

Wow really? Now that it is known to conflict with power profiles daemon, which integrates well to both Gnome and Plasma, tlp still present in Manjaro ISOs?
Sorry for hijacking the thread :slight_smile:

1 Like

Pinging @LordTermor to review this when he has time.

To be honest, because I’m a systemd-resolved and systemd-networkd user, I now even want to remove the Avahi package when installing the OS, I have absolutely no idea what else this thing is for, after all, I use mDNS.:sweat:

It’s required by other system packages, like geoclue and pipewire-pulse/pipewire-zeroconf.

I like pipewire, but I don’t like his dependence on Avahi.:sweat:

No, it was dropped awhile ago. I removed it from enabled services on KDE, apparently it was overlooked.

Back to the point, since systemd-resolved is not out of the box, while it is possible to claim the native mDNS support that systemd-resolved brings, I think manjaro still needs out-of-the-box mDNS support, whether brought by Avahi or not.

I noticed something that might be interesting and an explanation why avahi is disabled in KDE:

Once I enabled avahi/acpid according to the Arch linux wiki (cannot post the link here), I got a significantly longer list of found printers in the network. But I got a severe issue with the KDE “systemsettings” tool: It simply stopped working. The icon itself appeared for a brief moment - then the tool died without error message.

After I disabled the services again the reggression disappeared.

Something’s wrong on your side, I have avahi enabled for years and Systemsettings works as always. Launch it from terminal to see what error is raised.

I have /etc/systemd/system/avahi-daemon.service.d/override.conf with the following content though:


same problem here. I switched to KDE yesterday and installed with manjaro-kde-22.1.0-230421-linux61.iso.I was a bit confused why my Brother HL-L5100DN would not install. This worked perfectly under Manjaro Cinnamon.

With “systemctl enable avahi-daemon” and “systemctl start avahi-daemon” I was able to activate avahi and the printer installation went perfectly.

It’s no longer disabled on the KDE ISO profile.