Authorization supplicant timed out error

I get this error a few times a day : “Authorization supplicant timed out”. When it happens, the wifi gets disconnected for a few seconds and then reconnects. Any help is appreciated.
Here’s some relevant info:

inxi -Fazy

  Kernel: 5.14.0-0-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=fe64fafd-1c2a-4b55-846f-c264196ff166 rw nomce "acpi_osi=Windows 
  2018" quiet resume=UUID=4517ac81-4ac6-42a0-8e7a-a5870b5f98df 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 83CE v: 59.38 serial: <filter> UEFI: Insyde v: F.31 
  date: 10/30/2017 
  ID-1: BAT1 charge: 40.5 Wh (95.7%) condition: 42.3/42.3 Wh (100.0%) 
  volts: 13.2 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Charging 
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: EA cache: L2: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 32012 
  Speed: 800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Hewlett-Packard 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:134d class-ID: 0302 
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus-ID: 1-5:4 chip-ID: 04f2:b5d6 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 115 s-size: 424x238mm (16.7x9.4") 
  s-diag: 486mm (19.1") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.14.0-0-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.049.02-NAPI modules: r8169 
  port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IF-ID-1: br-ab1ab553cc42 state: up speed: 10000 Mbps duplex: unknown 
  mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
  IF-ID-3: veth045cfdd state: up speed: 10000 Mbps duplex: full mac: <filter> 
  IF-ID-4: veth7a32a3c state: up speed: 10000 Mbps duplex: full mac: <filter> 
  IF-ID-5: veth8534e91 state: up speed: 10000 Mbps duplex: full mac: <filter> 
  IF-ID-6: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-4:3 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends 
  Local Storage: total: 1.03 TiB used: 666.14 GiB (63.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: RSM7 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SD8SN8U-128G-1006 
  size: 119.24 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 0006 scheme: GPT 
  ID-1: / raw-size: 50 GiB size: 48.72 GiB (97.43%) used: 33.25 GiB (68.3%) 
  fs: ext4 dev: /dev/sdb5 maj-min: 8:21 
  ID-2: /boot/efi raw-size: 277 MiB size: 276.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 
  ID-3: /home raw-size: 56.97 GiB size: 55.83 GiB (97.99%) 
  used: 34.78 GiB (62.3%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 
  Kernel: swappiness: 1 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 12 GiB used: 1.5 GiB (12.5%) priority: -2 
  dev: /dev/sdb3 maj-min: 8:19 
  System Temperatures: cpu: 38.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 334 Uptime: 19h 35m wakeups: 8 Memory: 7.69 GiB 
  used: 4.03 GiB (52.4%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 clang: 12.0.1 Packages: 1995 pacman: 1988 lib: 439 flatpak: 1 
  snap: 6 Shell: fish v: 3.3.1 running-in: tmux: inxi: 3.3.06 

journalctl -xe -n 1000

tail -n +1 /etc/NetworkManager/conf.d/*

==> /etc/NetworkManager/conf.d/10-default-wifi-powersave-on.conf <==
wifi.powersave = 2

==> /etc/NetworkManager/conf.d/20-connectivity.conf <==

==> /etc/NetworkManager/conf.d/wgpia.conf <==

EDIT: It’s worth pointing out that this doesn’t happen in all networks. For example, my university network works just fine. At first I suspected that it was a new router that I bought. But I’ve replaced that router with a different one, the problem still persists. Also, this only started happening after I moved from India to US, so it might be worth considering if it’s some standards or locale issue.

Have you tried an LTS kernel yet?


Yep, tried it on 5.10 and 5.4
Same error.

Disable IPV6 on the router and try again.


It’s already off. I even set IPv6 to Ignore in Manjaro settings. But to no avail.

1 Like

Does this also happen when you down the (I suppose) bridge?

And what are these?


1 Like

wgpia0 is the interface set up by PIA VPN. IDK about the others. Also, I’m not sure what you mean by “bridge”.

If you don’t know your own configuration, I’m sorry, but then I cannot help you any further, but from the naming convention I guessed you have:

and I don’t know where those come from and they’re “up” so that’s why I was asking.

Did this problem start after you installed


1 Like

PIA VPN has been there for a while. It didn’t start the problem.

Is there a way to find out where those come from, so that I can disable them if unneeded? (It’s a bit hard to remember how I set something up a year ago.) Is there a way to kind of reset everything related to networking?

You might be on to something, check this out:

1 Like

This didn’t work either. I’m still facing the issue once/twice a day. Weirdly, the issue doesn’t happen for a few hours, and then happens repeatedly 4-5 times or more. Most of the time, systemctl restart NetworkManager fixes it temporarily, but not always.

The latest update (17/09) seems to have fixed the issue somehow.

EDIT : Spoke too soon. It’s back. But the frequency is somewhat lower than before.

EDIT2 : I had set my SSIDs to be hidden (stupid, I know). After setting them up as visiblen, the problem no longer happens. Sure, this shouldn’t have happened even then since my Android devices worked just fine, not to mention that I had hidden SSIDs back in India as well. But hey, at least it’s fixed now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.