"Authentication required by Wi-FI network" Manjaro I3, Archer T4U, rtl88x2bu drivers

Background information: yesterday i finally decided to give Manjaro a try after some time using Ubuntu 20.04 LTS. I went to the website and downloaded the version with the I3wm ( Manjaro - I3 , i think i downloaded the minimal install). Installed perfectly fine, until i tried putting my Archer T4U Wi-Fi usb adapter in, which may i add, worked as normal in Ubuntu 20.04 LTS after doing a dkms install on the drivers.

After the fresh install finished i went to get the drivers for my wireless adaptor. I got them here: GitHub - cilynx/rtl88x2bu: rtl88x2bu driver updated for current kernels. . They seemed to have installed as normal, i haven’t recognized any error messages during the installation and the device is recognized by the system, however when i try connecting to my Wi-Fi i get an error. The system keeps asking for authentication, picture below. I give the password for the network, but it doesn’t matter, the same “Authentication required by Wi-FI network” window keeps popping up and the internet doesn’t finish connecting.

[I had an image of the window here, however it seems i cannot post images in the forum, i hope my description was sufficient.]

I tried changing usb ports, reinstalling the system again, but nothing worked. My best guess is that it has something to do with the Kernel, i am still a new Linux user, i cannot give reasoning to my guess, but that is what i would bet after the online research i did.

Since this is a fresh install, i will give every single command i have run on this machine since i have installed Manjaro.

Before installing the drivers

sudo pacman -Syu
sudo pacman -S dkms base-devel linux510-headers firefox

I then cloned the git page of the drivers and followed the instructions for the dkms install

cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu

More information:
dkms status

rtl88x2bu, 5.6.1, 5.10.59-1-MANJARO, x86_64: installed

uname -r


pacman -Q | grep headers

linux-api-headers 5.12.3-1
linux510-headers 5.10.59-1

I hope this was enough information, please help me. I really wanted to use Manjaro, but not getting my Wi-Fi usb adaptor to work with it would instantly make the distro unusable for me.

:+1: Welcome to Manjaro! :+1:

Please read this:

especially the “How to install software” section as Manjaro has something called “The AUR” which is like “All of the PPA’s in the world in one big PPA”…

If the above still doesn’t work,

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.