AUR database sync error

I’m getting an error whenever I try to refresh databases in the add/remove software utility in Manjaro.

“Failed to synchronise AUR database”

Does anyone know what is causing this and maybe how to fix it?

Also, how would one include a screenshot? I’m new here and apparently you can’t embed images in a post.

2 Likes

Try deleting the database lock file:

sudo rm /var/lib/pacman/db.lck
1 Like

I gave it a try, but the file apparently didn’t exist. Something else is wrong then I guess

still nothing, but I was hopeful for a few moments then, lol
Also, might just be me, but paste.pics didn’t work when I tried it for whatever reason.

Could the AUR database be down? or maybe this is a Manjaro Cinnamon specific issue? As that is the version of Manjaro I’m using

Hello im getting same error…i tryed many things but nothing. May be database offline?

Hello the database was offline.
I try now and it is all ok…problem is solved.
Regards.

Thanks for the info. I tried it and it works for me as well now :wink:

Hi, I have this same issue. It hasn’t been fixed.

What’s more, when I try to download something with Pamac from the AUR, it fails. But if I run it in Konsole (not on the Add/Remove Software GUI) it works.

pacman-mirrors has nothing to do with AUR, why all people are suggesting sudo pacman-mirrors -f 5

Give relevant information then so people wouldn’t rely on their crystal ball to make guesses.

“It fails” what does that mean, is there an error message? What is the console output in the GUI (click the icon at bottom right corner when building an AUR package)?
What do you run in Konsole? what is the exact output of what you run in Konsole?

Also if you can not download this file from the computer https://aur.archlinux.org/packages-meta-ext-v1.json.gz the AUR database download can not work, fix it first if you can not download this file manually, as Pamac will also probably not be able to.

1 Like

It fails: I think it says “failed to build package” or something like that.

But if I try to install using sudo pamac install it works.

Is there any issues on Issues · Applications / pamac · GitLab related to this?

Do you want me to check? :face_with_raised_eyebrow: