Audio unreliable since Nvidia kernel updates

I teach for a living and with the amount of virtual learning we must do, I need to reliably be able to use my microphone and tablet.

Since the most recent update when I did a fresh install of Manjaro with Kernel 5.9.16 I have had two consistent issues, one minor annoyance and one that caused me to have to cancel class this morning.

The first is the failure of lightdm to run upon startup. I use the TTY workaround to start with sudo lightdm after getting to TTY on login – annoying to have to do every time imo (more so because I have a 40% form factor keyboard so I have to keep a spare around to enter TTY, my own issues) but not the worst.

However, I noticed that about 50% of the time on boot my audio doesn’t work at all. I’m not sure what the equivalent command is here, but I’m sure it’s there. I tried rebooting 3 times this morning in the middle of a lecture, and not once was I successful in booting into an environment where the audio works as expected. What can I do to resolve this? Normally I think it’s user error since I lack knowledge and sophistication w/r/t Manjaro, but this feels like something that shouldn’t be so unreliable on a stable kernel? What am I doing wrong?

Here is my inxi -f

CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP L2 cache: 3 MiB 
           Speed: 4157 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 4157 2: 2773 
           3: 2200 4: 2200 5: 2075 6: 2200 7: 2200 8: 2200 9: 4150 10: 2770 11: 2079 
           12: 2200 
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 
           bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy constant_tsc 
           cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc cr8_legacy cx16 
           cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr 
           fxsr_opt ht hw_pstate ibpb ibs irperf lahf_lm lbrv lm mba mca mce misalignsse 
           mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw 
           overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc 
           perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a 
           rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 
           sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc tsc_scale 
           umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave 
           xsavec xsaveerptr xsaveopt xsaves ```

about 50% of the time on boot my audio doesn’t work at all

Is this system dual-booting with a Windows OS?
If it is, check that the ‘Fast Startup’ feature is turned off in Windows
see this previous post for more information - Sound from speakers no sound from 3.5mm jack-audio (AMD ThinkPad E595) - #6 by nikgnomic

I suggest you use manjaro-settings-manager -m msm_kernel to install kernel v5.10
Kernel v5.9 is now End Of Life, and later kernel may support Ryzen system audio better

Please post system information:

ìnxi -Faz

and ALSA information

sudo --upload

If you can get ALSA data for both working and non-working audio states it may be possible to find differences in the data

Here is my inxi -Faz

           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
           root=UUID=88ec38db-9f99-4ff1-8f7a-41b7f1ec6589 ro quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel, plank wm: xfwm4 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7B85 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) v: 1.0 
           serial: <filter> UEFI: American Megatrends v: 1.B0 date: 11/08/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
           family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
           L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
           bogomips: 86435 
           Speed: 1979 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
           1: 1979 2: 1869 3: 2198 4: 2199 5: 2680 6: 2208 7: 2068 8: 2139 9: 1920 
           10: 2055 11: 3569 12: 2506 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Micro-Star MSI 
           driver: nouveau v: kernel bus ID: 26:00.0 chip ID: 10de:1f06 
           Display: x11 server: X.Org 1.20.10 driver: modesetting,nouveau 
           alternate: fbdev,nv,vesa display ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") 
           s-diag: 1245mm (49") 
           Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
           diag: 604mm (23.8") 
           Monitor-2: DP-3 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") 
           diag: 685mm (27") 
           OpenGL: renderer: NV166 v: 4.3 Mesa 20.3.1 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus ID: 26:00.1 chip ID: 10de:10f9 
           Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus ID: 28:00.4 chip ID: 1022:1487 
           Device-3: Microdia Webcam Vitade AF type: USB driver: snd-usb-audio,uvcvideo 
           bus ID: 1-4:4 chip ID: 0c45:6366 serial: <filter> 
           Device-4: Blue Microphones Yeti Stereo Microphone type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2:2 chip ID: b58e:9e84 
           serial: <filter> 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus ID: 21:00.0 
           chip ID: 8086:2526 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb 
           v: kernel port: f000 bus ID: 22:00.0 chip ID: 8086:1539 
           IF: enp34s0 state: down mac: <filter> 
           Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
           bus ID: 5-4:4 chip ID: 8087:0025 
Drives:    Local Storage: total: 465.76 GiB used: 51.18 GiB (11.0%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB 
           size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> rev: 2B2QEXE7 temp: 27.9 C 
Partition: ID-1: / raw size: 20 GiB size: 19.56 GiB (97.81%) used: 12.37 GiB (63.2%) 
           fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 
           ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 25.2 MiB (26.2%) 
           fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-3: /home raw size: 236.29 GiB size: 231.58 GiB (98.01%) 
           used: 38.78 GiB (16.7%) fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2 
           dev: /dev/nvme0n1p6 maj-min: 259:6 
Sensors:   System Temperatures: cpu: 45.5 C mobo: N/A gpu: nouveau temp: 22.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 927 
Info:      Processes: 313 Uptime: 10m wakeups: 4 Memory: 15.64 GiB used: 2.25 GiB (14.4%) 
           Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1221 lib: 402 
           flatpak: 0 Shell: Bash v: 5.1.0 running in: xfce4-terminal inxi: 3.2.01

And the ALSA information:

Uploading information to ... Done!

Your ALSA information is located at
Please inform the person helping you.

I am dual booting but I am 95% sure the Fast Startup is disabled as I followed the dual booting tutorial and recall that step. I will check later today on next reboot though, thank you!

I am trying to update my kernel and when I go to the Kernel manager in Manjaro Settings Manager I get the following combination of error/100%:


and when I run mhwd-kernel -li it definitely seems to have failed:

mhwd-kernel -li
Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
   * linux59

How can I try and run a kernel update from the command line? Or is there a reason why I’m unable to install the latest kernel via the system manager gui?

I can confirm that fast startup is disabled, here is a screenshot from Windows:

screenshot of Manjaro Settings Manager is showing - Install Linux 5.10.2-2
[Stable Update] 2021-01-19 included kernel 5.10.7-3

You need to update system before installing kernel

sudo pacman -Syyu

Reboot system to load updated packages

And then install kernel:

mhwd-kernel -i linux510

ALSA data looks OK, all input and output jacks appear to be detected and working

suggest you check if PulseAudio is working and detecting audio devices

systemctl --user -l --no-pager status pulseaudio
pacmd list-cards

here’s the result of the systemctl

Failed to get properties: Process org.freedesktop.systemd1 exited with status 1


No PulseAudio daemon running, or not running as session daemon.

I ended up using this solution from Fabby

still need to update my kernel so maybe that would resolve the issue as well and I can remove this script from my startup processes. How should I resolve this thread? The solution was from another thread so I can’t mark it here

1 Like

Also, on running sudo yay -Syyu it terminated with an option to update AUR packages. I thought I indicated to update them all but it turns out not?

:: Searching databases for updates...
:: Searching AUR for updates...
 -> Missing AUR Packages:  orage
:: 3 Packages to upgrade.
3  aur/google-chrome            87.0.4280.141-1 -> 88.0.4324.96-1
2  aur/rstudio-desktop-bin      1.3.1093-1      -> 1.4.1103-1
1  aur/signal-desktop-beta-bin  1.39.5beta.1-1  -> 1.39.6beta.1-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
refusing to install AUR packages as root, aborting

How can I update these? The rstudio-desktop-bin in particular because that is very buggy recently

I do not use signal, rstudio, google-chrome or yay so I can’t comment about any of that

I suggest you use 'pacman -Syyu` to make sure the repository packages are up to date so you can install install kernel 5.10.7-3

1 Like