Audio not working

Hello there,

I just recently installed Manjaro and it seems that my audio is not working. It detects the soundcard and knows which type of soundcard it is but I can’t get this fixed.

Audio: Device-1: Intel CM238 HD Audio driver: snd_hda_intel
cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH

Welcome to Manjaro

Please post more information about your system

inxi -Fazy

and this to show if any audio outputs or inputs are detected and configured correctly in PulseAudio

pacmd dump

and this to show ALSA settings for audio devices

amixer --card=0
2 Likes

I would like to add that when I execute alsamixer and select my card there are several unmute S/PDIF boxes (five of them) also I have my master volume unmute.

> [yuto@yutoLAP ~]$ inxi -Fazy     
> System:
>   Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
>   parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
>   root=UUID=7ac2e9a7-d849-4ff5-8701-7278fde029ba rw quiet apparmor=1 
>   security=apparmor udev.log_priority=3 
>   Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
>   dm: SDDM Distro: Manjaro Linux base: Arch Linux 
> Machine:
>   Type: Laptop System: CHUWIInnovationAnd(ShenZhen) product: GemiBook Pro 
>   v: N/A serial: <filter> 
>   Mobo: N/A model: N/A serial: <filter> UEFI: American Megatrends 
>   v: JXX-BI-14.1-W133GWR300-058-D date: 03/12/2021 
> Battery:
>   ID-1: BAT0 charge: 31.5 Wh (82.9%) condition: 38.0/38.0 Wh (100.0%) 
>   volts: 8.1 min: N/A model: N/A type: Unknown serial: <filter> 
>   status: Discharging 
> CPU:
>   Info: Quad Core model: Intel Celeron J4115 bits: 64 type: MCP 
>   arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 1 microcode: 36 
>   cache: L2: 4 MiB 
>   flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 14288 
>   Speed: 2377 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 2377 2: 2370 
>   3: 2376 4: 2394 
>   Vulnerabilities: Type: itlb_multihit status: Not affected 
>   Type: l1tf status: Not affected 
>   Type: mds status: Not affected 
>   Type: meltdown mitigation: PTI 
>   Type: spec_store_bypass 
>   mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>   Type: spectre_v1 
>   mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>   Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
>   Type: srbds status: Not affected 
>   Type: tsx_async_abort status: Not affected 
> Graphics:
>   Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel 
>   bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300 
>   Device-2: Microdia Webcam Vitade AF type: USB driver: uvcvideo bus-ID: 1-8:4 
>   chip-ID: 0c45:6366 class-ID: 0e02 serial: <filter> 
>   Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
>   loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0 
>   screens: 1 
>   Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.5x15.0") 
>   s-diag: 686mm (27") 
>   Monitor-1: eDP1 res: 2160x1440 hz: 60 dpi: 196 size: 280x180mm (11.0x7.1") 
>   diag: 333mm (13.1") 
>   OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 21.1.5 
>   direct render: Yes 
> Audio:
>   Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio 
>   driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
>   bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0401 
>   Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
>   Sound Server-2: JACK v: 1.9.19 running: no 
>   Sound Server-3: PulseAudio v: 14.2 running: yes 
>   Sound Server-4: PipeWire v: 0.3.32 running: no 
> Network:
>   Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel 
>   port: f000 bus-ID: 00:0c.0 chip-ID: 8086:31dc class-ID: 0280 
>   IF: wlo2 state: up mac: <filter> 
> Bluetooth:
>   Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
>   driver: btusb v: 0.8 bus-ID: 1-9:5 chip-ID: 8087:0aaa class-ID: e001 
>   Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
>   rfk-block: hardware: no software: yes address: see --recommends 
> Drives:
>   Local Storage: total: 238.47 GiB used: 12.3 GiB (5.2%) 
>   SMART Message: Unable to run smartctl. Root privileges required. 
>   ID-1: /dev/sda maj-min: 8:0 vendor: Netac model: SSD 256GB size: 238.47 GiB 
>   block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD 
>   serial: <filter> rev: 0A0 scheme: GPT 
> Partition:
>   ID-1: / raw-size: 107.42 GiB size: 105.18 GiB (97.91%) 
>   used: 12.24 GiB (11.6%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 
>   ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
>   used: 68.9 MiB (71.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
> Swap:
>   Alert: No swap data was found. 
> Sensors:
>   System Temperatures: cpu: 45.0 C mobo: N/A 
>   Fan Speeds (RPM): N/A 
> Info:
>   Processes: 207 Uptime: 3m wakeups: 1 Memory: 11.51 GiB 
>   used: 3.01 GiB (26.1%) Init: systemd v: 248 tool: systemctl Compilers: 
>   gcc: 11.1.0 Packages: 1226 pacman: 1223 lib: 328 flatpak: 0 snap: 3 
>   Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06
> [yuto@yutoLAP ~]$ pacmd dump
> ### Configuration dump generated at Tue Aug  3 17:34:58 2021
> 
> load-module module-device-restore
> load-module module-stream-restore
> load-module module-card-restore
> load-module module-augment-properties
> load-module module-switch-on-port-available
> load-module module-udev-detect
> load-module module-jackdbus-detect channels=2
> load-module module-bluetooth-policy
> load-module module-bluetooth-discover
> load-module module-bluez5-discover
> load-module module-dbus-protocol
> load-module module-native-protocol-unix
> load-module module-gsettings
> load-module module-default-device-restore
> load-module module-always-sink
> load-module module-null-sink sink_name=auto_null sink_properties='device.description="Dummy Output"'
> load-module module-intended-roles
> load-module module-suspend-on-idle
> load-module module-console-kit
> load-module module-systemd-login
> load-module module-position-event-sounds
> load-module module-role-cork
> load-module module-filter-heuristics
> load-module module-filter-apply
> load-module module-x11-publish display=:0 xauthority=/home/yuto/.Xauthority
> load-module module-x11-xsmp display=:0 xauthority=/home/yuto/.Xauthority session_manager=local/yutoLAP:@/tmp/.ICE-unix/990,unix/yutoLAP:/tmp/.ICE-unix/990
> load-module module-cli-protocol-unix
> 
> set-sink-volume auto_null 0x10000
> set-sink-mute auto_null no
> suspend-sink auto_null yes
> 
> set-source-volume auto_null.monitor 0x10000
> set-source-mute auto_null.monitor no
> suspend-source auto_null.monitor yes
> 
> set-default-sink auto_null
> set-default-source auto_null.monitor
> 
> ### EOF
[yuto@yutoLAP ~]$ amixer --card=0
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

IEC958 would be a digital output for S/PDIF or HDMI outputs on the audio codec

Your ALSA controls should look like this hardware scan
HW probe of Chuwi GemiBook Pro #021617b9a0: amixer | linux-hardware.org
but all the controls for Headphones, Speakers and Microphones are absent

please get detailed information about ALSA with this command

sudo alsa-info.sh --upload

and post the link to the uploaded information

http://alsa-project.org/db/?f=ec326683708822935186633e8d0dbe096729596a

I’m relatively new to Manjaro myself ( well… new to GNU/Linux as a whole really :wink: ), and had a similar experience with wondering why sound did not seem to be reaching my speakers over S/PDIF.

The main reason was because the system defaulted the “HD Audio Controller” to the standard “Analog stereo output” and I needed to remap it to use the digital channel instead.

  1. Launch Manjaro System Settings
  2. Select the Audio section and click Configure… on the bottom right
  3. Select the proper output audio channel from the dropdown list for you HD Audio device
  4. When you return to the previous screen, you should be able to adjust your Volume/Balance levels as you see fit and select it as your “active” audio device (radio button)… and sound should now work
  5. If I recall correctly, “Playback Streams” was also muted by default… so you may want to enable/unmute that too

@Daniel-I – OP would only see a ‘Dummy Device’ available for playback, because PulseAudio failed to detect any analog or digital outputs available in ALSA

ALSA data is showing an out of date option added to system twice to disable internal digital microphones

!!Modprobe options (Sound related)
snd_hda_intel: dmic_detect=0
snd_hda_intel: dmic_detect=0

One of the instances of this option has been added in GRUB boot command
and an error message also confirms the dmic_detect option is not working

!!ALSA/HDA dmesg

Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=7ac2e9a7-d849-4ff5-8701-7278fde029ba rw quiet apparmor=1 security=apparmor udev.log_priority=3 snd_hda_intel.dmic_detect=0

dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

I suggest you edit /etc/default/grub and remove snd_hda_intel.dmic_detect=0 and then

sudo update-grub

To keep the internal microphone array disabled
find the .conf file in /etc/modprobe.d/ containing:
options snd_hda_intel dmic_detect=0
and change it to
options snd-intel-dspcfg dsp_driver=1

But the internal microphones should be supported by kernel v5.10
and the ALSA data is showing that the Sound Open Firmware drivers to support the digital microphone are installed
The file /etc/modprobe.d/*.conf containing this option can be changed to
options snd-intel-dspcfg dsp_driver=0
to check if the new SOF drivers are auto-detected and loaded correctly
If it all works the /etc/modprobe.d/*.conf file can be deleted

I tried all of that but as @nikgnomic said I only see a Dummy Device.

Hello again,

I changed the grub file as you suggested and edited the alsa-base.conf.

[yuto@yutoLAP ~]$ cat /etc/modprobe.d/alsa-base.conf
options snd-intel-dspcfg dsp_driver=1

or

[yuto@yutoLAP ~]$ cat /etc/modprobe.d/alsa-base.conf
options snd-intel-dspcfg dsp_driver=0

I restarted my machine and for the time being it remains the same.

A long-shot here… after reading some of the news on the 21.1 RC3, there was a nugget about what to do if there was no sound…

3 Likes

Hello,

My bluethoot headset is working fine but my audio jack and speakers are not working. At least one of them is getting the audio.

Bluetooth and network-connected devices can access PulseAudio directly and would not be affected by a problem in ALSA

I suggest you try installing kernel v5.13
use Manjaro Settings Manager GUI - manjaro-settings-manager -m msm_kernel
or this command

sudo mhwd-kernel -i linux513

If a later kernel does not help you might be able to get information about the working audio codec configuration using this guide:
How to sniff verbs from a Windows sound driver · ryanprescott/realtek-verb-tools Wiki · GitHub