Audio Not Balanced after latest update (Oct 01, 2020)

Does “pulseaudio” have a balance control ?
Today (after installing some updates) I notice that my left ch. output is much stronger than the right ch. output. It’s as if the right ch just dropped out. It’s there but at a much lower volume. I reverted back to Kernel 5.4 but that didn’t fix it. Problem does NOT occur when I boot into Win10…then sound is fine (dual boot configuration).

Basic System Config:
Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Kernel Version: 5.8.11-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-7400 CPU @ 3.00GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 630

Hardware Detect output:

AGP      : agpgart intel-gtt 
BLOCK    : sr_mod xhci-hcd xhci-pci xhci-pci-renesas 
CDROM    : cdrom 
CPUFREQ  : acpi-cpufreq pcc-cpufreq 
CRYPTO   : aesni-intel crc32c-intel crc32-pclmul crct10dif-pclmul ghash-clmulni-intel glue_helper cryptd crypto_simd 
DRM      : drm_kms_helper drm i915 
HWMON    : coretemp 
I2C      : i2c-algo-bit i2c-i801 i2c-smbus 
INPUT    : evdev input-leds atkbd mousedev psmouse i8042 libps2 serio serio_raw 
KVM      : kvm-intel kvm 
MEDIA    : cec rc-core 
NET      : r8169 fjes libphy 
SOUND    : pcspkr snd-hwdep snd snd-pcm snd-timer snd-hda-core snd-intel-dspcfg snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-codec snd-hda-codec-realtek snd-hda-intel soundcore 
WATCHDOG : iTCO_vendor_support iTCO_wdt 
OTHER    : intel-cstate intel-uncore rapl ledtrig-audio mac_hid intel_pmc_bxt ee1004 mei_hdcp mei intel_rapl_common intel_rapl_msr intel_powerclamp x86_pkg_temp_thermal fb_sys_fops syscopyarea sysfillrect sysimgblt irqbypass 

The audio/KDE interface seems to be “broken”. Here is sample from the log.
I was attempting to test the left/Right speakers after playing a u-tube video.
I am also getting a lot misc Qt/KDE warning messages.

10/3/20 2:21 PM systemsettings5 org.kde.plasma.pulseaudio: No object for name “alsa_output.pci-0000_00_1f.3.analog-stereo.monitor”
10/3/20 2:21 PM systemsettings5 file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/DeviceComboBox.qml:59:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:21 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:21 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:21 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:21 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:22 PM systemsettings5 file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/DeviceComboBox.qml:59:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:22 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:22 PM systemsettings5 file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/DeviceComboBox.qml:59:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:22 PM systemsettings5 file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
10/3/20 2:22 PM systemsettings5 file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/StreamListItem.qml:36: TypeError: Cannot read property ‘width’ of null
10/3/20 2:22 PM systemsettings5 file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/StreamListItem.qml:36: TypeError: Cannot read property ‘width’ of null

It seems that I fixed this issue myself! (with my very limited knowledge of KDE/Manjaro/Pacman). I downloaded the pulse-audio volume control applet (qt version, there are 2) since I was looking for a speaker-balance-adjustment. Another search told me it might be buried in this app. It’s not. The download, installation of this control and a restart of pulse-audio seems to have fixed the problem, for now. I’m still a bit concerned about all those KDE log warnings though. But for now I’m a happy user :slight_smile:

Pulseaudio does not have a balance control, but the left and right channels can be set to different levels

If you go to pavucontrol --tab=3 and click the padlock icon to unlock the audio channels they can be set to different levels

I had the same issue except my right channel was stronger. Pulse audio did have balance control. It was a little hidden.

  1. After installing, I opened the application up and went to “Output Devices” in the tabs at the top and saw the audio device I was running in there.
  2. On the right hand side there is a padlock symbol. Upon clicking that you’ll notice the single slider turns into two sliders.
  3. Here is where I found that my left channel was 20% lower than my right (41%L and 63%R). Which is weird because I never changed my audio balance. I turned them both to the same (63%) and hit the padlock icon again.
  4. Audio is balanced now.

Didn’t have to restart or anything.

Thanks for the feedback folks. I found the “lock-ch” tab in the pulseaudio volume. However the problem is more cryptic than I first thought. After boot-up (or coming out of suspend) the pulseaudio output levels are all set to 5%. The KDE volume level (by the speaker icon) shows 56%. At this point the two controls are “uncoupled”. The KDE Volume control has NO affect on the sound. In order to get proper balanced sound I have to raise the “pulseaudio” volume back to 56-66%. At this point the two controls are re-coupled. However once audio is idle for a while (approx 2min) the pluseaudio gain output control will drop back down to 5% ! Then I’m back to square-one.I think there’s something in “pulseaudio” timer causing this, or its reacting to some unused input. I wondering if I should re-tag this problem as “Random Pulseaudio Volume resets”.

suggest check all the volume levels Pulseaudio might use with

pacmd dump-volumes

then suggest go to Pulseaudio Volume Control Configuration tab - pavucontrol --tab=5

change Profile for all devices to Off
(this should force Pulseaudio to clear old user settings in home folder databases - ~/.config/pulse/*.tdb)

Then reset Configuration Profile to original profile (Analog Stereo Output or Analog Stereo Duplex)

if a level mismatch was shown in pacmd dump-modules check it again to see if the level mismatch has now been corrected