Audio issues with recent kernels

I generally use the RT-LTS kernels and have noticed severe audio drop out and hugely excessive xruns in recent kernels.

Starting a session with kernel 5.4.106-rt54-MANJARO from GRUB gives me a beautifully smooth system like I’m used to so I’m sure it’s the kernel which is at fault.

Issues have been observed and seem about the same in the current RT-LTS kernel, which is 5.9-rt, and on the Liquorix kernel built to days ago, which is version 5.11.14-lqx. Thus the issue isn’t only with the RT version maintained by Manjaro/Arch and it has persisted for multiple kernel updates.

I use the laptop for some audio production, digital DJing, video editing etc as hobbies and as such I always have Jack running and for the analogue audio use the PA-Jack bridge. With the good 5.4-rt kernel I may see 1 or 2 xruns in an hour of moderate usage but not observe anything on actual audio output. With the problem kernels I can boot the system and leave it completely idle and get over 100 xruns in an hour. I also get audio dropout with doing nothing more than watching a video on VLC which would play perfectly smooth previously. Dropouts observed on both internal analogue audio (via PA-Jack-ALSA and through purely Jack-ALSA) and over the HDMI (via PA-ALSA with no Jack but Jack still running for the analogue, unused path.)

In kernel 5.7 there was a kernel change to the driver for managing CPU (governor, staging etc) and I have a 5th generation i7 mobile CPU. This is the most recent that should go to the new governor in these kernels (named intel_cpufreq, not to be confused with the old acpi-cpufreq.) Manually forcing 5.9-rt to use intel_pstate (which was used previously) didn’t make any difference. 5.11-lqx seems to load acpi-cpufreq instead of intel_cpufreq but also shows the same issues. This was the only obvious change in the kernel around that time I could think to try see if it may be a culprit.

Not tested an external audio interface (but I do have a DJ controller with one built in but haven’t found the time to test and compare.) I haven’t tried with Jack server stopped as audio dropouts while playing video aren’t all the time so would be rather time consuming to see if it still occurs then.

Is it possible to lock a kernel so it will never be removed in an upgrade? I currently have the system set to keep current and previous two kernels. I would like to lock 5.4-rt until this is fixed.

What more can I do to help this get fixed upstream?

System:
  Kernel: 5.4.106-rt54-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-rt-x86_64 
  root=UUID=061bfd5e-d64c-49e5-9fbb-53062d0aa575 rw quiet 
  resume=UUID=77edc4d2-06b7-4b8c-af4c-c7757bbe342f 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 840 G2 
  v: A3009D410303 serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 2216 v: KBC Version 96.5B serial: <filter> 
  UEFI: Hewlett-Packard v: M71 Ver. 01.27 date: 07/12/2018 
Battery:
  ID-1: BAT0 charge: 32.4 Wh (100.0%) condition: 32.4/32.4 Wh (100.0%) 
  volts: 12.7 min: 11.4 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
Memory:
  RAM: total: 15.04 GiB used: 2.69 GiB (17.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: 
  L2: 4 MiB bogomips: 19163 
  Speed: 2402 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 2402 2: 2416 
  3: 2396 4: 2655 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx 
  avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
  ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx 
  pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 5500 
  vendor: Hewlett-Packard ZBook 15u G2 Mobile Workstation driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.0.2 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c 
  class-ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:9ca0 class-ID: 0403 
  Sound Server-1: ALSA v: k5.4.106-rt54-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.17 running: yes 
  Sound Server-4: PulseAudio v: 14.2 running: yes 
  Sound Server-5: PipeWire v: 0.3.25 running: no 
Network:
  Device-1: Intel Ethernet I218-LM vendor: Hewlett-Packard driver: e1000e 
  v: 3.2.6-k port: 5080 bus-ID: 00:19.0 chip-ID: 8086:15a2 class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: ef80 
  bus-ID: 03:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Message: No bluetooth data found. 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 3.64 TiB used: 2.86 TiB (78.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 4TB 
  size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 2B6Q scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 61.04 GiB size: 59.83 GiB (98.02%) used: 34.24 GiB (57.2%) 
  fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 061bfd5e-d64c-49e5-9fbb-53062d0aa575 
  ID-2: /boot/efi raw-size: 497 MiB size: 496 MiB (99.80%) 
  used: 49.9 MiB (10.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: A27D-524E 
  ID-3: /run/media/me/data raw-size: 3.19 TiB size: 3.14 TiB (98.40%) 
  used: 2.82 TiB (89.9%) fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: be07e4f2-9d3f-4157-b3af-bb4ba093d0c3 
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 15.26 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 77edc4d2-06b7-4b8c-af4c-c7757bbe342f 
Unmounted:
  ID-1: /dev/sda2 maj-min: 8:2 size: 61.04 GiB fs: ext4 label: N/A 
  uuid: 3ffef06f-042c-4c31-85a9-df054c4fffe8 
  ID-2: /dev/sda4 maj-min: 8:4 size: 61.04 GiB fs: ext4 label: N/A 
  uuid: 1ebebcd8-bc3c-401c-b148-439e932188ee 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 8087:8001 class-ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-3:2 info: Microchip (formerly SMSC) Hub ports: 4 rev: 2.1 
  speed: 480 Mb/s chip-ID: 0424:2134 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 3-3:2 info: Microchip (formerly SMSC) Hub ports: 4 rev: 3.0 
  speed: 5 Gb/s chip-ID: 0424:5534 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 58.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 193 Uptime: 1h 23m wakeups: 1 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 2036 lib: 479 
  Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04 
1 Like

Kernels aren’t removed from your computer during upgrades.

Then why do I only have three kernels available on a system that has been running for four years and had many, many more kernel updates than that? Where is kernel 4.14 from when I installed the system?

I can’t answer to that, maybe it’s your configuration.

By default, Manjaro’s configuration does not ever remove your installed kernels.

I have kernel 5.4, 5.7, 5.8, 5.9, 5.10, 5.11, 5.12 on my computer currently. Been meaning to remove 5.7, 5.8, 5.9, but been lazy.

Strange. I swear I’ve never changed the default settings and never manually deleted a kernel. I have had to run pacman -Sc on multiple occasions though so maybe this is somewhere configured to keep a certain amount of kernels. I’m sure I had read about the three (current and two previous) kernels somewhere in the official docs but I can’t find it now…

There is a possibility that when you did sudo pacman -Syu, it suggested you to update to a different kernel and remove an unsupported (EOL) kernel, and you pressed “Y” instead of “N”.

Kernel 5.4 is supported until December 2025 anyway, so it won’t go away any time soon.

Sounds quite possible, I can’t remember noticing the word Remove/Delete but I can’t pretend I don’t often read things quicker that I should.

Still sure somewhere I’ve seen there’s an option to set how many old versions are kept…

As in it will remain in the repos for manual install if I accidentally remove it down the line?

Yes, you can see the life of kernels here:

https://www.kernel.org/category/releases.html

1 Like

Semi-related.

Any reason mhwd doesn’t show the liqourix kernel installed from AUR?

$ mhwd-kernel -li
Currently running: 5.4.106-rt54-MANJARO (linux54)
The following kernels are installed in your system:
   * linux52-rt
   * linux54-rt
   * linux59-rt

Probably because mhwd doesn’t have a profile for it. mhwd runs on meta files that profiles each kernel and hardware iirc.

1 Like

Forgot to reply to this. The maintainers of upstream kernels uses bugzilla, so you can report bugs here:

https://bugzilla.kernel.org/

https://www.kernel.org/doc/html/v4.15/admin-guide/reporting-bugs.html


Side complaint: I wish they use GitLab like freedesktop does. It is better organized and looks better in my opinion. Even AMD has a section that they themselves are active in.

Looks like the realtime kernels aren’t kept for long like the generic ones, although the package I use is still labelled as LTS.

$ mhwd-kernel -l
available kernels:
   * linux414
   * linux419
   * linux44
   * linux49
   * linux510
   * linux511
   * linux512
   * linux54
   * linux59
   * linux54-rt
   * linux59-rt

So thanks to your pointer I’ll be extra vigalent when running updates to try and make sure I don’t remove an installed kernel until I manage to test a new one as working without issues.

Although I’ll also admit with Manjaro having full Preempt in its generic kernel most likely I don’t need to be running the rt one at all. Done more out of habit if I’m honest and never got around to testing the standard one properly…

You think my information so far is complete enough to go upstream with a bug report? I’ll try and at least find a day when I can test my USB for number of xruns 5.4-rt against 5.9-rt as I feel that’s an important test I haven’t done yet…

You should try standard kernels as well before submitting a bug to upstream: Kernel 5.10, 5.11, 5.12

I’ve tried liqourix 5.11 which isn’t realtime but isn’t quite generic either and that also has the issue… I’ll install 5.12 though :slight_smile:

Also, alternatively, if you think it’s actually a pulseaudio issue for some reason, you can post the issue here, or PipeWire issues here

You can always try PipeWire to see if that works. I believe you just need the meta package manjaro-pipewire to replace PulseAudio with PipeWire.

Note:

Your driver did load. But I don’t know about audio enough to figure out how everything connects to troubleshoot this issue. Idk if something in the kernel is making it not work, or something in the kernel causing pulseaudio to freak out with your specific audio, or what

It happened a bit less when I unloaded the PA-Jack module but still nothing like normal smooth operation under 5.4 so I decided it unlikely PA was at fault. I did try and stop PA loading but even though my config has autospawn = no in it I couldn’t kill it without it restarting itself so didn’t test beyond remove the PA-Jack bridge.

Just tried 5.12 generic and issue is just as bad there. (And updating while installing to has completely broken Firefox :frowning: but at least I have Brave as a backup browser.)

While doing the install I did notice this line, not sure what would have caused a version of sndio from outside the main repos to be installed but it does make me wonder…
warning: sndio: local (20180120-1) is newer than community (1.7.0-3)

That’s strange… you probably should install 1.7.0-3 because it’s in our repo in all branches. sudo pacman -Syuu should “downgrade” the package. That being said, you aren’t using sndio anyway it seems?

yeah, I noticed this:

IDK if you need to, but there is a section about ALSA too for Jack

Note the inxi you are looking at is while the system is running the good 5.4 kernel. I should probably have taken it and posted while running a problem one, or posted both for comparison…

I read through all those kind of things when I initially installed 4 years ago and it’s run lovely and smooth since, up until the 5.9 kernel install. I have various edits which I can’t remember exactly what I’ve done now (one of the tests I did I didn’t mention about was to return all the PA config files to the Manjaro ones, compare, and edit one line at a time, to no avail. I didn’t revert my ALSA changes though, think about all I did was have to set CARD1 to default as CARD0 is the HDMI but I may have forgotten other bits…)

Should this have been moved to Sound when booting using an older kernel fixes the issue and thus it seems to be in some way related to the kernel? The About thread in the kernel category says this and it’s exactly what happens.

Hint: A problem is probably related to the kernel if it happens with some kernel series and version and doesn’t happen with other kernel series and versions.

EDIT: Although it’s a better place for other people who might experience similar issues to come across the thread so I can see it’s a good idea in that way :slight_smile:

I forgot to say the audio dropouts happen more the longer the laptop has been on, and thus warmer it’s running, which was another thing that pointed me to the CPU driver changes in kernel 2.7…

1 Like