Audio device power saving configuration

Hello,

Since around october 2021 audio device power saving has been enabled per default (only on Intel audio devices I assume?), which caused the issue described in these posts:
/t/after-update-2021-10-08-audio-devices-click-pop-when-playback-starte
/t/click-sound-before-playing-any-audio

To sum up: the issue is that when power saving activates, which happens if audio hasn’t played for 10-30 seconds, when any audio plays again it will re-enable the audio device, causing an annoying pop / click noise. How loud the click is seems to depend on the audio device, but for me it has been loud enough to be a constant annoyance.

Instead of the current setup I would prefer either:
a) Power saving on audio devices is disabled per default.
b) Power saving is enabled after perhaps 20-30 minutes - at least on desktop PC’s.

And it would also be great to find such options for the audio under System Settings > Power Management, so that people could change this to whatever they prefer.

Any thoughts?

maybe yes, please check the output of

cat /proc/asound/modules 

and post it please. there should be the intel_snd.

if so you can shut down the power saving of the audio with the following temporarily

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save 

echo N | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller

you can make the changes permanent if the problem disappears with the following

echo "options snd-hda-intel power_save=0 power_save_controller=N" | sudo tee /etc/modprobe.d/hda.conf
2 Likes

On all my intel system this is needed to keep the audio devices alive, otherwise they go in suspend mode:

pipewire
Edit /usr/share/pipewire/media-session.d/media-session.conf
Comment (#) out this line: suspend-node

Pulseaudio
Edit /etc/pulse/default.pa comment this line: load-module module-suspend-on-idle
Edit /etc/pulse/system.pa comment this line: load-module module-suspend-on-idle

Thanks, I already solved it thanks to the other forum posts. I didn’t need to change the power save controller module setting, I only needed to change the power_save to 0 to solve the issue. It has worked on 2 of my PC’s so far.
Here are the sound modules:

cat /proc/asound/modules                                                                             ✔ 
 0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio

Edit: wait, this was supposed to be in feature requests, not support. I don’t need further support.
I was hoping that this issue could be solved for other users with an improved default configuration, which is what I am asking for.

1 Like

The PulseAudio module can be unloaded temporarily before making a permanent configuration change

pactl unload-module module-suspend-on-idle

If this is found to be effective only one configuration change is needed

sudo sed -i '/load-module module-suspend-on-idle/s/^/#/' /etc/pulse/default.pa

Configuration file /etc/pulse/system.pa is only for running in system wide mode which is not suitable for most Linux systems
What is wrong with system mode? – PulseAudio

@doublejim disabling power management for audio devices would not be considered for default configuration because some laptop users would not be happy about the reduction in battery life if audio devices are not suspended

Adding options to reconfigure audio driver in ALSA alongside audio controls for PulseAudio/PipeWire
is not appropriate and unlikely to be considered by KDE developers when reconfiguration can be dealt with by a single terminal command
Unloading the PulseAudio module would be more appropriate to have as an option in KDE audio settings but also unnecessary when reconfiguration can be implemented by user

thanks for explaining, i didn’t know about system mode

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.