Audacity broken

I have an up-to-date system. When I try to launch audacity, it fails saying there’s no When I run

ldd /usr/bin/audacity | grep tiff => not found => /usr/lib/ (0x00007f296b298000)

Libtiff conflict - can't update depending packages This forum entry states that got removed, but there’s the AUR-package libtiff5. Installing it results in following errors when running audacity:

audacity: /usr/lib/ no version information available (required by /usr/lib/
audacity: symbol lookup error: /usr/bin/../lib/audacity/ undefined symbol: _ZN13wxArrayStringC2ERKS_

Do you have any ideas?

What version of Audacity? I have 3.2.4, and get no such error.

I have the same version 1:3.2.4-1 from stable branch

Doing sudo ln -s /usr/lib/ /usr/lib/ without the libtiff5 aur package results in similar error

audacity: symbol lookup error: /usr/bin/../lib/audacity/ undefined symbol: _ZN13wxArrayStringC2ERKS_

Are you sure you have the correct version on a fully updated system?

pamac update --force-refresh

Please don’t symlink different libraries that obviously mismatch in their major version. This can’t work.

(I have no idea about the usage of audacity and libtiff but I think it’s weird that a audio program depends on a image manipulation library.)

I don’t get any error from audacity (up to date system, also, same 3.2.4-1 version).
And when checked ldd /usr/bin/audacity | grep tiff just searches for, no .5

So, it seems like a ldconfig problem. Have you tried to reconstruct cache with ldconfig -v ?
Have you previously installed audacity from other source (an AUR package)? Perhaps that could explain an incorrect library search.
Have you tried to uninstall and reinstall of audacity? That couls also make the trick…

no pending updates, so the command didn’t change the issue

ldconfig -v doesn’t change the issue

after removing und installing audacity again, there’s no change of the issue. Let me try another mirror

still no change

One binary can’t depend on two different versions of the same library.

ldd shows not only directly linked libraries, it also shows libraries of dependencies that are needed to run this program. Do you have any AUR package installed? You can check with a program like lddtree (in pax-utils, do not use it with grep)

1 Like

Then I can’t imagine why it’s asking you for .5
Another option, but don’t think that will probably help. Try to downgrade
sudo downgrade audacity
if you have enabled downgrading. And see if an older version still has the problem. For, if I undestand properly, that happens since some time, but was working previously, wasn’t it?

Yes, @xabbu is right. It has to be a library for a dependence (and there are lots for audacity).
Check if any package on which Audacity depends is installed from AUR or another source that official ones. You can check in pamac (or octopi) the dependences for Audacity and the installed packages from AUR

yep that seems really strange in the output of ldd. Yes I do have a few AUR packages installed.
lddtree shows

/usr/bin/audacity (interpreter => /lib64/
    ... => /usr/lib/
        ... => None
    ... => /usr/lib/ => /usr/lib/

So it is not a problem with Audacity. On my system is part of wxwidgets-gtk3 .

I had wxwidgets-gtk3-light from AUR installed, so I’ve reverted back to wxwidgets-gtk3 from the repos which solved the issue.

Thank you all for your patience and helpfullness!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.