AsusPro P3540FB slow start

Hello everyone!
I apologize in advance for my poor english. :sweat_smile:

I recently installed Manjaro KDE on my laptop to test the system and start getting to grips with the linux environment.

The installation was successful, no hitch. The problem arises when I try to start the machine: when I press the power button, the computer brings up the screen with the ASUS logo twice for about 8-10 seconds before reaching the login. In fact, to find myself in front of the login screen it takes me at least 28 seconds.

Is there any way to reduce this waiting time? Is it normal for me to see the screen with the Asus logo twice?

Thanks immediately for the answers!
:fist:

Welcome at the Manjaro forum, @Kasui92 :tada:

Yes. That’s all what I can say based on the available info of your system. If you wish more advice then have a look here:

As a first tip, open a terminal window and enter

systemd-analyze critical-chain

Post the result here as well.

Thanks for the welcome, @Wollie ! :man_dancing:

I’ll take a look at it, ty for the advice!

This is the result of the command:

graphical.target ->10.268s
└─multi-user.target ->10.267s
└─docker.service ->9.071s +1.196s
└─network-online.target ->9.069s
└─NetworkManager-wait-online.service ->2.145s +6.924s
└─NetworkManager.service ->2.015s +128ms
└─dbus.service ->2.014s
└─basic.target ->2.012s
└─sockets.target ->2.012s
└─snapd.socket -> 2.012s +470us
└─sysinit.target ->2.009s
└─systemd-timesyncd.service ->1.710s +299ms
└─systemd-tmpfiles-setup.service ->1.649s +54ms
└─local-fs.target ->1.647s
└─var-lib-snapd-snap-skype-153.mount ->1.199s +447ms
└─dev-loop6.device ->1.645s +66ms

In bold I marked the lines that appear red to me.

The link was actually provided to help you to find this command as well:

inxi -Fazy

and

cat /etc/default/grub

I think you can stop/disable/mask NetworkManager-wait-online.service which reduces the waiting time by ~7s but first I would like to see the output of the above commands.

This is the result:

**System**:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=896fdc27-8ec6-4a3c-b635-f143980a5168 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
**Machine**:
  Type: Laptop System: ASUSTeK product: ASUSPRO P3540FB_P3540FB v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: P3540FB v: 1.0 serial: <filter> UEFI: ASUSTeK 
  v: P3540FB.309 date: 04/22/2020 
**Battery**:
  ID-1: BAT0 charge: 62.0 Wh condition: 64.3/70.0 Wh (92%) volts: 15.8/15.8 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging 
  cycles: 73 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
**CPU**:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 604 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 
  4: 700 5: 700 6: 700 7: 700 8: 700 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
**Graphics**:
  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3ea0 
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: ASUSTeK driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 02:00.0 chip ID: 10de:174e 
  Device-3: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-5:5 chip ID: 0408:3090 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") 
  s-diag: 1052mm (41.4") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
**Audio**:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
**Network**:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel 
  port: 5000 bus ID: 00:14.3 chip ID: 8086:9df0 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: br-3f1ee4b3f447 state: down mac: <filter> 
  IF-ID-2: br-46996d743943 state: down mac: <filter> 
  IF-ID-3: br-77c35a8d7501 state: down mac: <filter> 
  IF-ID-4: docker0 state: down mac: <filter> 
**Drives**:
  Local Storage: total: 238.47 GiB used: 26.01 GiB (10.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Kingston model: RBUSNS8180DS3256GJ size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 61E1 scheme: GPT 
**Partition**:
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 26.01 GiB (11.1%) fs: ext4 dev: /dev/sda2 
**Swap**:
  Alert: No Swap data was found. 
**Sensors**:
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2500 
**Info:**
  Processes: 246 Uptime: 15h 51m Memory: 15.49 GiB used: 3.38 GiB (21.8%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1241 pacman: 1233 
  lib: 350 flatpak: 0 snap: 8 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05 
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

I hope I gave you the information you needed!
Thanks for your time

OK. You can do the following:

systemctl disable --now NetworkManager-wait-online.service
systemctl mask NetworkManager-wait-online.service

Also change the grub file by

sudo nano /etc/default/grub

and change in that file

GRUB_TIMEOUT=10

into

GRUB_TIMEOUT=2

Save the file, exit the editor and enter

sudo update-grub

Finally, reboot and report the result.

1 Like

In terms of booting, I saved ~8 seconds. It s great!
:fist:

Any further advice?

Thank U so much!

1 Like