[ARM Unstable Update] 2023-10-24: Phosh, Phoc, Gnome 45.1, Kodi, KDE-git

Hi ARM Community,

we updated some of our packages and synced again with ALARM.

Here some highlights:

  • Phosh and Phoc overlays are now dropped and we adapt ALARM packages
  • More updates to Gnome 45.1
  • Some fixes to RasberryPi 4 and 5 kernels
  • Kodi-RPI should work again
  • more Python2 packages got dropped
  • regular KDE-git package updates

Report any issues you may have with this. Thx.

1 Like

For some reason okular is not getting pulled in with the upstream sync’s in unstable. It has been in ARCH-ARM’s repo since October 12th at v23.08.2-1. We seem to be stuck at v23.04.3-1. This upgraded package is now needed in our unstable and testing branches because of the recent KDE5 renaming.

http://nj.us.mirror.archlinuxarm.org/aarch64/extra/

[ray@jellyfin ~]$ sudo pacman -S okular
resolving dependencies...
warning: cannot resolve "kpty", a dependency of "okular"
warning: cannot resolve "kactivities", a dependency of "okular"
warning: cannot resolve "threadweaver", a dependency of "okular"
warning: cannot resolve "kparts", a dependency of "okular"

Alone the same lines with the KDE5 renaming our pamac-tray-icon-plasma package needs a rebuild to be compatible. This is now needed in our unstable and testing branches.

Also our sddm-breath-theme package in our unstable and testing branches will not upgrade because of the KDE5 renaming. There was some discussion a while back with kvantum being discontinued a while back with x86 and some packages at that time was upgraded on the ARM side so there could be some upgrades but this package was left out. If kvantum is discontinued almost all of our ARM images will have to be redone.

@Darksky you can always perform a sync to get latest packages from ALARM into our mirrors …

With more investigating the reason okular was not upgrading is we were building our own package apparently for mobile compatibility. I have built and pushed our okular package to the unstable and testing branches when the mirrors sync.

okular 23.08.2-2
1 Like

some package won’t update anymore, should remove.
e.g. hyprland & xdg-desktop-portal-hyprland, gcc-12 issue.

Be more specific @Rip2

build gcc-13 only, had try clang but failed.

Still don’t get what you want to achieve here …

GT King Pro Manjaro-Arm-Gnome-linux-aml-6.1.58-1. Upgraded successfully to Arm-Unstable-2023-10-24.

I need to raise an issue, the latest unstable update for the rpi4 firmware broken my realvnc server

the files from opt/vc/lib are gone

please see this issue

any plans to fix it on unstable ? or will things move away from the old raspberrypi-utils

RPi was using their own API and recently discontinued using it in favor of the regular libs under /usr/lib/. Try rebuilding the realvnc server package from AUR and see if it will build using the regular system libs. Otherwise there may have to be some coding changes in their coding. Since it is an AUR package there is not much that can be done as far as manjaro or arch upstream packaging.

https://github.com/raspberrypi/userland/blob/master/README.md

Added:

Looking at the PKGBUILD they are repackaging .deb’s. You may have to wait for realvnc to update unless you built the package your self from source.

Well, the /opt thing is a hack done in the third-party package you linked to:

(a really ugly hack at that, because it overwrites system libraries!). So removing that part (or switching to the realvnc-vnc-server package from AUR that does not have this snippet) might fix it, though you may have to reinstall the packages providing the libraries that were overwritten.

Or you could try using a VNC server that is actually Free Software. There are a few of those. RealVNC is proprietary, binary-only software which is being repackaged from .deb packages intended for Debian and/or Ubuntu, so if the underlying system libraries change, there is very little that can be done to fix RealVNC to work with the new ones.

GT King Pro-Gnome-linux-aml-6.1.58-1 Unstable Branch upgraded successfully to Gnome-45.2.

everytime i try to upgrade my kernel from 5 to 6 it says kernel module rtc-808 not found
and i think the problem is simply that in lsmod it is found as rtc_rk808 instead, same power management module but not getting passed the manjaro logo, or not writing to init.dram successfully because it does not address to rtc_rs5c372 and rtc_rk808.

KDE 6 on Manjaro ARM unstable branch, congratulations to the dev, Enjoy !

https://packages.manjaro.org/?query=plasma&arm=on

Tried to update Manjaro-Arm-KDE Unstable Branch and there is a request to replace “mkinitcpio” with “cryptsetup”. Manjaro-Arm no longer use “mkinitcpio”? Did not proceed.

Enter a number (default=1): 
looking for conflicting packages...
:: cryptsetup and mkinitcpio are in conflict. Remove mkinitcpio? [y/N]

Please ignore the above message. It is due to fact I had been using an older “mkinitcpio version 36.1”.

After allowing “mkinitcpio” to upgrade to version 38-4, “sudo pacman -Syu” proceeded to update/upgrade successfully.

After upgrading to KDE-Plasma-6.0.1-1 could NOT boot into Plasma-Wayland Session. Keep going in a loop at Login Screen.

Can boot into Plasma-X11 but it is not functioning correctly either! No 3D GPU Hardware Acceleration. System sluggish.

Anyone having this issue after upgrading to KDE Plasma 6.0.1-1?

[jfl@jfl-mnjro ~]$ glxinfo -B
name of display: :0

Error: couldn't find RGB GLX visual or fbconfig

image

Edit: Update – After downgraded llvm to llvm-libs-16.0.6-1-aarch64.pkg.tar.xz. 3D GPU Hw Acceleration is available Plasma-X11 Session.

[jfl@jfl-mnjro ~]$ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa (0xffffffff)
    Device: Mali-G52 (Panfrost) (0xffffffff)
    Version: 24.0.2
    Accelerated: yes
    Video memory: 3775M

But still cannot boot into Plasma-Wayland Session (Stuck at Login in Screen).

Hi @nl.smart, can your Odroid N2 boot into Plasma-Wayland after you upgraded to KDE Plasma 6.0.1-1?

1 Like

Hi,

I’m not on unstable branch but stable. I can test it this week-end…

but

sudo buildarmimg -d on2 -e kde-plasma -v 2024.03.18 -b unstable n

doesn’t work, I think it’s the raison the dev team don’t push the unstable update for the moment, they have to solve some issue…

build image issue, see below :

[nls@lap ~]$ sudo buildarmimg -d on2 -e kde-plasma -v 2024.03.18 -b unstable n

==> Creating kde-plasma edition rootfs image for on2…
→ Removing old aarch64 rootfs…
→ Extracting aarch64 rootfs…
→ Setting up keyrings…
→ Setting branch to unstable…

==> Installing packages for kde-plasma edition on on2…
:: Synchronizing package databases…
core downloading…
extra downloading…
community downloading…
:: Some packages should be upgraded first…
resolving dependencies…
looking for conflicting packages…

Packages (2) manjaro-arm-keyring-20240211-2 manjaro-keyring-20230719-2

Total Installed Size: 0.11 MiB
Net Upgrade Size: -0.61 MiB

:: Proceed with installation? [Y/n]
checking keyring…
checking package integrity…
loading package files…
checking for file conflicts…
checking available disk space…
:: Processing package changes…
upgrading manjaro-arm-keyring…
gpg: Warning: using insecure memory!
==> Appending keys from manjaro-arm.gpg…
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: error reading key: No public key
==> Locally signing trusted keys in keyring…
→ Locally signed 1 keys.
==> Importing owner trust values…
gpg: Warning: using insecure memory!
==> Disabling revoked keys in keyring…
→ Disabled 1 keys.
==> Updating trust database…
gpg: Warning: using insecure memory!
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 21 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 21 signed: 2 trust: 0-, 0q, 0n, 21m, 0f, 0u
gpg: depth: 2 valid: 1 signed: 0 trust: 1-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2026-08-21
upgrading manjaro-keyring…
==> Delete expired Key by Jonas Strassel
gpg: Warning: using insecure memory!
==> Updating trust database…
gpg: Warning: using insecure memory!
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 21 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 21 signed: 2 trust: 0-, 0q, 0n, 21m, 0f, 0u
gpg: depth: 2 valid: 1 signed: 0 trust: 1-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2026-08-21
==> Delete expired Key by Jonas Strassel
==> ERROR: The key identified by A44C644D792767CED7941AFEABB2075D5F310CF8 could not be found locally.
error: command failed to execute correctly
gpg: Warning: using insecure memory!
==> Appending keys from manjaro.gpg…
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
gpg: Warning: using insecure memory!
==> Locally signing trusted keys in keyring…
→ Locally signed 3 keys.
==> Importing owner trust values…
gpg: Warning: using insecure memory!
gpg: setting ownertrust to 4
==> Disabling revoked keys in keyring…
→ Disabled 8 keys.
==> Updating trust database…
gpg: Warning: using insecure memory!
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 22 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 22 signed: 2 trust: 0-, 0q, 0n, 22m, 0f, 0u
gpg: depth: 2 valid: 1 signed: 0 trust: 1-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2026-08-21

:: Starting full system upgrade…
resolving dependencies…
:: There are 2 providers available for dbus-units:
:: Repository core

  1. dbus-broker-units 2) dbus-daemon-units

Enter a number (default=1):
:: There are 2 providers available for qt6-multimedia-backend:
:: Repository extra

  1. qt6-multimedia-ffmpeg 2) qt6-multimedia-gstreamer

Enter a number (default=1):
warning: cannot resolve “kjs”, a dependency of “okular”
:: The following package cannot be upgraded due to unresolvable dependencies:
okular

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘kjs’ required by okular
==> ERROR: Aborting…

==> Creating kde-plasma edition image for on2…
→ Creating ext4 partitions…
→ Copying files to image…
mv: cannot stat ‘/var/lib/manjaro-arm-tools/tmp/root/boot/*’: No such file or directory
→ Writing the boot loader images…
Boot PARTUUID is 21643652-01…
Root PARTUUID is 21643652-02…
Root UUID is 8afc975e-6db6-4638-afb1-4b216128aecf…
→ Cleaning up image…
→ Compressing Manjaro-ARM-kde-plasma-on2-2024.03.18.img with xz…
Manjaro-ARM-kde-plasma-on2-2024.03.18.img: 2 846,7 KiB / 1 820,0 MiB = 0,002, 205 MiB/s, 0:08
→ Removing rootfs_aarch64…

==> Time elapsed: 1.52 minute(s)
[nls@lap ~]$

Update on GT King Pro Manjaro-Arm-KDE6.

Upgraded to https://mirror.easyname.at/manjaro/arm-unstable/extra/aarch64/mesa-24.0.3-1-aarch64.pkg.tar.zst enabled llvm-libs-17 to work on Plasma-X11 but it will still not boot into Plasma-Wayland. Just stuck at Login Screen.

Furthermore, at the login screen it complain about missing theme.

1 Like

KDE 6 on Manjaro ARM unstable branch now on 6.0.2, its going well :-) Enjoy !

https://packages.manjaro.org/?query=plasma&arm=on

Did you managed to login in to Plasa-Wayland with KDE Plasma-6.0.2 on Odroid n2?

On GT King Pro still cannot login to Plasma-Wayland.