[ARM Stable Update] 2023-02-16 - Firefox 110, PlaMo Gear 23.01, Mesa, LibreOffice 7.5 and Kernels

Hello ARM community.

Getting ready for our next release, this update brings in a lot of everything.

Some highlights:

  • Most of our kernels got updated
  • Firefox updated to 110.0
  • Plasma Mobile Gear updated to 23.01.0
  • Mesa updated to 22.3.5
  • Plasma Frameworks updated to 5.103
  • KDE Gear applications updated to 22.12.2
  • GStreamer updated to 1.22
  • LibreOffice updated to 7.5.0
  • QEMU updated to 7.2.0
  • Thunderbird updated to 102.7.2
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

End Of Life kernels (will soon by removed from the repo):

  • linux60 (EOL on 2023-01-12)

Gnome 43 theme changes

Gnome 43 changes how themes are applied to the system, so when upgrading you might notice something is off with the theming.
We have tried to make it easy to get a pretty good theme going when updating, but it does require a few steps.

  1. Install adw-gtk3 and gradience. But you will need to set your own colors in Gradience after it’s installed.
  2. Open Gradience and import this preset (link will follow) and Apply it.
How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Removing python2 from the repositories

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package changes:

(Thu Feb 16 19:35:21 CET 2023)

  • arm-stable community aarch64: ??? new and ??? removed package(s)
  • arm-stable core aarch64: ?? new and ?? removed package(s)
  • arm-stable extra aarch64: ??? new and ??? removed package(s)
  • arm-stable kde-unstable aarch64: ??? new and ??? removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Docker 23 not starting

Since the update to Docker 23, upstream is now inforcing new paths for apparmor related stuff. But there has been changes to dependencies yet. So Docker 23 will error on start.
Fix: Install apparmor from the repositories.


Ethernet and Wifi not working right on kernel 6.1.2+ on some devices

Some devices have been reported to not have properly working ethernet and wifi after the update to kernel 6.1.2 and above.
Fix: Kernel 6.1.5-2 and above should have working ethernet and wifi again.

Reduced video playback performance in mpv

There has been reports of video playback performance in mpv has regressed since an update to mpv.
Fix: MPV now needs a vd-lavc-dr=no parameter to play hw acceleration supported 1080p videos smoothly.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in. PostMarketOS likely won’t fix this in their source, so we might need to carry a patch for this.


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Fix: Update to Mesa 22.3.2 was reported to work here.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

Looks like I voted “everything went smooth” too soon. Two of my docker containers (mediawiki and teamspeak3-server) are no longer starting up. Looks like the issue described here. There’s also a post with some kernel parameters that are supposed to fix it, but I’ve never really had to touch u-boot so far so I’m not sure how to try these out.

Edit: Forgot to mention, my home-assistant container is still running. I’m not sure why it is not affected by the issue…

The linkes issue seems to be about AppArmor. We have not changed anything regarding AppArmor in a while. Did it work fine before this update?

It did. I don’t even use AppArmor. Still, here’s the error I get when launching the Teamspeak container:

docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: unable to apply apparmor profile: apparmor failed to apply profile: write /proc/self/attr/apparmor/exec: no such file or directory: unknown.

This is how I start the container:

docker run -d --name TeamSpeak3_Server -e TS_UPDATE=1 -e TIME_ZONE=Europe/Berlin -p 9987:9987/udp -p 10011:10011/tcp -p 30033:30033/tcp --restart=unless-stopped -v /terra/teamspeak3-server/:/teamspeak/save/ ertagh/teamspeak3-server:latest-box

The mediawiki container throws the same error as teamspeak. My installation is running on a Rock Pi 4B+.

Edit: Doing some investigating, it seems the problem is happening inside the containers, which makes sense because as mentioned, I never had AppArmor installed. Seeing how two images have this problem, one of which has not received any kind of update in three months, I assumed the problem is with docker itself, or rather there’s been some kind of change that necessitates changing the images in some way. Downgrading docker to 20.10.22-1 -aarch64 confirmed this suspicion.

1 Like

Package manager doesn’t work correctly.
Please see last refresh date and time.

Since I installed this update the issue on PinePhone where the lock screen no longer responds to touch input happens way more often.

Strange. I have the impression that this is much more stable on my PinePhone than the previous (January) stable update.

Maybe it’s related to: FS#77481 : [docker] 1:23.0.1-1 broken, either won't start or sends SIGTERM to the app inside container ?

It seems that Docker and ContainerD changed the way they handle LimitNOFILE, which is set to infinity in the config/service files.

There are reports that limiting the NOFILE limit fixes this for some people.

So I would like you to try installing this package to see if it fixes it with docker 23 for you (extract the zip first, then install with pacman -U):
If it does, please let me know, so I can upload the fix to all branches.

Thank you, but sadly I still get the same error, even after rebooting. It’s strange how I get this exact error-message on three different containers (I found an apache-instance on another Rock Pi affected as well), but searching online I can’t find anyone with this exact error. Anything I’m missing I could investigate on my end?

I really don’t know anymore then. Maybe there was upstream changes in some thing, making it now require AppArmor to run some things.

As far as I can see in the updates on the packages, no dependencies have been changed.

Alright, I’ll see what the maintainers of the affected containers make of this, thank you!

It is quite random. It might happen multiple times a day or just every few days. But so far I had to reboot the phone at least once a day.

FYI, the January update had a known broken (for the Allwinner A64) Mesa, which is fixed in this update. But you may be running into some other regression.

The upstream issue @rootgordon linked to makes it pretty clear that this is an upstream regression (apparently in runc) that makes Docker no longer work if AppArmor is not installed.

Hm, according to some of the PR’s listed there, they add apparmor to the CONFIG_LSM option in the kernel config, which we already have.

But yes, sounds like an upstream regression or oversight.

It’s a very long standing issue (over a year now I think).

It is also mentioned in the known issues section of the ARM PlaMo beta releases: Manjaro ARM Beta 14 with Plasma Mobile (PinePhone / PinePhone Pro)

I upgrade my pinebook and nows wifi dissapear.

I was trying to find info to upgrade kernel via pamac without success.

How I can upgrade kernel version without compile from source?