[ARM Stable Update] 2022-04-13 - Firefox, Mesa, Electron and Kernels

Hello ARM community.

It’s been a while since the last update, but here it finally is! Get ready for the 22.04 release!

Support for the Quartz64 Model B coming soon!


Some highlights:

  • Most of our kernels got updated
  • Firefox updated to 99.0
  • Gnome updated to 41.5
  • Plasma updated to 5.24.4
  • Also Thunderbird updated to 91.8.0
  • LibreOffice updated to 7.3.2
  • And Mesa updated to 22.0.1
  • Amazfish updated to 2.0.5
  • As well as Electron has updated to 18.0.0
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

over_voltage=5
arm_freq=2000
#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d,cma-512
#max_framebuffers=2    #disable cause kodi uses more
dtoverlay=rpivid-v4l2
disable_fw_kms_setup=1

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.


Upstream Notifications:

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention


Package changes:

(Wed Apr 13 20:36:18 CEST 2022)

  • arm-stable community aarch64: 700 new and 721 removed package(s)
  • arm-stable core aarch64: 75 new and 76 removed package(s)
  • arm-stable extra aarch64: 722 new and 751 removed package(s)
  • arm-stable kde-unstable aarch64: 377 new and 377 removed package(s)

See the full package list here


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Donation

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

Poll

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    }
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
    }
}
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via 192.168.250.1" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

@Strit,

Beelink GT King Pro upgraded successfully to Arm-Stable-2022-04-13 and so far run smoothly.

Great job. Mesa 22.0.1-3 is working well.

On Ubuntu I tested with Mesa 22.0.1 there seems to be having compatible issues. Some apps don’t seem to be working well with Mesa 22.0.1 on Ubuntu where it works without issue with Mesa 21.3.7 or Mesa 21.2.6.

We apply a patch to Mesa 22 to make it work correctly. It’s an issue that is fixed in Mesa 22.1, but has not been backported. Ubuntu likely does not patch this fix in.

Thanks for the info. Great work.

2 Likes

I still experience a hard crash after rebooting from the update.
But most of the times it only happens once after updating.

Using Wayland has improved (compared to a couple of months ago). Not sure if it is because of Wayland, or that apps like Firefox have improved compatibility with Wayland. Advantage of using Wayland is that Chromium can play Youtube in 1080p on my Pinebook Pro. Perhaps this is the moment for me to stay on Wayland.

Update to latest stable linux-khadas kernel on vim3 pro broke audio. @spikerguy

2 Likes

Interesting, I hope they did not change the Sound node name :frowning:
Will look into it tomorrow.

Thanks for reporting.

2 Likes

@spikerguy
I have installed linux-lts and it has fixed the audio for the time being.

P.S. (It was broken on linux-rc as well)

I use Manjaro - ARM XFCE on a Raspberry Pi 400 via an SSD. I just received a push update of the Manjaro-keyring and ran the update.
Screenshot_2022-04-21_01-12-28

After it finished the update a warning popped up showing this:

Was wondering if you knew about this and if you do are you trying to fix it?

While it does look like it’s giving out errors, it does actually complete successfully.

I use Manjaro - ARM XFCE on a Raspberry Pi 400 via an SSD. I just received a push update of the Manjaro-keyring and ran the update.

I got the same error messages, except with MATE desktop on RPi 4 with 8GB, also running from an SSD.

Since that update, I cannot access through Thunar to a distant file with samba.
Thunar used to mount it and now it says that that particular smb://192.168.x.xxx/“Shared” : can be mounted.

Before the update, Thunar did the job for me. It opened a dialog box “connect as : guest or register user”
I am a basic user and I do not know how to solve it.
Thanks a lot

After this update qutebrowser started to crash frequently on rpi4.
Starting it from terminal I found out that the crash is due to ‘Too many open files’, and looking at the fd folder of the process I discovered a huge amount of file descriptors named anon_inode:sync_file, so it seems that the issue is due to mesa update: I found an old issue with a similar description ([bisected] anon_inode:sync_file file descriptor leak (#1949) · Issues · Mesa / mesa · GitLab).
I tryed to install mesa-git, but the issue is not solved: opening https://github.com page where there is an animated globe, the maximun number of fd that can be opened is reached in less than 15 minutes.
Before to open an issue upstream I would like to try to downgrade the mesa package to confirm that the issue is caused by this update, but unfortunately I don’t have it anymore in the cache; is there some archive where I can download the old package?
Thanks

Just found a new mesa tag (22.0.2) created few days ago. How can I build a mesa package for manjaro with all patches you have included in 22.0.1? I would like to try it to see if the issue is already solved.
Thanks

  1. Take the PKGBUILD from Arch Linux ARM: PKGBUILD - mesa (aarch64) | Package Files | Arch Linux ARM
  2. Update pkgver= to be pkgver=22.0.2 and pkgrel to be pkgrel=1.
  3. Remove the https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15365.patch and patch -Np1 -i "${srcdir}/15365.patch" lines.
  4. Run updpkgsums in the folder with the PKGBUILD file.
  5. Run makepkg -sci in the folder with the PKGBUILD file on an aarch64 based device.
  6. Wait for 40-60 minutes while it creates the package and installs it.
2 Likes

@Strit thanks a lot for the instructions.
I tryed to build mesa 22.0.2 but the issue is not solved.
Is there some place where I can find old packages? I tryed to search at https://archive.archlinux.org/ but I cannot find aarch64 packages.
Thanks

http://tardis.tiny-vps.com/aarm/packages/m/mesa/