[ARM Stable Update] 2021-10-15 - QT, Firefox, Uboot, Vivaldi and Kernels

Hello ARM community.

This is a pretty big update. It simply has it all!


Some highlights:

  • Most of our kernels got updated
  • QT 6 got a big point release with 6.2.0
  • And Firefox is updated to 93.0
  • Most of our mainline Uboot packages updated to 2021.10
  • KDE Gear updated to 21.08.2 and KDE Frameworks updated to 5.87
  • Vivaldi updated to 4.3
  • And our own Manjaro ARM Flasher updated to 0.8 with early support for PyQt6
  • Yay updated to 11.0.1
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker linux-rpi4 xf86-video-fbturbo-git

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

over_voltage=5
arm_freq=2000
#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d,cma-512
#max_framebuffers=2    #disable cause kodi uses more
dtoverlay=rpivid-v4l2
disable_fw_kms_setup=1

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.


Upstream Notifications:

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
https://archlinux.org/news/sorting-out-old-password-hashes/

Older notifications

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention


Package changes:

(Fri Oct 15 22:22:39 CEST 2021)

  • arm-stable community aarch64: 648 new and 611 removed package(s)
  • arm-stable core aarch64: 50 new and 50 removed package(s)
  • arm-stable extra aarch64: 722 new and 803 removed package(s)
  • arm-stable kde-unstable aarch64: 412 new and 407 removed package(s)

To see the full package list, click here !


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Donation

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

Poll

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

3 Likes

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

On the Raspberry Pi 400:
Pulse Audio now cannot find any audio devices and routes sound to the dummy device

1 Like

See if this helps.

https://forum.manjaro.org/t/i-have-no-sound-output-through-hdmi-on-5-10-73-1-or-5-14-or-5-15/86485/6

Another old issue. Once again, numpy breaks because it can’t find libblas.so.3

Once again, have to go to /lib directory and remove libblas.so and create symbolic links for libblas.so to libopenblas.so and libblas.so.3 to libopenblas.so.3

cd /lib
ls -l | grep blas
sudo rm libblas.so
sudo ln -s libopenblas.so libblas.so
sudo ln -s libopenblas.so.3 libblas.so.3

I’ve come to expect this every time I see libblas is updated.

There’s a chain of symbolic links in this folder that all end up at libopenblas_armv8p-r0.3.18.so*, but the key is making sure libblas.so and libblas.so.3 get to it.

Just ran the latest updates today (XFCE), And audio no longer plays over HDMI. Did a fresh install just now (KDE) Audio worked, Did updates on fresh install then reset and audio is broken again and can only play over 3.5mm audio jack. No HDMI in options in mixer…

Raspberry Pi?

See 2 posts above yours.

GT King Pro Manjaro-Arm-GNOME updated successfully to Arm-Stable-2021-10-15 as usual but this time on startup NO Sound.

.

I think is due to the g12_sound.sh is using NEW CONF. Switch to OLD CONF should resolve the NO Sound issue.

Yes Reverting to OLD CONF resolved the Sound issue.

# Amlogic G12 HDMI to PCM0 - OLD CONF
  mixer $card 'FRDDR_A SINK 1 SEL' 'OUT 1'
  mixer $card 'FRDDR_A SRC 1 EN' on
  mixer $card 'TDMOUT_B SRC SEL' 'IN 0'
  mixer $card 'TOHDMITX I2S SRC' 'I2S B'
  mixer $card 'TOHDMITX' on

# Amlogic G12 HDMI to PCM0 - NEW CONF
#   mixer $card 'FRDDR_A SINK 1 SEL' 'OUT 0'
#   mixer $card 'FRDDR_A SRC 1 EN' on
#   mixer $card 'TDMOUT_A SRC SEL' 'IN 0'
#   mixer $card 'TOHDMITX' on
#   mixer $card 'TOHDMITX I2S SRC' 'I2S A'

GT King Pro Manjaro-XFCE-Edition updated successfully. Upon Restart No Sound same issue as with GNOME Edition. Resolved as above.

Because of the breakage, I had to switch rigs. Didn’t realise you people would be so efficient.

Have now switched back to the Pi and edited cmdline.txt.:
from

snd-bcm2835.enable_compat_alsa=0

to

snd-bcm2835.enable_compat_alsa=1

and I now have sound back !!!

Thanks ever so much !! You folks are the best !!!

For the record: I am running Manjaro-MATE on the Pi 400. I have swapped out MATE for an i3 desktop. Speakers are hooked up through HDMI.

⇒ KJ

2 Likes

I use a Raspberry Pi 400 and my daily DE is XFCE . I had the same audio issue with audio through HDMI as others above have reported. I came here to the forum and found the solution already posted. I then follow the ink to the instructions and applied the fix through terminal and restarted my Pi. every thing was working but I found I had entries in the Audio mixer for Built-in Audio Stereo. I opened the Audio mixer and went to the Configuration tab and tuned off one of the Built-In Audio Stereo entries and was back to normal. Thank you @Darksky for providing the solution.

Also, the current version for Vivaldi that installed with this update is working great including video. :grinning: :+1:t2:

1 Like

Hi, I am new to Manjaro. Where can I find this config? I run a Pi400 and think this is the solution to my problem not having sound. The other tips did no solve the problem.
Thank you

Not sure g12_sound.sh exist for Pi-400. If not mistaken g12_sound.sh is only for Amlogic devices. The file is in /usr/bin/

https://forum.manjaro.org/t/i-have-no-sound-output-through-hdmi-on-5-10-73-1-or-5-14-or-5-15/86485/6

Rock64 KDE Plasma

The update replaced kernel 5.14.8-1-MANJARO-ARM by 5.14.12-1-MANJARO-ARM, however

/boot/initramfs-linux.img

remains still version 5.14.8-1 !

$ uname -r
5.14.8-1-MANJARO-ARM

It resulted at least in a missing network device.

/lib/modules/5.14.12-1-MANJARO-ARM

is correct.

I just received an update to XFCE on my Raspberry Pi 400 that fixed the audio issue but now the Manjaro loading splash screen that comes when shutting down and when loading the Light DM GTK+ Greeter at startup is no longer is running. How do I get it back?

Wow Lizzie. I did not consider that as I disable the boot splash here and it also is going to involve @strit to help fix that. Look in the the backup file that should have been made in /boot/ named cmdline.txt-backup. Copy everything in it except leave out snd-bcm2835.enable_compat_alsa=whatever & snd_bcm2835.enable_headphones=1 to your /boot/cmdline.txt.

I am pushing another fix right now so you will have to go through the same procedure when it installs until I can get with @strit to change another package of his.

Pi Linux update released today hosed my RPi4 XFCE. Boots to rootfs after update. Will rebuild completely and never, ever do another “stable” update within a few weeks of release.

1 Like

Weird. Sounds like the greeter got disabled. You can try sudo systemctl enable lightdm if it is a stock image. This did not happen here on my xfce on upgrade.

Your fix worked. I had to do it twice though because I got the update again. Now no update is being pushed through pamac. Audio through HDMI is working also.

1 Like