[ARM Stable Update] 2021-07-23 - Box64, Firefox, PlaMo Gear, SystemD, MyGNUHealth, Pipewire and Kernels

Hello! Congratulations on the release.

Some things I noticed during the install…

  • 131/131) checking available disk space ... warning: could not get file information for usr/lib/libblas.so.3 Not sure what’s going on here. I’d think a permissions issue, but doesn’t pacman have root access for this?
  • ===> Keeping old cmdline.txt file... and ===> Keeping old config.txt file... These are expected, but is there ever a new release where we need to delete these and let Manjaro regenerate fresh ones? (And then customize them again before restarting…)
  • From MariaDB: warning: /etc/my.cnf.d/server.cnf installed as /etc/my.cnf.d/server.cnf.pacnew I haven’t checked to see what’s different with the default file, yet. EDIT: Nothing new in the default file. I’d just added some settings.
  • Also from MariaDB, here for reference: :: MariaDB was updated to a new feature release. To update the data run:
    systemctl restart mariadb.service && mariadb-upgrade -u root -p
  • upgrading podman                                                                                                                                
    warning: directory permissions differ on /etc/cni/
    filesystem: 700 package: 755
    warning: directory permissions differ on /etc/cni/net.d/
    filesystem: 700 package: 755
  • WARNING: Major config changes. Make sure to read /usr/share/doc/qtile/CHANGELOG.
    New optional dependencies for qtile
    python-dbus-next: for utils, notifications and several widgets
    python-pywlroots: for experimental wayland support
  • warning: directory permissions differ on /etc/sudoers.d/
    filesystem: 755 package: 750

I’m experiencing trackpad unstability on PineBook pro. I’m often unable to move the cursor (I get kind of get it back on track by taping meta key and left clicking a few times but I sometimes have to reboot/logout)

It’s an issue with the openblas/blas package.

The whole idea is to not have the user do anything. The point is that the current configs you use works, so that’s why we keep them.
If we absolutely need to change something in them, we will do it by other means. So not an issue.

Totally expected. Just means you had made edits in the file, and the package didn’t overwrite it, just like it’s suppose to. So not an issue.

Also as expected. So not an issue. It’s a guide, that tells you what you need to do. So not an issue.

These are because the package has different permissions listed for these directories, that what is presently on your system. You can change them manually. So not an issue.

Simply information about new optional dependencies. Not an issue.

Same as the permission differ section above. Not an issue.

1 Like

same behaviour

I know the chances of this being an Manjaro issue is basically about the same as me taking a rocket to the moon in the next year. However, I have two PI’s both running Manjaro, one is a 1gb the other is a 4gb. Both are POE powered an both boot from a WD Blue SSD via a StarTech SATA->USB cable. I updated the 1GB model the 24th and upon reboot the root was corrupted. I fixed the issues. Today, I undated the 4GB model and fscked the drive before just because I didn’t want to find a surprises after the update. The drive came back clean, updated and the drive ended up being corrupted on reboot.

Only a couple of things come to mind. Sometimes if it is too overclocked corruption can occur with large upgrades. I always do a “sudo sync” to flush the memory after large upgrades before rebooting.

I guess low power to the drives could also cause corruption.

I am using Manjaro ARM on a R Pi4. After updating today, CURA is unable to launch.
Anyone have similar issue?
Did a reinstall and the issue still the same.

1 Like

Looks like a python incompatibility.

[ray@pi4 ~]$ cura
Traceback (most recent call last):
  File "/usr/bin/cura", line 25, in <module>
    import pynest2d # @UnusedImport
ValueError: PyCapsule_GetPointer called with incorrect name


I installed cura and was getting this even before doing this update when testing it. I was already on the testing branch.

1 Like

Update seems to have gone well on my PinebookPro.

I just wish I could figure out how to work Box64. Wanted to see if I could get Steam, Discord, or something like that working, especially for chatting… but also it’d be neat to try some light programs and such with proton or Wine.

I’ll probably have to wait until someone who is a bit better than me at this stuff writes something up. Major release coming up at work and my brain is fried.

Edit: Apparently so fried I forgot that some of those are 32 bit only still. So still need box86 to try some of it.

Edit 2: I got so close to getting Factorio working… Performance wasn’t bad just… too many graphical errors.

Edit 3: Nice. Works, other than an apparent issue with Box64 on saving.
Edit 4: Autosaving works. If anyone wants a config, let me know.

Does the update going trough discover on pinephone work’s or should I use pamac -Syyu?

The update works if there is no conflicts (which all depends on when you updated last).

But pacman -Syu does work.

Seems like Superslicer and prusar slicer also unable to launch.
What could be the reason?

Can’t tell without the error message.

My best guess, is you need to rebuild them, as they are AUR packages.

I can only wait for more updates. Currently unable to use the slicer software for 3D printing. The rest are fine.

1 Like

Any idea if appimage runs on manjaro arm?
Tried using appimagelauncher, can’t run the software as well.
tried to use cura4.10 appimage from ultimaker website.

how do i extract out the error message?
it did not pop up on the screen. Any where to locate the log file?

Run the software from the terminal. Post the output it gives.

But try rebuilding them from AUR first.

AppImages run, if the AppImage is made for aarch64/arm64.

To note though; amd64 AppImages do have some weird behavior with Box64. Not saying it’s your guys job to figure out, but in the event it becomes relevant. Can’t detect FUSE or something of that sort.

Do you have fuse installed? (we don’t install it by default)

I do, yes. I needed it for something awhile back.

Now, mind you; I assume it would work with native AppImages.

…Actually, I just had a thought on how I might get AMD64 app images to work with Box64. Might take me a bit to test since I have to run some errands and have a late night release coming up. I assume it’s expecting the AMD64 binaries. Which for some reason didn’t hit me until now.