[ARM Stable Update] 2021-06-18 - Pacman 6, Plasma 5.22, PlaMo Gear 21.06, Firefox 89, Gnome 40.2 and Kernels

Hello ARM community.

Pretty big update, with pacman, Plasma and mobile stuff.

Plasma 5.22.1is out!

Some highlights:

  • Most of our kernels got updated
  • KDE Plasma 5.22.1 is out!
  • Also KDE Plamo Gear 21.06 released recently
  • Cutefish got updates to 0.2
  • Our main browser, Firefox got updated to version 89.0.1
  • Pacman 6.0 released and we updated all our tools to be compatible, including Pamac
  • KDE Gear got a new point release of 21.04.2
  • And also Gnome got updated to 40.2
  • Lots of updated packages for our Mobile offerings, introducing Kasts and Tokodon
  • The regular Python updates
  • And regular updates from upstream

How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker linux-rpi4 xf86-video-fbturbo-git

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:

Older notifications

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:

The nss and zn_poly packages requires manual intervention:

The packages hplip and firewalld requires manual intervention:

Package changes:

(Fri Jun 18 20:14:12 CEST 2021)

  • arm-stable community aarch64: 829 new and 788 removed package(s)
  • arm-stable core aarch64: 66 new and 65 removed package(s)
  • arm-stable extra aarch64: 1038 new and 1016 removed package(s)
  • arm-stable kde-unstable aarch64: 396 new and 396 removed package(s)
  • arm-stable mobile aarch64: 0 new and 1 removed package(s)

See all the package changes here!

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login. We are working on a fix for this!
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-2.1 and qt5-es2-declarative-5.15.2+kde+r28-2.2.

Libcanberra dependency issue
You might be blocked updating when using pacman due to some libcanberra packages. Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. Or you can use pamac update which takes care of it for you.

Old Issues

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

1 Like

Updated keyring, replaced libcanberra-pulse, mntray, and qca, resolving dependencies and looking for conflicts… all fine. Downloaded most of updated packages, and then…
Failed to retrieve okular-21.04.2-1-aarch64.pkg.tar.xz from several mirrors (404 error), and then failed to commit. No packages upgraded.
On PinebookPro.

pacman -Q okular returns:
okular 21.04.0-1
Which does not match what is being requested.

Successful upgrade by using:
sudo pacman -Syu --ignore okular

Several warnings reported during upgrade:
upgrading pacman
warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew

installing libpamac
warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew
=> An authentication agent is required
Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
have an authentication agent already.
See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
for other desktop environments.
Optional dependencies for libpamac

upgrading sudo
warning: directory permissions differ on /etc/sudoers.d/
filesystem: 755 package: 750

I’m an inexperienced user, so the above could be nothing or big trouble, I don’t know…

warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew

There are a few bits that need to be merged from the pacman.conf.pacnew into pacman.conf
If i recall most of it was in # lines but there was the addition of parallel downloads option

=> An authentication agent is required
Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
have an authentication agent already.

if you use one of thoes DEs then there is nothing to do, if not then read the wiki link.

   warning: directory permissions differ on /etc/sudoers.d/
        filesystem: 755 package: 750

See below

    You get `[PKGNAME] warning: directory permissions differ on [Directory name]`

    followed by:

    > Filesystem: NNN package MMM
    Please click the ► at the beginning of this line to view this solution

    * **The solution:**

    sudo chmod MMM DirectoryName

    Where obviously MMM is the second number you see (the correct one)

    * **The explanation:**
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.
1 Like

I’ll look into this one. Thanks for reported.

The other messages are general warnings and information. You should compare pacman.cong with pacman.conf.pacnew and merge the differences into pacman.conf.

1 Like
> diff pacman.conf pacman.conf.pacnew 
< #IgnorePkg   =
> # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
< Color
< #TotalDownload
> #Color
> #NoProgressBar
> #ParallelDownloads = 5

Looks like the only changes were removal of an extra #IgnorePkg line, addition of the #Pacman won’t… line, change of #TotalDownload to #NoProgressBar, and addition of #ParallelDownloads = 5.
And putting a # on Color.

Thanks for the help.

1 Like

Odroid N2 kde up to date.

1)I apply with pacman this command

sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer``

2)up date the os with pamac.

Beelink GT King Pro, up to date with had few warnings but updates proceeded successfully.

:: Starting full system upgrade...
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] Y
warning: libtool: local (2.4.6+44+gb9b44533-14) is newer than core (2.4.6+42+gb88cebd5-15)
:: Replace mntray with community/matray? [Y/n] Y
:: Replace qca with extra/qca-qt5? [Y/n] Y
resolving dependencies...
looking for conflicting packages..

WARNING: Non-backwards compatible changes to ALSA require restarting of audio engines (e.g. pulseaudio or pipewire) using it.

(230/231) upgrading sudo                           [######################] 100%
warning: directory permissions differ on /etc/sudoers.d/

Operating System: Manjaro-ARM
KDE Plasma Version: 5.22.1
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Kernel Version: 5.12.11-1-MANJARO-ARM (64-bit)
Graphics Platform: X11
Processors: 6 × 
Memory: 3.7 GiB of RAM
Graphics Processor: Mali G52

Somehow again, Plasma-Wayland sessions does not work. Just hang/freeze at Login Greeting Screen. Is there a way to rectify this?

Hi @nl.smart,

Are you able to login to Plasma-Wayland session on Odroid N2?


Yes I did in the past for the n2 kde, I don’t use it permanently (vnc don’t support it for the moment, but for sure in the future)
take care, some soft are not able to run with wayland for the moment.

First, install wayland

secondly, select and active wayland on boot

Does this mean have to set it as Automatic Login as Plasma-Wayland? I have already installed plasma-wayland-session module and on the Login Greeting Screen, can select Plasma (Wayland). Just that if select Plasma (Wayland) and enter password it will just freeze and need to power cycle to get it to reboot. With Plasma (X11) I can login and works just NOT Plasma (Wayland).

Worried if I set automatic login as Plasma (Wayland) it could lead to a situation where I cannot access to Manjaro Desktop as it might just freeze as it is happening now. Unless the Login Screen (SDDM) settings is NOT for automatic login.

No, You don’t need to set the auto login at boot.

So, I test wayland without the auto login at boot, wayland is working.

on boot you have to select your graphic session, plasma wayland

graphic session with x11

[nln2@n2 ~]$ inxi -G
Graphics:  Device-1: meson-g12a-vpu driver: meson_drm v: kernel 
           Device-2: meson-g12a-mali driver: panfrost v: kernel 
           Device-3: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: kernel 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting s-res: 1920x1080 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
[nln2@n2 ~]$ 

graphic session with wayland

[nln2@n2 ~]$ inxi -G
Graphics:  Device-1: meson-g12a-vpu driver: meson_drm v: kernel 
           Device-2: meson-g12a-mali driver: panfrost v: kernel 
           Device-3: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: kernel 
           Display: wayland server: X.Org driver: loaded: modesetting s-res: 1920x1080 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
[nln2@n2 ~]$ 

@JFL have a look here, I found my first test with wayland on the n2

Thanks will try out your suggestion without autologin but set as your suggestion.

Hi @nl.smart, “System Settings”, “Startup and Shutdown”, “Login Screen (SDDM)”, “Behavior” but cannot apply Plasma (Wayland) unless select Automatically log in and Apply the settings.

Else it revert back to Plasma (X11) once I leave the settings.

The above does not reflect the actual situation as it will revert back to Plasma (X11) unless I select the “Automatically log in”

Hi @Strit,

FYI info, just found out Bluetooth did not work after update to latest Stable. BCM4356A2.hcd file is missing from /usr/lib/firmware/brcm folder.

numpy broke, cannot find libblas.so.3

in /usr/lib/
ls -l
libblas.so → libopenblasp-r0.3.15.so
libblas.so.3 does not exist
libopenblas.so → libopenblas_armv8p-r0.3.15.so
libopenblas.so.3 → libopenblas_armv8p-r0.3.15.so

commands used:
sudo rm libblas.so
sudo ln -s libopenblas_armv8p-r0.3.15.so libblas.so
sudo ln -s libopenblas_armv8p-r0.3.15.so libblas.so.3

Nota bene: I am an inexperienced user, so use your experience to alter above as required.

I did a sudo pacman -Syu, accepted all the default changes and everything went smoothly. However, I have not customized my system much yet. It’s mostly Manjaro Fusion “as shipped.”

openblas has been a problem in upstream for quite a while now. I wonder why the package maintainer in Arch ARM has not done anything. It was even reported on their forum a while ago.

Hello, no more complete syntax highlighting under fish shell on tmux/byobu. No more light or dark blue colors, only some sorte of dark cyan color. Red, green and yellow seem OK.

fish -v
fish, version 3.2.2
byobu -v
byobu version 5.133
tmux 3.2a

Fish’s syntax highlighting without tmux/byobu is OK.

Seem to be a tmux’s problem because no update for fish or byobu this time, only tmux. I send a bug report to Tmux developers.

This is not a tmux issue, it seems. After reboot, complete color scheme works properly under X, but not in tty.

In tty, syntax highlighting do not work properly, some colors are missing.

msgcat --color=test

In tty only 7 colors plus black, white, and grey (10 colors).