[ARM Stable Update] 2021-06-04 - Cutefish, Thunderbird, QT6, Foot and Kernels

Hello ARM community.

Pretty big update, with lots of perl, python and mobile stuff.

Curefish is a new DE, designed for tablets and desktop, based on qt and plasma!


Some highlights:

  • Most of our kernels got updated
  • Cutefish got added to the repository
  • And QT6 got it’s first major point release with 6.1.0
  • Thunderbird also got a new point release with 78.10.2
  • Introducing Foot terminal emulator to the repository
  • Lots of Perl packages got updated to work with 5.34
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker linux-rpi4 xf86-video-fbturbo-git

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

over_voltage=5
arm_freq=2000
#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d,cma-512
#max_framebuffers=2    #disable cause kodi uses more
dtoverlay=rpivid-v4l2
disable_fw_kms_setup=1

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.


Upstream Notifications:

Older notifications

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

The nss and zn_poly packages requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
https://www.archlinux.org/news/zn_poly-092-2-update-requires-manual-intervention/

The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package changes:

(Fri Jun 4 12:22:27 CEST 2021)

  • arm-stable community aarch64: 1264 new and 1123 removed package(s)
  • arm-stable core aarch64: 60 new and 56 removed package(s)
  • arm-stable extra aarch64: 469 new and 444 removed package(s)
  • arm-stable kde-unstable aarch64: 400 new and 392 removed package(s)
  • arm-stable mobile aarch64: 0 new and 2 removed package(s)

See all the package changes here !


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Donation

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

Poll

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Hi,

Is this up date available for the Odroid C2 ?

Would foot happen to be a suitable mobile app?

Don’t think so. It’s going to be used in the Sway edition.

We don’t include/exclude devices from our updates. They all get them as they are based on the same repositories.

Not a huge issue for me, but anbox is now broken on my pinephone. Replacing the env EGL_PLATFORM=x11 in the anbox.desktop file does not resolve the issue. I will investigate further this weekend.

Since last stable update start menu acts like this:

I’ve installed the latest kernel, but it hasn’t fixed this problem.

Hm. That’s a weird one.

As a test, can you try killing conky and see if that makes a difference?

Thanks for your answer.

The question was, is it possible to build an image for the Odroid C2 ?
Unfortunately the C2 don’t boot with the last image I built.

Odroid N2 kde up to date, Enjoy ! :-)

Hello,
This is my first post. Congratulations and thanks to the Manjaro Team & All contributors!

I’ve got last week my new RPi 400 and I started with RPi OS 32-bit Desktop on a new µSD card. As I was not completely satisfied I decided to look for an alternative.

Already using Manjaro Cinnamon on one of my PC (laptop) and being very pleased with it, I decided to give a try to Manjaro-Arm MATE. It was installed 2 days ago followed by a full update. Everything went very well except for JACK/ALSA and some Audio/MIDI applications.

Today I updated the OS to the latest version and my problems are still around, in summary:

  • HDMI (output): JACK (QjackCtl) / ALSA (Qsynth) are working well but Qsynth’s Audio is bypassed so I cannot control the volume by the OS but only directly from inside the application. And both Reverb and Chorus are inactive.
    I have the following message in the app and son on…
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition ‘cards.bcm2835_hdmi.pcm.front.0:CARD=0’
    ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_refer returned error: Aucun fichier ou dossier de ce type
    ALSA lib conf.c:5233:(snd_config_expand) Evaluate error: Aucun fichier ou dossier de ce type

  • Audio/USB Dongle (I/O): The situation is better. I can now control the volume with the OS but still both Reverb and Chorus are inactive in Qsynth.

  • PURE DATA: is not working at all. When trying to launch it from a terminal I get: "application-specific "initialization failed: unknown color name “BACKGROUND” and the cursor is blinking. I tried to reinstall it but still the same issue. Searching on the web was not helpful.
    I was not able to test PURR DATA as it’s not available yet for ARM 64-bit.

  • GPIO: I installed all the 4 available packages from the software center; i.e. gpio/utils, libgpiod, python-gpiozero and python-raspberry-gpio. Then running ‘pinout’ in a terminal prints:
    raceback (most recent call last):
    File “/usr/bin/pinout”, line 33, in
    sys.exit(load_entry_point(‘gpiozero==1.6.2’, ‘console_scripts’, ‘pinout’)())
    File “/usr/bin/pinout”, line 25, in importlib_load_entry_point
    return next(matches).load()
    File “/usr/lib/python3.9/importlib/metadata.py”, line 77, in load
    module = import_module(match.group(‘module’))
    File “/usr/lib/python3.9/importlib/init.py”, line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
    File “”, line 1030, in _gcd_import
    File “”, line 1007, in _find_and_load
    File “”, line 986, in _find_and_load_unlocked
    File “”, line 680, in _load_unlocked
    File “”, line 855, in exec_module
    File “”, line 228, in _call_with_frames_removed
    File “/usr/lib/python3.9/site-packages/gpiozerocli/pinout.py”, line 27, in
    from gpiozero import pi_info
    File “/usr/lib/python3.9/site-packages/gpiozero/init.py”, line 79, in
    from .output_devices import (
    File “/usr/lib/python3.9/site-packages/gpiozero/output_devices.py”, line 26, in
    from colorzero import Color
    ModuleNotFoundError: No module named ‘colorzero’
    So I cannot access to the GPIO.

Some wishes (missing default apps &/or utilities), I had to install among others:

  • Mate Menu Manager,

  • Mate System Monitor,

  • Gnome Disks,

  • GIMP,

  • VLC (but it’s missing the Fluidsynth/Soundfont plugin),

  • Sonic Pi working great (was 1st design for RPi!)

  • Etc.

  • Last but not least, Manjaro-Arm 64-bit (Firefox) is performing much better than RPi OS 23-bit (Chromium) with high definition video. My RPi 400 is currently overclocked to 2.2 GHz (SOC).

  • I was also obliged to make some fine tuning for my wireless mouse (usbhid.mousepoll=4 (8 default) in cmdline.txt).

Thanks. Best,

1 Like

By the way, I have forgotten at least one thing:

  • HDMI (Output): With Sonic Pi / SuperCollider the issue is the same than with above JACK/ALSA; i.e. I can’t control the volume with the OS only from inside Sonic Pi. Using an Audio/USB dongle, the problem is fixed.

Thanks.

Beelink GT King Pro, XFCE, update to date. But initial “sudo pacman -Syu” was not successful.

error: failed to commit transaction (conflicting files)
linux-firmware: /usr/lib/firmware/brcm/brcmfmac4356-sdio.khadas,vim2.txt exists in filesystem (owned by kvim2-firmware)
Errors occurred, no packages were upgraded.

This is the second time I get this same error (previous system update had the same error). Resolved this by renaming the file to another name. After that the system updated successfully.

Is there a way to resolve this so that the next update it will not occur again?

I believe @spikerguy fixed it in unstable branch already. So yes, next update should have this fixed.

1 Like

conky was not the impostor

In the meantime I went back to the 5.7.19 kernel. The other start menu is also affected (since the last stable update). The only things reacting to the mouse cursor hovering over them in the second menu are the favorite icons:

But I don’t know if this is a correct behavior or there should be a selection square around the brightened icon, because I wasn’t using this menu before.

Hello!
Just the same on the vim2 max.
Did just the same (rename existing sdio.txt) and update went fine.
Alas, wifi isn’t working. Error -2…
Any idea, please?

Hello,

With RPi 400 / Manjaro-Arm MATE.
After the yesterday system update I tried to install HPLIP v.3.21.4-1 and its dependencies from the Software Manager. Everything went well.
Then I ran HPLIP - Setup device… - Device Discovery - Network/Ethernet/WiFi network - Select from Discovered Device: HP Officejet Pro 8710 - Setup Device: All info are okay for both Printer Setup & Fax Setup → Add Printer: No Installed HP Devices Found!
I tried several times, but still with the same issue.

From within HPLIP: Device - Diagnose HPLIP Driver…I’m getting a long list within a terminal with the following errors (in red) like:
error: cups CUPS - Common Unix Printing System REQUIRED 1.1 2.3.3 MISSING ‘CUPS may not be installed or not running’
error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING ‘python3-notify2 needs to be installed’
error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING ‘python3-pyqt4-dbus needs to be installed’
error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING ‘python3-pyqt4 needs to be installed’
error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - - MISSING ‘gcc needs to be installed’
error: make make - GNU make utility to maintain groups of programs REQUIRED 3.0 - MISSING ‘make needs to be installed’
and so on…

Thanks.

RPi 400 / Manjaro-Arm MATE:
In Pamac, it’s missing Raspberry Pi Imager.

Thank you @Strit and @spikerguy

@Strit @Lila-Kuh

This afternoon I built an image (kde) for the Odroid C2, unfortunately it doesn’t work, same issue as the last time, no blinking blue led and then nothing.

d0bc16c8873b6841cab2ffac91285bb914e2a046_2_690x263

Like in the past, no problem to do some test for the C2 boot.

Post scriptum : I hope every C2 owner have a working power supply for the device :-)