Arm device update issue

after update from

warning: linux-rpi4-rc: ignoring package upgrade (5.12.rc8-1 => 5.15.rc3-1)
warning: linux-rpi4-rc-headers: ignoring package upgrade (5.12.rc8-1 => 5.15.rc3-1)

dvb-t2 signal from tv-hat using mpv play only audio if i try --hwdec=v4l2m2m-copy i have to set --hwdec=no while 5.12 is fine .

The linux-rpi4-mainline and linux-rpi4-rc kernels was broke @2 months ago. They have just now made it back in our repo; but it still is a Work In Progress. I would suggest trying the linux-rpi4 kernel.

1 Like

linux-rpi4

same problem no video on mpv only audio.

archlinux 5.12.0-rc8-1-MANJARO-ARM

is fine.

Not sure why you want to use --hwdec=v4l2m2m-copy with mpv or what has changed why you can not have it on your command line. If you are trying to get gpu hw decoding the only way I know of on the pi4 using a 64bit OS is with a special compiled kodi/player compiled with a special ffmpeg that uses V4L. It will do h.264 and h.265 HW decoding but will never do mpeg2 as the onboard chip is not capable of it.

I played a .mp4 with --hwdec=v4l2m2m-copy and with out and all it did was fallback to SW rendering with no difference with cpu usage.

On 32 bit os one could compile and install ffmpeg-mmal and mpv-rpi from AUR and mpv detects HW decoding automatically. This is not an option on a 64bit Os because of proprietary libs. You need to have a player capable of accessing the chip either like omxplayer which accesses at a lower level or one that will access at a higher level with MMAL.

I have used kodi with tvheadend as a backend in the past to get HW decoding with my satellite system but I have not tried it with the new kodi-rpi package to see how it does. I’m more into iptv these days.

1 Like

Not sure why you want to use --hwdec=v4l2m2m-copy

to keep CPU low

uname -a
Linux archlinux 5.12.0-rc8-1-MANJARO-ARM #1 SMP PREEMPT Mon Apr 19 14:53:34 UTC 2021 aarch64 GNU/Linux
[alarm@archlinux ~]$ pacman -Qi ffmpeg
Name : ffmpeg
Version : 2:4.4-4
Description : Complete solution to record, convert and stream audio and video
Architecture : aarch64
URL : https://ffmpeg.org/
Licenses : GPL3
Groups : None
Provides : libavcodec.so=58-64 libavdevice.so=58-64 libavfilter.so=7-64
libavformat.so=58-64 libavutil.so=56-64 libpostproc.so=55-64
libswresample.so=3-64 libswscale.so=5-64
Depends On : alsa-lib bzip2 fontconfig fribidi gmp gnutls gsm jack lame
libass.so=9-64 libavc1394 libbluray.so=2-64 libdav1d.so=5-64 libdrm
libfreetype.so=6-64 libiec61883 libmodplug libpulse libraw1394
librsvg-2.so=2-64 libsoxr libssh libtheora libva.so=2-64
libva-drm.so=2-64 libva-x11.so=2-64 libvdpau libvidstab.so=1.1-64
libvorbisenc.so=2-64 libvorbis.so=0-64 libvpx.so=6-64 libwebp libx11
libx264.so=161-64 libx265.so=199-64 libxcb libxext libxml2 libxv
libxvidcore.so=4-64 libzimg.so=2-64 opencore-amr openjpeg2 opus sdl2
speex srt v4l-utils xz zlib
Optional Deps : avisynthplus: AviSynthPlus support [installed]
ladspa: LADSPA filters [installed]
Required By : chromaprint chromium ffmpegthumbnailer ffms2 firefox gst-libav
qt5-webengine simplescreenrecorder telegram-desktop tvheadend
vapoursynth
Optional For : libde265 youtube-dl
Conflicts With : None
Replaces : None
Installed Size : 30.09 MiB
Packager : Arch Linux ARM Build System builder+n1@archlinuxarm.org
Build Date : Thu 10 Jun 2021 04:41:23 PM CEST
Install Date : Wed 16 Jun 2021 09:05:16 PM CEST
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

When v4l2m2m-copy is on watching dvb-t2, with mpv, CPU is 80%, when hwdec=no CPU is 135% using hat-tv when video is h264 bitrate 6000kbps (sway wayland with Xwayland)

I have used kodi with tvheadend as a backend in the past to get HW decoding with my satellite system but I have not tried it with the new kodi-rpi package to see how it does. I’m more into iptv these days.

can i watch on kodi in screen 1 and browse on screen 2 at same time?

As what you’re trying to do currently is not possible,

you should currently just live with high CPU usage until upstream has fixed the issue.

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

No. The kodi-rpi packages in the repo were not made to run in a DE; it boots up in it’s own environment straight in to kodi when properly set up. Some have run it in the past in a DE but you loose HW decoding.

[Solved] linux-rpi4-udl is now on repo and run with hwdec=v4l2m2m-copy.

[alarm@archlinux ~]$ pacman -Qi linux-rpi4-udl
Name : linux-rpi4-udl
Version : 5.10.44-2
Description : The Linux Kernel and modules - Raspberry Pi 4 64-bit kernel with additional
DVB/ATSC/DVBT modules
Architecture : aarch64
URL : Ray Sherwin / rpi-linux-udl · GitLab

now mainline is fixed

Linux archlinux 5.14.9-1-MANJARO-ARM #1 SMP PREEMPT Fri Oct 1 10:10:07 CDT 2021 aarch64 GNU/Linux

Great! It had been in the repo and accidentally got deleted. I put it back a couple of days ago. I had it there in the first place because I have some extra opensource dvb/atsc/dvbt modules compiled in it that are not provided by upstream. It will also do Spectrum / Blindscan on satellites and terrestrial devices.

There is also a custom companion program called updateDVB that does the before mentioned tasks and from it you can launch mpv to play the stream. You can edit the mpv command line in the Settings. I have no clue if updatedvb will be compatible with your device but you can test and see.

I maintain these specially patched kernels for the pi’s and x86 on my gitlab for a satellite forum I am active in. There also is some extra firmware in the repo but I forgot the name of the package.

I froze it at this version as a backup because after that is where the rpi kernels starting having issues and it has everything the forum kernel does + the extra modules patched in.

My repos:

x86
RPi’s