Applications with GTK style not responding in dialog windows

Hi guys,

I have a problem with virtualbox (6.1.16 r140961) when running with KDE. The dialog boxes are not working, not responding when selecting f.e. another VDI disk within a VM configuration. Even the main “preference” configuration of Virtualbox itself is not responding. When configuring only with command line everything is working fine.

Since the application is rendered by GTK i presumed a problem corresponding the rights of my user or the one of the application. I set up another user and gave it a the XFCE desktop which lead to success.

Does anybody have the same problem and already found the solution?

Thank you very much in advance.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.9.11-3-MANJARO
OS Type: 64-bit
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 31.2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

1 Like

Virtualbox is a Qt application and uses the native file dialog in KDE Plasma by default.
Did you installed xdg-desktop-portal-gtk over the xdg-desktop-portal-kde ?

Hi, thanks a lot for your reply.

Yes. I read that Manjaro is not very happy if you do so, but I thought I give it a try and it worked. I can always rollback. I had the same problem with an other application, but unfortunately I don’t remember which one.

What worked? Is no longer an issue? The point is to not have both of those packages installed.

Hello I got the same problem. Uninstalled xdg-desktop-portal-kde and installed gtk one but I still have the same issue. Any chance did I misunderstand what to do to solve it ?

Thank you

1 Like

If you are on kde is better to use the kde portal.
If replaced with gtk one, then test if xdg-desktop-portal-gtk.service is loaded …

I replaced kde one just to solve the file dialog problem. Anyway, gkt.service is not loaded but also not found if I try to start via systemctl:

sudo systemctl status xdg-desktop-portal-gtk.service

Unit xdg-desktop-portal-gtk.service could not be found.

Same thing if I try to start it:

sudo systemctl start xdg-desktop-portal-gtk.service
Failed to start xdg-desktop-portal-gtk.service: Unit xdg-desktop-portal-gtk.service not found.

Sorry guys, was busy with celebrating the New Year. I wish you all the very best, be happy and healthy and always find a solution with IT problems.

It is not about the desktops. It is about KDE that has a problem with programs like virtualbox. When virtualbox runs with XDG but doesn’t run with KDE on the same linux kernel, then you can definitely blame KDE for being the sinner.

So in my opinion the discussion about desktops is leading in the wrong direction and since I think KDE is the best desktop I have ever seen I would like to pursue the problem solution as mentioned in my first post.

I can no longer reproduce the success of running virtualbox with XDG desktop. Both desktops do not work anymore.

I just tried Manjaro 20.2.1 KDE in a VM, but virtualbox and many other programs running GTK within KDE are still not working.

It seems that I am the only one in the community that is concerned about that …

1 Like

Having the same issue here on a freshly installed manjaro. Virtualbox is completely unusable and it is sad to hear that other gtk programs have similar issues. Is there a list of the affected programs?

@bithki dismissing the issue as a KDE problem appears weird. Virtualbox is happy on other KDE distros like kubuntu.

EDIT: this seems to depend on how recent your KDE is (kubuntu ships an older one).

This seems to be Virtualbox bug 20222 (#20222 (GUI BUG: file picker on Linux KDE Plasma does not handle mouse, unusable) – Oracle VM VirtualBox).

The workaround provided there seems to work. Namely use:


There seems to be a proper patch that is applied downstream by other distros (File vb-6.1.16-modal-dialog-parent.patch of Package virtualbox - openSUSE Build Service)