Applications icon missing in system tray

Yeah I’m pretty puzzled. Yep, all application icons are missing (e.g. Slack) but system icons like volume or bluetooth are there.

What about the obvious?

Right-click the System Tray → Configure System Tray → Entries

Everything looks normal there.

Try to create a new profile/user, then you can check if it has the same issue?

I tried it earlier and it’s totally fine for a new user.

That mean your main(old) user must have some bug or mess in the Home directory.

If you do not find the bug, then you can switch to the new user, then copy/move your important data into this user, then delete the old user.

Last try:

Log out. In a TTY2 terminal, delete this file:

rm -v -f $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc

Log back into KDE. Reconfigure your tray settings.


However, when you ran @brahma’s command earlier (with “find”), it sohuld have removed this file already.


Can you post a video or screenshot of exactly what this issue is? I’m still a bit confused.

The only screenshot you shared was of the collapsed tray “arrow”, which is normal behavior.


EDIT: Oh, okay, I get it now.

Then I must ask:

Does this seem to occur with AUR packages?

The PKGBUILD slack hasn’t been updated since September 2021. (Unless you mean the GTK-frontend slack-desktop)

It might have something to do with Qt / KDE / Plasma libraries being “too new” for certain older software applications.


As a test, can you install keepasxc and see if it shows up in the list of entries in your Configure System Tray settings?

I remember that file was removed yesterday when I tried it, so I don’t think it would help.

The issue appeared after the recent Manjaro update, and affects not just slack (which is provided by slack-desktop) but other applications too (Dropbox, Transmission, etc…) I tried Keepass and it’s the same there, no application icons show up. When I open these applications, no new entry appears in the System Tray settings.

Did you find a solution? I had this issue a few weeks ago, then an update fixed it. But the latest update has again broken it and I cannot afford to wait another few weeks for the next update to potentially fix it.
I documented my findings here: Dbus errors causing Kwallet to no longer work, system sluggish

Hi, I have the same issues. Fixed with a previous update, and then broken again with the last update. There are some additional symptoms which I believe are linked to the same issue:

  • Some system icons don’t show up in the system tray, not just applications, for instance battery indicator, mute mic icon, keyboard layout switcher if added.
  • On reboot, screen configuration and layout in a multi-screen configuration is not restored.
  • System is extremely slow to open files from Dolphin (30+ seconds)
  • Custom shortcuts menu is slow to open (1 minute) and custom shortcuts don’t work anyway, I believe it’s related to this issue Custom Shortcuts not working after update
  • Dolphin freezes when deleting files

What does journalctl -r show after opening an application, as well as after logging in?

If it’s the same issue as I’m having, there should be dbus response errors

Yeah, my bad, I should have been clearer on the symptoms. They are exactly the same, so I indeed have the dbus response error log.

For instance I have this message when trying to open the custom shortcuts menu (reproduced everytime)

mai 30 08:57:40 <hostname> systemsettings[5008]: Unable to start server org.kde.khotkeys (kded module) [ "org.freedesktop.DBus.Error.NoReply" ]: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

It seems that this issue is quite widespread, but because it effects so many different system components, all the information is spread over many threads. Hopefully someone can find a solution as this is severely impacting my productivity.

2 things to try:

  • System Settings > Startup and Shutdown > Background Services > Status Notifier Manager > Deactivate it and apply change and then activate it again and apply change.

  • If above didn’t help, call terminal and find potential errors with:

kded5 --replace

kded5 --version should give 5.94.0 with current updates

Perform a new logon afterwards.

Hi, I tried both suggestions.

Status Notifier Manager

When changing the Status Notifier Manager status, I get this message, which is the same I get when trying to update the custom shortcuts for instance.

I think that this log message on journald is related to it, it happens roughly at the same moment:

juin 06 07:45:09 xxx systemsettings[3972]: kcm_kded: Failed to get loaded modules “org.freedesktop.DBus.Error.NoReply” “Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the net
work connection was broken.”

kded replace

This command returns an error with DBUS:

➜ kded5 --replace                           
kf.dbusaddons: Couldn't register name 'org.kde.kded5' with DBUS - another process owns it already!

A new logon doesn’t to anything more after that.

I do have the expected version

➜ kded5 --version
kded5 5.94.0

@faercol I have the same issues, and also:

  • System Settings → Network → Settings → Cookies (probably related to the log lines about kded_kcookiejar)

Are there other threads you know of that cover this combination of issues?

@faercol I figured it out! Solved all issues including multi-monitor, system tray icon, custom shortcuts, cookies, etc.

2 Likes

Oh wow, that’s exactly it. I removed the ~/.config/kwinrc file, and it was fixed after a reboot. (did not have the konquerorrc)

Thanks a lot for everything!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.