Any USB Mouse Not Working

My USB mouse has suddenly stopped working on Manjaro linux. I’m on a laptop, and my touchpad and keyboard is working fine. I’ve tried many solutions from this forum and others, however, none of them seem to do the trick. I’m running GNOME on Manjaro linux.

I ran “sudo libinput debug-events” and tried moving my mouse, and I can see the events are being captured perfectly. I suspect it’s something in the X11 config or something similar, but the cursor is not moving nor the click is working.

Much appreciated if someone can help.

Below are my system details

CPU: dual core Intel Core i5-5200U (-MT MCP-)
speed/min/max: 2207/500/2700 MHz Kernel: 5.15.16-1-MANJARO x86_64 Up: 30m
Mem: 2937.9/7864.7 MiB (37.4%) Storage: 465.76 GiB (6.5% used) Procs: 225
Shell: Zsh inxi: 3.3.12

Please find the xinput list output

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SYN1B7E:01 06CB:2970 Touchpad           	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Lid Switch                              	id=8	[slave  keyboard (3)]
    ↳ Video Bus                               	id=9	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=10	[slave  keyboard (3)]
    ↳ HD WebCam: HD WebCam                    	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=14	[slave  keyboard (3)]

How to increase your chances of solving your issue:

Please provide Information: