Any luck with Wine/Box86?

Running KDE Plasma on a RPi4.

I’m just curious if anyone has had success with Wine or Box86. A few threads all seem to be dead-ends. I’m pretty new to this sort of thing and just know about Wine. If there are additional alternatives, I’d love to hear about them.

It’s certainly not essential, but I just want to run Dwarf Fortress (released for Windows, Mac, and Linux[obviously x86 and x64, but not for ARM]) if it’s possible.

All I know is the post here in our forum starting with this post:

https://forum.manjaro.org/t/how-to-install-box86-on-manjaro-arm64/43473/10

Hmm… I spent the last two hours trying this - which failed at the wine step (I’d guess, just out of date ubuntu image, maybe? It failed when trying to find freetype, and ncurses, despite ncurses being present for sure, and freetype should be there too.)

Part of this process might be useful, though. If I can use Ubuntu x64 or x86, rather than armhf, that’ll be enough. Pretty far out of my depths here, but I’ll see if I can figure it out.

I also found Box64 - which has been in the repositories for a couple months. Missing libraries makes it not useful, unfortunately (libraries I can’t get, such as libgtk-x11.)

What libraries? for LibGTK see this issue: Error FARA64 Linux libgtk · Issue #128 · ptitSeb/box64 · GitHub and this issue: libgtk-x11-2.0.so.0 - missing, but it's right there! · Issue #92 · ptitSeb/box64 · GitHub. So seems like it might work in next release of Box64.
Pretty sure others have it working.

All dependencies should be defined in the CMakeLists.txt files in the source and it will not compile if one of them is missing.

I’m not using cmake with box64 - when you say “it will not compile”, what do you mean?

For Dwarf fortress:
libgtk-x11-2.0.so.0, so this exact issue someone else had. I’ll see if I can get it working.
Also needs libgraphics.so, which I haven’t looked into yet.
(dropping the x86_64 libgtk-x11 seems to have worked, though I still need to find and drop in more libraries. I’ll keep pursuing this.)

I also tried running a different game, which said “Stack corrupted” and aborted. As this is just turning into Box64 discussion, I’ll see if I can figure it out from ptitSeb’s documentation.

EDIT: In case anyone else rolls through this thread I ultimately abandoned the effort. Searching for libraries and dropping them one-by-one got tedious, and I started to get errors related to libraries mismatching (presumably not available on the RPi).