Another boot issue

I am also having this same problem after installing updates. then I rebooted and now I cant get back to the desktop.
maybe I’m just dumb but from what I understand it’s because I updated the kernel and to fix it I either need to go back to the previous kernel or update to a newer kernel. the only problem is I cant get back to the desktop to change the kernel.
but this post was from 9 months ago so I’m not even sure that this is the reason why I’m having this problem. i need help.

manjaro wiki kernel change:

And allways install 2 kernels (one LTS) so you can switch when necessary

those all involve being able to boot onto the operating system I cant get in the OS.
how do I get past this screen with the error?

somehow I was able to get into the OS. so I installed 2 other LTS kernels.
but when I go to boot from either one in grub I get the same error message.
and now I can’t get back into the OS.
I did find that while I’m on that screen if I mash my keyboard I can get to a terminal of some kind and I can log in. I ran the mhwd-kernel -li command and I could see that I have 3 kernels installed.
but I’m not sure what to do with that to fix my problem.

sooo… still no solution to this problem.
I really don’t want to have to reinstall the OS.
so I guess it’s not the kernel because I tried other kernels. unless all 3 kernels I tried all had the same problem. maybe it’s something I installed?
what does the error even mean?
What’s an IRQ handler? and what vector is it referring to?

can you report

inxi -Fza

I assume this is a command of some kind you want me to type in.
where do you want me to input it?
in Grub terminal?
or in the terminal I was able to get to by mashing my keyboard while its stuck on that boot screen?

Please help. I hate having to use windows.

is any USB live manjaro working ?
if so boot on USB live manjaro
open a terminal & browser on this topic
and returns

inxi -Fza 
1 Like

ok I booted from my old installation of manjaro on my HHD
this is the output:

[kodi4444@kodi4444-GamingPC ~]$ inxi -Fza
System:    Kernel: 4.19.167-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=4b6acf4a-1d27-4438-a256-da251f47b93f rw quiet 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 2607 date: 08/14/2020 
CPU:       Info: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701021 L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 182057 
           Speed: 1970 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 1970 2: 2207 3: 2196 4: 2195 5: 1961 
           6: 2469 7: 2007 8: 3592 9: 2051 10: 2052 11: 2190 12: 2188 13: 2015 14: 2187 15: 2193 16: 2195 17: 2193 18: 3596 
           19: 2052 20: 2053 21: 2190 22: 2195 23: 2192 24: 2194 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 0a:00.0 
           chip ID: 10de:1c03 
           Display: x11 server: X.Org 1.20.10 driver: loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           display ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 7040x1080 s-dpi: 96 s-size: 1863x286mm (73.3x11.3") s-diag: 1885mm (74.2") 
           Monitor-1: DP-2 res: 1280x1024 dpi: 68 size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
           Monitor-2: HDMI-1 res: 1920x1080 dpi: 81 size: 600x330mm (23.6x13.0") diag: 685mm (27") 
           Monitor-3: HDMI-2 res: 2560x1080 hz: 60 dpi: 81 size: 798x334mm (31.4x13.1") diag: 865mm (34.1") 
           OpenGL: renderer: NV136 v: 4.3 Mesa 20.3.3 direct render: Yes 
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
           chip ID: 10de:10f1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.4 chip ID: 1022:1487 
           Device-3: C-Media Blue Snowball type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-1:2 chip ID: 0d8c:0005 
           serial: <filter> 
           Sound Server: ALSA v: k4.19.167-1-MANJARO 
Network:   Device-1: Realtek driver: r8169 v: kernel port: e000 bus ID: 04:00.0 chip ID: 10ec:8161 
           IF: enp4s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k v: kernel port: e000 bus ID: 05:00.0 
           chip ID: 168c:0030 
           IF: wlp5s0 state: down mac: <filter> 
           Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 06:00.0 chip ID: 10ec:8168 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 4.55 TiB used: 105.91 GiB (2.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS500G2B0C-00PXH0 size: 465.76 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 211070WD 
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HUA723020ALA640 size: 1.82 TiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: A870 
           ID-4: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HUS724020ALA640 size: 1.82 TiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: NS00 
Partition: ID-1: / raw size: 628.52 GiB size: 617.65 GiB (98.27%) used: 105.89 GiB (17.1%) fs: ext4 dev: /dev/sdb3 
           maj-min: 8:19 
           ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 25.5 MiB (26.6%) fs: vfat dev: /dev/sda2 maj-min: 8:2 
Swap:      Alert: No Swap data was found. 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 419 Uptime: 4m wakeups: 0 Memory: 62.88 GiB used: 2.61 GiB (4.2%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 alt: 8/9 clang: 11.0.1 Packages: pacman: 1545 lib: 434 flatpak: 0 Shell: Bash v: 5.1.0 
           running in: xfce4-terminal inxi: 3.2.02 

Try to switch the IOMMU setting in BIOS.

Also your BIOS is very outdated.

And I hope you’re not using the 4.x series kernel with your modern hardware. Use latest kernels.

can you please returns

sudo pacman-mirrors -c all
sudo pacman -Syyu

this was from my old installation of manjaro so the kernel is equally as old.
I am using a much newer kernel on my new installation of manjaro.

what is this?
is this a list of all the things I have installed?

I can get into the terminal if someone knowledgeable can guide me through fixing this problem.
finding out why I’m getting this error then fixing the problem.
please I really don’t want to have to reinstall.
if i knew what this error meant then i might be able to figure out what i did to break it.

nobody can help me?

on my side if I don’t get a reply to my message I’m not wasting more time so maybe reply to messages.

I believe I did reply to you.
but regardless, I updated my BIOS and that didn’t fix it. I couldn’t find IOMMU. what is IOMMU?

You did reply, but not to my message. I even quoted so it is crystal clear what I’m talking about.

Search for IOMMU in the BIOS manual.

Also when you don’t know something, good practice is to search for the word on a search engine to at least try to understand iommu - Google Suche

ok IOMMU was on auto so I tried enabled and disabled and neither worked.