Amlogic TV box wiki page

sorry i am new to this forum sorry

Not telling you off, just highlighting a minor mistake. Everyone makes mistakes, new or not.

1 Like

I have updated the wiki page to include a ‘Hardware accelerated video playback’ section and I’ve added a link to a dtb for X96 Max Plus models with the rtl8822cs wifi chipset.

I’ve been preparing a video comparing the X96 Air to the RPi 4 and the Jetson nano, which should be done in the next few days. I found I get the best results from mesa/glmark2 etc by running sway but I had problems running the recommended wayland terminal, alacritty. I got that working in the end so I’ve added a new section to the sway page on the Arch wiki about Wayland terminals:

https://wiki.archlinux.org/title/Sway#Terminal

3 Likes

Waiting to see the comparison video.

Thank you for all your hard work.

1 Like

Thanks for your work , danboid !

I agreed that Manjaro ARM aml images that already contain the linux-aml kernel is necessary for new comers. I have a TV box which ships with S905M-B soc , 1G ram, 4G EMMC ,100M Lan port ,rtl8189etv wifi and 3 leds .After several tests with vim2 image, I figured out that mainline kernel 5.11 could boot into filesystem while 5.13 not, which means you could not boot if you flashed later releases like 21.06 or updated from 21.04 directly without some tweaking. You could read the details in my post :

Best regards .

Yes would create a new amlogic image which will use linux-aml and can also let the users select the dtb to be used.

1 Like

I got RTL8189ETV (may also works with rtl8189es) working with jwrdegoede/rtl8189ES_linux:
(kernel : 5.13.12-1-MANJARO-ARM #1 SMP Wed Aug 18 07:36:58 UTC 2021 aarch64 GNU/Linux)

git clone https://github.com/jwrdegoede/rtl8189ES_linux.git
sudo pacman -S linux-headers
cd /usr/lib/modules/5.13.12-1-MANJARO-ARM/build/arch
sudo mv arm armold
sudo mv arm64 arm
cd ~/rtl8189ES_linux/
make -j4 ARCH=arm KSRC=/usr/lib/modules/5.13.12-1-MANJARO-ARM/build
sudo cp 8189es.ko /usr/lib/modules/5.13.12-1-MANJARO-ARM/kernel/drivers/net/wireless/realtek/
sudo depmod -a
sudo modprobe 8189es

Check with nmtui or ip addr and rename arm&arm64 back.

1 Like

The Amlogic TV boxes page needs a few updates, mainly to mention that eMMC installation is now an option.

I’m thinking of adding Burn card maker to the Unbricking section but only if some AML TV box users can confirm it works for them because it hasn’t worked to unbrick my X96 Air. If you’ve had burn card maker work to unbrick your TV box then please provide some instructions and I’ll add it as an unbricking option before suggesting shorting eMMC pins. Should I expect to see something output via HDMI after booting off a burn card maker created SD card? I don’t.

As far as I’m aware, there is no Linux or Mac alternative to burn card maker, is there?

I have updated the AMlogic TV boxes wiki page to fix the example commands for the new boot structure, added a mention of the eMMC install script and rewrote the Unbricking section to link to a different video and a guide to creating recovery SD cards under Linux and Windows:

1 Like

Thank you very much for your effort and support for Manjaro ARM Project.

1 Like

Thanks for your great efforts in supporting Manjaro ARM @spikerguy !

1 Like

I updated this page yesterday to note that TV box users should install the linux-odroid kernel to increase the chances of getting onboard wifi to work. Until yesterday it still referenced the old linux-aml kernel which hasn’t been updated in a while.

1 Like

Hi everyone, great support here and a warming hello from my me.
Today was a productive day, yet i thought, and i gave the following a try.
I have a X92 S912 amlogic tv box running on ARMBian UOS. As that is discontinued since 2020 i wanted to deploy Manjaro but that wouldnt boot from SD.

As the forums inform me to do is to modify a ini file in the boot which is not available in newer builds.
I modified the extlinux.config with the information in the latest generic ARM build like so:

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/amlogic/meson-gxm-vega-s96.dtb
APPEND initrd=/initramfs-linux.img root=PARTUUID=787e7833-02 rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 quiet splash plymouth.ignore-serial-consoles

This is what i have with my armbian, which boots like a charm:

LABEL Armbian
LINUX /zImage
INITRD /uInitrd

FDT /dtb/amlogic/meson-gxm-vega-s96.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0

I add the boot.ini from the VIM2 build as it is also running the S912 SOC, which is not pretty different compared with the chips it is running on and using for the peripherals.

Could someone point me in the right directions before i start pulling my hair out :smile:

Hello and welcome to the forum,

Do you have Armbian on emmc or sdcard ?

Vim2 images will not work on generic tv boxes anymore.
You will need to use Manjaro Arm image from either AM6 or GTKingpro.
Change the dtb name in uEnv.ini file in boot partition. This should work as long as you have Android in emmc.

Still if it does not work then you will have to share uart logs to understand what is happening inside.
I do not know anyone who have this tv box model who can help you look into this post.

1 Like

Hi Spikerguy,

Armbian was running from sdcard, android 7 was installed.
I installed it now on emmc, but i can revert to android 7 as this is necessary to have the dual boot.
I’ll download the AM6 rom, (Couldnt find the GTKingpro?) and try again after i flashed Android back.

Where do i find these UART logs, are these stored on the SDCARD or do you want an output of the UART port while booting? The second one, i need to verify if there is an UART port and how i can use it.

Will post updates soon, thanks so far :).

1 Like

Hi everyone,

The S912 boots with the Beelink image. (HERE) I had to modify the DTB. I used the Q201 as the android 7 uses this in the recovery mode. Will check the S96 later on. I used the KDE and XFCE image, no major changes.

What i did notice is that is slow when using pendrives and SD cards to boot from.
I got a USB 3 SSD now attached, its faster but not breaking world records as the ports on the device are USB2. Need to figure out how to deploy to EMMC maybe this will resolve the slowness issues.

//Update 2: Found the script for the EMMC in /boot/ and it is working.
SUDO BASH \boot\SCRIPT

Updating seems to be ok, drivers are also installed without problems.

1 Like

Please share the accurate name of your device and the dtb you used.
If you have link of the devices then it’s helpful.

I will add it to the first post for any other user who might have same devices.

Thanks.