Manjaro arm on Amlogic Tv box?

This is for HW Accel when you are on Xorg only.

I’ll give it a shot later , as I’ve encounted a weired issue .
Vim2 Sway 21.08 restarts after the first time configuration , and boots into desktop normally ,which is by far all good . However ,the next reboot ( 3rd boot ) fails to enter desktop . From dmesg I see this line :

lima d00c0000.gpu: dev_pm_opp_set_regulators: no regulator (mali) found: -19

I reflashed Vim2 Sway 21.08 again yet ran into the same issue : Failed to boot desktop at third boot . I could not do fsck as /dev/mmcblk0p2 is mounted . Will try another SD card later .

Gnome is not good for your s905. Sway works because is not a desktop one but a windows manager like openbox or icewm.

You have to remove any khadas package that can change your system.

About the driver I am thinking about dkms-mali-utgard. I think is in the repo.

I solved my issue with sway :

Just replace “oem” with your actual user name :slight_smile: Seems the bug in install script have not been fixed yet which results in greetd.service fail.

I’m using Beelink gtking on Manjaro-ARM-xfce-vim3-21.08 using meson-g12b-gtking.dtb.
Ethernet is working but wifi not working. dmesg | grep brcm only return bluetooth.
How to resolve this?

Try compile driver . I compiled driver of rtl8189etv and made it working :

I am not familiar but the instruction look straight forward. How to find the Wifi model?

With GT King Pro (wifi-5) the wifi and bluetooth firmwares:


Are you having the new GT King with wifi-6 model?

Please advice such wifi module is used it gt king as I have pro version and wifi works with our firmware package.

Or send with the serial number on the back of your device, i will get board schematic from beelink support team.

Yes is a newer model with wifi-6

My serial number start with 6B9X.

From Beelink site, I will need to choose firmware that says:-
This firmware is suitable for GT-King with SN code starting with C92X, SA9X, SA9X, 6B9X.

It is using AP6275S, a quick google search shows its a wifi6 chip so I am not sure if the firmware is available for linux.

Till then you will have to use usb-wifi dongle. :wink:

Good Luck.

Thanks for the findings. Will search for it.
For now, I am using cable.

1 Like

Cloning a functioning/bootable USB Stick/SD Card with Linux OS to another USB Stick/SD Card but with different Disk Size

Hi, I am relatively new in Linux commands/apps and would like to clone/copy an existing fully functioning/bootable USB Flash/SD Card with Linus OS to another USB Stick/SD Card that have a different memory size.

In this actual instance I have a fully functioning Manjaro OS on an old 8GB USB Flash (USB 2.0) and would like to clone/copy it to a USB Flash (64GB/32GB USB 3.1). Similar situation with an Ubuntu OS USB on SD Card

Is there a user friendly App to do this? Some detail guides would be much appreciated.

Edit: 2021-10-02. Found the solution to clone the USB 2.0 USB Flash to USB 3.0 USB Flash.

dd if=/dev/sda of=/dev/sdb status=progress

Took around 1300 seconds to complete cloning the 8GB USB 2.0 Flash. After successful cloning and boot up, use fdisk or gparted to resize the new USB 3.0.

1 Like

Chromium with Ozone-Platform=Wayland Activated Can Cause Manjaro-Arm-Gnome Edition To Activate Logout Screen By Itself After Running For More Than 60 Minutes When You Select/Click Application Menu

Hi, Just checking whether any of you had encountered similar situation. i have been testing/trying Chromium with Ozone Platform=Wayland since on Manjaro-Arm-Gnome in June 2021 and had encountered the above situation a few times. The terminal command line use:

chromium --enable-features=UseOzonePlatform --ozone-platform=wayland --enable-gpu-rasterization --enable-zero-copy --ignore-gpu-blocklist --incognito --in-process-gpu

The situation that led to Manjaro-Arm-Gnome to Auto Logout (that i.e. Login Screen appearing by itself) that I can relate to is when after running Chromium with Ozone-Platform=Wayland Enabled for a while (say 60 minuts to 180 minutes) and you happen to select/click Application Menu that triggers the Logout.

 jfl@MNJROGTKPro    inxi -Fxza
  Kernel: 5.14.8-1-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: root=PARTUUID=a43f02e9-02 rootflags=data=writeback rw 
  console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 
  fsck.fix=yes net.ifnames=0 audit=0 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro ARM base: Arch Linux 
  Type: ARM Device System: Beelink GT-King Pro details: N/A 
  Info: 6-Core (2-Die) model: N/A variant-1: cortex-a53 
  variant-2: cortex-a73 bits: 64 type: MCP MCM arch: ARMv8 family: 8 
  model-id: 0 stepping: 4 
  features: Use -f option to see features bogomips: 0 
  Speed: 1000 MHz min/max: 100/1992:1908 MHz Core speeds (MHz): 1: 1000 
  2: 1000 3: 1000 4: 1000 5: 1000 6: 1000 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 mitigation: __user pointer sanitization 
  Type: spectre_v2 status: Vulnerable 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: meson-g12a-vpu driver: meson_drm v: kernel bus-ID: N/A 
  chip-ID: amlogic:ff900000 class-ID: vpu 
  Device-2: meson-g12a-mali driver: panfrost v: kernel bus-ID: N/A 
  chip-ID: amlogic:ffe40000 class-ID: gpu 
  Device-3: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: kernel bus-ID: N/A 
  chip-ID: amlogic:ff600000 class-ID: hdmi-tx 
  Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
  loaded: modesetting display-ID: 0 resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mali G52 (Panfrost) v: 3.1 Mesa 21.2.2 
  direct render: Yes 
  Device-1: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: kernel bus-ID: N/A 
  chip-ID: amlogic:ff600000 class-ID: hdmi-tx 
  Device-2: axg-sound-card driver: axg_sound_card bus-ID: N/A 
  chip-ID: amlogic:sound class-ID: sound 
  Sound Server-1: ALSA v: k5.14.8-1-MANJARO-ARM running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.37 running: yes 
  Device-1: meson-g12a-dwmac driver: meson8b_dwmac v: N/A port: N/A 
  bus-ID: N/A chip-ID: amlogic:ff3f0000 class-ID: ethernet 
  IF: eth0 state: down mac: <filter> 
  Device-2: pwm-clock driver: pwm_clock v: N/A port: N/A bus-ID: N/A 
  chip-ID: pwm-clock:wifi32k class-ID: wifi32k 
  IF-ID-1: wlan0 state: up mac: <filter> 
  Device-1: meson-gx-uart driver: meson_uart bus-ID: N/A 
  chip-ID: amlogic:ffd24000 class-ID: serial 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Local Storage: total: 114.92 GiB used: 10.11 GiB (8.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/mmcblk1 maj-min: 179:0 model: SLD64G size: 57.62 GiB 
  block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
  rev: 0x8 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.00 scheme: MBR 
  ID-1: / raw-size: 57.07 GiB size: 56.11 GiB (98.32%) 
  used: 10.07 GiB (17.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot raw-size: 213.6 MiB size: 213.4 MiB (99.89%) 
  used: 48.7 MiB (22.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: zram size: 5.53 GiB used: 0 KiB (0.0%) priority: 100 
  dev: /dev/zram0 
  System Temperatures: cpu: 52.3 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 232 Uptime: 2h 25m Memory: 3.69 GiB used: 1.48 GiB (40.0%) 
  Init: systemd v: 249 tool: systemctl Compilers: gcc: 10.2.0 Packages: 
  pacman: 889 lib: 258 Shell: Bash v: 5.1.8 running-in: gnome-terminal 
  inxi: 3.3.06 
 jfl@MNJROGTKPro   
1 Like

Hi there,
I have a X96 Max Plus A100 4G/64G, also referred to as X96 Max Plus (2?) T100 in 4PDA Forum.
It has a Amlogic S905X3 Cpu and a “AM7256” (Broadcom 4354) Wifi Chip and a 100M Ethernet.

First I had SlimboxTV Firmware for X96 Max Plus A100 on the device, but the Bootloader from that Rom could not load Linux. So I prepared a SD Card with SD Burning tool, to load the Original Firmware for X96 Max Plus A100 from here:
I checked “update bootloader” and UNchecked “erase flash”. After the Update, the bootloader could load Linux, if I initially pressed the AV button, and after that just by inserting the MicroSD Card before boot.

I got it working first with Manjaro Arm XFCE for Vim3 21.03 Image from here:
With the change in extlinux.conf to FDT /dtbs/amlogic/meson-sm1-sei610.dtb , it is booting fine.

So I changed the X11 config to Option "AccelMethod" "glamor"
and tried to enable the sound with systemctl enable sound --now

But with the 21.03 Vim3 Image, I had no sound and no Wifi. And also the reboot did not work.

Fixing Wifi:
For the Wifi, the file brcmfmac4354-sdio.txt was missing, so I loaded the file from here:
(first google result) and copied the file to /lib/firmware/brcm/brcmfmac4354-sdio.txt
then the Wifi was working. Then I enabled the SSH Service with
sudo systemctl enable sshd and logged in over SSH.

I tested first to upgrade the linux (to 5.14.8-1) and linux-vim (to 5.13.5-1) package, but it was not working: It booted both only to an Error:
kvm: pmu event creation failed

So, I reverted back to the Kernel from the 21.03 Image and copied from the 21.03 Image (After mounting the Image with gnome-disk-utility) BOOT_MJRO/Image, BOOT_MJRO/Image.gz, BOOT_MJRO/initramfs-linux.img, ROOT_MJRO/lib/modules/5.11.4-1-MANJARO-ARM and ROOT_MJRO/lib/modules/extramodules-5.11-vim to my SD Card partitions.

Upgrade Linux and Packages: (Fix Sound and Reboot)
Then I tried the linux-aml (5.13.rc5-1) package with pacman -S linux-aml and it is working fine without the error. I the upgraded all the Packages with pacman -Suy --noconfirm and after that, I noticed that the Sound was working now. Also the reboot was working fine. Lastly I removed the orphan packages with pacman -Qtdq | pacman -Rns -

I have to give a big thank you to all the developers and contributors involved in this project.

Device: X96 Max Plus A100 4G/64G (also referred to as T100) with AM7256 Chip and 100M
Tested and working: HDMI Display, HDMI Sound, Wifi, USB, Reboot
Not tested but probably working: Bluetooth, Ethernet, AV Sound
Not tested: IR Remote, AV Video

  Kernel: 5.13.0-1-MANJARO-ARM aarch64 bits: 64 Console: tty pts/0 
  Distro: Manjaro ARM 
  Type: ARM Device System: SEI Robotics SEI610 details: N/A 
  Info: Quad Core model: N/A variant: cortex-a55 bits: 64 type: MCP 
  Speed: 1908 MHz min/max: 100/1908 MHz Core speeds (MHz): 1: 1908 2: 1908 
  3: 1908 4: 1908 
  Device-1: meson-g12a-vpu driver: meson_drm v: N/A 
  Device-2: meson-g12a-mali driver: panfrost v: kernel 
  Device-3: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: N/A 
  Display: server: 1.20.13 driver: loaded: modesetting tty: 80x24 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: meson-g12a-dw-hdmi driver: meson_dw_hdmi 
  Device-2: axg-sound-card driver: axg_sound_card 
  Sound Server-1: ALSA v: k5.13.0-1-MANJARO-ARM running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Device-1: meson-g12a-dwmac driver: meson8b_dwmac 
  IF: eth0 state: down mac: <filter> 
  Device-2: pwm-clock driver: pwm_clock 
  IF-ID-1: ip6tnl0 state: down mac: <filter> 
  IF-ID-2: wlan0 state: up mac: <filter> 
  Device-1: meson-gx-uart driver: meson_uart 
  Report: rfkill ID: hci0 state: up address: see --recommends 
  Report-ID: ID: hci1 state: up address: N/A 
  Local Storage: total: 87.71 GiB used: 5.65 GiB (6.4%) 
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SD32G size: 29.46 GiB 
  ID-2: /dev/mmcblk1 vendor: Samsung model: CJNB4R size: 58.24 GiB 
  ID-1: / size: 28.71 GiB used: 5.53 GiB (19.3%) fs: ext4 
  dev: /dev/mmcblk0p2 
  ID-2: /boot size: 213.4 MiB used: 123.6 MiB (57.9%) fs: vfat 
  dev: /dev/mmcblk0p1 
  ID-1: swap-1 type: zram size: 5.53 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
  System Temperatures: cpu: 49.3 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 185 Uptime: 1h 1m Memory: 3.69 GiB used: 560.5 MiB (14.8%) 
  Init: systemd Shell: Bash inxi: 3.3.06

Interesting to know your struggle.

Happy to hear that it’s working fine for you. Hopefully Ethernet should work too if it doesn’t then try a different dtb.

So You’re using linux-aml maybe you should move to linux pkg as it is upstream and regularly updated.

How did you know 21.03 Vim3 was the last of the Vim images that works with TV box?

Note: This is probably only relevant to DTB meson-sm1-sei610.dtb and X96 Max Plus A100/T100 (Wifi AM7256, Ethernet 100M)

with linux upstream and also in minimal vim3 Image from 20211004 I have this message in early boot and then a freeze:

kvm: pmu event creation failed -2

I am trying now to find the latest minimal vim3 release that boots without a freeze.

21.08 - Boot freezes after message:
kvm: pmu event creation failed -2
21.06 & 21.07 - Boot freezes after message:

reg-fixed-voltage regulator-ao_5v: Failed to register regulator: -517
reg-fixed-voltage regulator-emmc_1v8: Failed to register regulator: -517

21.04 - Booting but never gets to configuration, not freezing but infinite boot animation
21.03 - Booting and configuration

Now I am making a franken-image with Vim3 21.03 minimal, setting it up and then installing linux-aarch64 (5.14.9-2) from archlinux-arm to see wether the Error has been fixed in upstream Kernel from archlinux-arm.
Now I have downloaded linux-aarch64 from archlinux-arm, removed linux-vim with pacman -R linux-vim and installed linux-aarch64 with pacman -U linux-aarch64-5.14.9-2-aarch64.pkg.tar.xz
and linux-aarch64 5.14.9-2 is booting without problems and without Errors.
But HDMI Sound is not working with linux-aarch64 from archlinux-arm, and mkinitcpio -p linux-aarch64 gives me a missing module: display_connector, probably because the module is build-in, because it is loaded.

For Bluetooth Support, I also had to download this file:

and extract these files from the above archive to /lib/firmware/brcm/


and rename the file from the archive bcm4354.hcd to (uppercase) BCM4354.hcd and also put it in /lib/firmware/brcm/

After that, bluetooth pairing works with a PS4 Wireless Controller.

Not sure whether this is usefu for the new Beelink GT King Pro with WiFi 6. From Beelink Forum

At the moment I’m checking Coreelec because they already added wifi-6 ap6275 firmware to Legacy 4.9 kernel.