Amlogic TV box wiki page

Hi Spikerguy,

Armbian was running from sdcard, android 7 was installed.
I installed it now on emmc, but i can revert to android 7 as this is necessary to have the dual boot.
I’ll download the AM6 rom, (Couldnt find the GTKingpro?) and try again after i flashed Android back.

Where do i find these UART logs, are these stored on the SDCARD or do you want an output of the UART port while booting? The second one, i need to verify if there is an UART port and how i can use it.

Will post updates soon, thanks so far :).

1 Like

Hi everyone,

The S912 boots with the Beelink image. (HERE) I had to modify the DTB. I used the Q201 as the android 7 uses this in the recovery mode. Will check the S96 later on. I used the KDE and XFCE image, no major changes.

What i did notice is that is slow when using pendrives and SD cards to boot from.
I got a USB 3 SSD now attached, its faster but not breaking world records as the ports on the device are USB2. Need to figure out how to deploy to EMMC maybe this will resolve the slowness issues.

//Update 2: Found the script for the EMMC in /boot/ and it is working.

Updating seems to be ok, drivers are also installed without problems.

1 Like

Please share the accurate name of your device and the dtb you used.
If you have link of the devices then it’s helpful.

I will add it to the first post for any other user who might have same devices.


Or you could add it to the recommended dtb files section of the wiki page

Hi Spikerguy,

The box is OTT TV BOX X92 v2. YT link and Aliexpress link
The DTB is the GXM Q201 in the DTB folder of the image.

The OS runs on the EMMC but (and this could be me) i noticed that Armbian runs a bit smoother.


I have added this info to the AML TV boxes wiki page. It should get updated /approved later today.

1 Like

Hello, I just tried the new KDE Manjaro version 22.08 for am6(b) plus. Is this box an abandoned project?

  • bad cpu and gpu operating frequencies
  • bad mmc, sd and usb transfer rate
    -no wifi
    -no spdif
    -no jack out
    -shutdown and reboot work randomly.
    -various error messages when starting.


Please share uname -a

If it is using linux or linux-khadas then please install linux-odroid as the kernel.

There was never a support for am6(b) plus yet as it have things which are not exactly as am6-plus.
I asked ugoos for schematic and they send me 2 screenshot of emmc and wifi and I cannot put time on it which such limited documentation.
I asked them to share schematic under NDA but they just shared screenshot of 2 page only.

Sorry for the bad experience but there is very little we can do if there is not documentation or bsp codes shared with us.

Also the OS no longer boots on the latest android image anymore so that is another issue that cannot be resolved until we know what is going on at BSP uboot level.

Did you update your eMMC Android version to latest firmware ?

Hi, I’m new here. So sorry if I’m posting in the wrong place.
I have a tvbox with the IK316 chip, I can’t find any bootable image on it. Does this generic image run on it? Can someone help me?


It is the first time i am reading about such model soc.

Quick search shows that it is some new soc from allwinner and there is no support for it in Mainline linux kernel.

Thanks, I’ll keep trying.
if I want to create an img compatible with it, where should I start?

Hello, sorry for the long response time :(.

Linux dams-pc 5.19.3-1-MANJARO-ARM-ODROID #1 SMP PREEMPT Tue Aug 30 18:36:06 UTC 2022 aarch64 GNU/Linux

it’s sad to read this, especially since they claim to have Manjaro support on their blog :frowning:
it would only require a minimum of effort on their part :frowning:

no, on the contrary thank you, you are doing an incredible job. I never thought such a small box could run Linux so smoothly. I’m just doing a review to see what can be improved. if it can help…

I solved this problem by using a gtking dtb and modifying it a bit. it seems to work quite well (in reading speed I went from 43mb/s to 145mb/sec anyway!). For sure it would go even better with the official data :frowning:

the latest drivers I found (firmware/brcm at 56dd5532128502a72d670387d2f7d5be52a5a178 · armbian/firmware · GitHub), I can’t really give an opinion since the room where the box is picks up wifi very badly, but for me it picks up better on linux than with the official ugoos firmware. (I had a material problem also at the level of the antenna connectors, a weld).

I think there is a big problem with the sound system. I just know that on android and librelec everything works…

now it works fine

-ext4-fs: mount option(s) incompatible whit ext2
-systemd-fstab-generator[222]: failed to create unit file /run/systemd/generator/boot.mount, as it already exists. Duplicate entry in /etc/fstab?
-systemd[216]: /usr/lib/systemd/system-generators/systemd-fstab-genrator failed whit exit status 1
-debugfs: directory ‘ff800280.cec’ whit parent ‘regmap’ already present !

yes but on linux the memory was incorrectly recognized.

Glory to the fanless!!

Thanks and if you can share the changes that you did then I can test it with latest firmware where it cannot find sdcard on kernel boot.

Did you use gtking or gtkingpro dts?

Thank you for all your effort.


I have tested with gtKing dts and it works fine as only change to am6 was the sdcard frequency.

Trying brcm firmware fails to load the wlan interface but firmware is loaded fine.

I will try multiple kernels to see if that helps.

The dtb:
It’s gtking dts modified. I just changed the gpu and cpu frequency (from dts kahdas vim3), wifi chip reference and sound card reference, it seems to me.

:+1: :+1:

personally I use linux kernel, it run smooth and i like the fact that the cores are not always at maximum frequency. on the other hand, with the linux kernel glmark2-es2-wayland gives me 1349 against 1759 with the odroid kernel; But it’s not that obvious in-game.

1 Like

It will be helpful if you can share the dts instead of dtb as i can read it from my phone. :wink:


No problem

Hello, @spikerguy do you know if it is possible to activate the spdif output of am6b+ box? if so, does this happen in the dtb? and/or in the system? does it require a driver? I don’t really know where to start

Yes it can be.

Yes just need to add the needed nodes for spdif.

Already present.

I am using gtultimate with spdif on le and it have the right support. For am6 i am not sure where to look for but check for similar soc which have spdif like gsking pro and try to use the spdif nodes from there in am6 plus you will need audio routing alsa script or you can play with alsamixer.

You will need the optical cable inserted for it to appear.

1 Like

I’ve just made a few updates to the Amlogic TV box wiki page, most importantly I’ve updated the aml-flash-tool instructions to note that users must install libusb-dev or libusb-compat or whatever libusb 0.1 is called in your distro. No doubt several have read the Manjaro TV box wiki page and wondered why they couldn’t flash their box under Linux - that is most likely why!

I also want to add a photo of the maskrom contact pads for my X96 Air q1000 to the wiki page but I’m not sure uploading pics to the wiki works? Do I have to upload images to another image hosting site (or github maybe)? I’ve tried uploading an image to the wiki but it says I don’t have permission, even though its a page I created and can edit?

Here’s the image I want to add to the wiki:

When I try uploading an image to the Manjaro wiki, I cannot dismiss the window that appears telling me I don’t have permission to do that. I lost and had to redo about an hours work because of this, because I’d not save my changes before I tried to upload an image.

Finally got sometime to look into Ugoos AM6 Plus and AM6B Plus.

I have most of the IO working on both devices, now I have to find why mmc breaks on newer android firmware.

I will do some test soon with new firmware to figure out the issue. Chewitt have taken some interest in preparing AM6Plus dts so hopefully we can get it upstreamed.