All Applications are gone after updating - no Icons in the Menu + Taskbar, no Apps can be found

Hey guys,

I updated my system yesterday using pacman (as always) and after running the updates as always, I was confronted with the issue that all Icons in my Taskbar were gone and no Applications could be found searching the system. Funny enough the Desktop Icons are still visible. Most Settings can still be found by the way and when running e.g. Firefox from cmdline it works. First I got a notification that my Theme was not working correctly - so I changed it to the defaults or a new theme and rebooted multiple times. But my System still looks like this:
(I tried to do those screenshots for about 20 minutes using spectacle but I could not get it to start/find it, so I had to use my smartphone sorry)

It finds every folder/file EXCEPT the App.

Here you can see that there is absolutely “nothing” installed.

Even when trying to open a File like a .txt the system “forgot” about all Software that could do that :rofl:

I’m desperate for help, I have never seen such a thing honestly. I also tried to upgrade the kernel to 6.6.30-2-MANJARO but nothing changed. Is there anything I could do about it? Looking into journalctl I found some errors but nothing with priority 0 for the latest boots, but I can’t really interpret what the system is/isn’t doing, maybe someone knows:

Mai 19 17:22:39 k kernel: usb 1-4.2: 1:1: cannot get freq at ep 0x81Mai 19 17: - (changed username for security reasons)

Please help me, I’ve tried to do everything I possibly know but obviously I am not smart enough to fix that problem. Can I maybe just reverse the last pacman transaction for now? Thanks for everyone trying to help me out.

Do you have a timeshift snapshot before you updated?

I am fairly certain it is your cache and previous configurations.

The following script will reset your configuration the the default - likely fixing your issue

#!/usr/bin/env bash
#  orginal script by 
#    This program is free software: you can redistribute it and/or modify
#    it under the terms of the GNU General Public License as published by
#    the Free Software Foundation, either version 3 of the License, or
#    (at your option) any later version.
#    This program is distributed in the hope that it will be useful,
#    but WITHOUT ANY WARRANTY; without even the implied warranty of
#    GNU General Public License for more details.
#    You should have received a copy of the GNU General Public License
#    along with this program.  If not, see <>.#
# mogrified for Manjaro by @linux-aarhus
# don't run as root
if [[ $(whoami) == "root" ]] ; then
    echo "This script is not for root account"
    exit 1

echo "!----------------------------------------------------------------!"
echo ":: This script will wipe ALL your Plasma settings"
echo ":: You cannot undo without having a backup..."
echo "!----------------------------------------------------------------!"

read -p "Press ENTER to wipe Plasma settings (Ctrl+c to cancel)"

cd ~/
rm -rf .kde 
cd ~/.cache
rm -rf plasmashell* org.kde.dirmodel-qml.kcache kioexec krunner ksycoca5* krunnerbookmarkrunnerfirefoxdbfile.sqlite
cd ~/.local
rm -rf kate/ kded5/ klipper/ knewstuff3/ kscreen/ konsole/ kwalletd/ ksysguard/ kmail2/ kcookiejar/ kactivitymanagerd/
cd ~/.local/share
rm -rf dolphin kate kcookiejar kded5 keyrings klipper kmail2 knewstuff3 konsole kscreen ksysguard kwalletd kxmlgui5 plasma_engine_comic plasma plasma_notes org.kde.gwenview
cd ~/.config
rm -f plasma*
rm -rf kde* akonadi* KDE kconf_updaterc baloo* dolphinrc drkonqirc gwenviewrc kmail2rc k*rc katemetainfos plasma-workspace
echo "Done!"
echo "!----------------------------------------------------------------!"
echo ":: Restore Manjaro Default User Settings"
echo "!----------------------------------------------------------------!"

read -p "Press ENTER to restore Manjaro Default (Ctrl+c to cancel)"

cp /etc/skel/. -r /home/$USER
echo "Done!"

echo "To ensure no issues with"
echo "applications and associations missing"
echo "the script will launch these commands as superuser"
echo "sudo update-mime-database /usr/share/mime"
echo "sudo update-desktop-database"
echo "Please enter your superuser password at the prompt"
sudo update-mime-database /usr/share/mime
sudo update-desktop-database

read -p "Press ENTER to restart (Ctrl+c to cancel)"

while [ $secs -gt 0 ]; do
   echo -ne "Awaiting restart ... $secs\033[0K\r"
   sleep 1
   : $((secs--))

systemctl soft-reboot

I should have one from about a week ago normally but I can’t open Timeshift correctly because its not a found application or something .-. But I will try, I still got backups of all the userdata, so the system being corrupt or something would not be a big deal anyways. But because its Linux I think there’s a simple fix to this.

It should not be needed.
You just need to clear some items from $HOME.

(see the post just above yours)

I updated multiple computers this weeks, and a few of them I had to remove the ~/.cache folder and reboot.

Thanks for the script. Sadly this did not change anything except my plasma having reset like basically ALL settings. The programs are still gone sadly.

Tried to find the stuff I need to remove manually in ~/.cache but there seems like its nothing relevant from plasma except theme stuff I don’t want to risk deleting rn. What should I be looking for in that folder?

Hi, new to Manjaro, my setting got messed up from the update, i need step by step instructions on how to run this.

This is all not like the reported “applications are all gone”. No. They are all there on our computers. They are missing in the “all Applications” menu, and all file associations are somehow also erased/missing after/due to the update.
However, you can launch all of your applications in the following way:

  1. start the package manager
  2. switch to “installed”
  3. find in the list the application that you need [desperately]
  4. launch it [or remove or reinstall]

It has just happened to me, so in the next step I will see if reinstalling will bring back them to the menu in “All Applications” and if this is going to restore file associations.
If anyone has any other smart idea how to fix this unnecessary problem at minimal cost, it will be appreciated.
No, wait. I solved it:
Everything magically restored to the previous magnificent beauty of our Manjaro. Problem solved, by a simple removal of any single one application that resulted in revising the system files. It restored the menu, and file associations. Reinstall of any single application should be also simple and effective in solving this problem. The system must revise itself after install/reinstall/removal. Very simple.

You could try running

sudo update-mime-database /usr/share/mime
sudo update-desktop-database

Man, I can’t even start the ■■■■■■■ Package Manager anymore because the association in the TaskBar does not work and I can’t find it in my Apps also. Of course the software is still there, but I can’t launch it anymore which makes them basically ueselss. Reinstalling any app? That would require to reinstall 100+ Applications including the System Apps :thinking:

You are a God. Thanks for that two commands - it basically fixed my system without even having to reboot :partying_face: :pray: All Apps are back on track and I can continue work as I did.

I am not - I am no god - please - I am just an experienced user … pleased to be of help.

:+1: Only Thing I now experience is that through resetting all stuff to default I cannot set the primary screen correctly anymore. In previous versions we had the option to mark one as primary via the Display Config Menu, but that disappeared. I can change the priority in resulting that nothing changes at all. Did they change this?

No - that is still possible

One rarely used screenshot

You can also just rename the folder…

If you have a timeshift snapshot before you did the update, you can follow my points for a clean update:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.