AHCI painfuly slow

Hi! I installed the latest manjaro with AHCI to my intel sata ssd. It was painfuly slow because the disk usage light was always on. I tried a lot of things and one of them succeded. I switched from ahci sata mode to raid. This works but i need ahci for windows because i don’t have the proper drivers for amd raid installed. Before manjaro I had kubuntu and it worked great with ahci but decided to switch. Is there anything i can do?

  Kernel: 6.1.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2203 quiet systemd.show_status=1
    splash driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x
    serial: <filter> UEFI: American Megatrends v: 6042 date: 04/28/2022
  Message: No system battery data found. Is one present?
  RAM: total: 7.67 GiB used: 5.07 GiB (66.1%)
  Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM_A1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 2800 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: Corsair part-no: CMK8GX4M1A2400C14
    serial: N/A
  Device-2: DIMM_A2 type: no module installed
  Device-3: DIMM_B1 type: no module installed
  Device-4: DIMM_B2 type: no module installed
  Info: model: AMD Ryzen 5 2600 socket: AM4 bits: 64 type: MT MCP arch: Zen+
    gen: 2 level: v3 note: check built: 2018-21 process: GF 12nm
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 2166 high: 3400 min/max: 1550/3400 boost: enabled
    base/boost: 3400/3900 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 3400 2: 1550 3: 1550 4: 1550
    5: 3400 6: 1550 7: 1550 8: 1550 9: 3400 10: 1550 11: 1550 12: 3400
    bogomips: 81625
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2
    sse4a ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 525.89.02
    alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 08:00.0
    chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 90 s-size: 474x303mm (18.66x11.93")
    s-diag: 563mm (22.15")
  Monitor-1: DP-0 res: 1680x1050 hz: 60 dpi: 90
    size: 474x296mm (18.66x11.65") diag: 559mm (22") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce GTX 1060
    6GB/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 10de:10f1
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Sound API: ALSA v: k6.1.11-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Hardware-1: Advanced Micro Devices [AMD] Device driver: N/A v: N/A port: N/A
    bus-ID: 01:00.1 chip-ID: 1022:43bd rev: N/A class-ID: 0104
  Hardware-2: Advanced Micro Devices [AMD] Device driver: ahci v: 3.0
    port: N/A bus-ID: 0a:00.2 chip-ID: 1022:7916 rev: N/A class-ID: 0104
  Local Storage: total: 372.62 GiB used: 8.72 GiB (2.3%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9160412AS
    family: Momentus 7200.4 size: 149.05 GiB block-size: physical: 512 B
    logical: 512 B sata: 2.6 speed: 3.0 Gb/s type: HDD rpm: 7200
    serial: <filter> rev: HPM1 temp: 26 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 218d 2h cycles: 3415 Old-Age:
    g-sense error rate: 355 Pre-Fail: attribute: Spin_Retry_Count value: 100
    worst: 100 threshold: 97
  ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSC2BW240A4 family: 53x
    and Pro 1500/2500 Series SSDs size: 223.57 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: DC32 temp: 25 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 89d 19h cycles: 2177
    read: 11.91 TiB written: 11.77 TiB
  Message: No optical or floppy data found.
  ID-1: /tmp/calamares-root-cbzdge0e raw-size: 77.76 GiB
    size: 77.76 GiB (100.00%) used: 8.68 GiB (11.2%) fs: btrfs block-size: 4096 B
    dev: /dev/sdb6 maj-min: 8:22 label: N/A
    uuid: 4e70d00e-8ac4-431c-89ef-30b2a03e4d8f
  ID-2: /tmp/calamares-root-cbzdge0e/boot/efi raw-size: 1.08 GiB
    size: 1.07 GiB (99.80%) used: 30.6 MiB (2.8%) fs: vfat block-size: 512 B
    dev: /dev/sdb4 maj-min: 8:20 label: N/A uuid: 33EE-A258
  ID-3: /tmp/calamares-root-cbzdge0e/home raw-size: 48.83 GiB
    size: 48.83 GiB (100.00%) used: 3.8 MiB (0.0%) fs: btrfs block-size: 4096 B
    dev: /dev/sda5 maj-min: 8:5 label: N/A
    uuid: 080fef78-989b-4629-ae89-b2171163a622
  ID-4: /tmp/calamares-root-cbzdge0e/var/cache raw-size: 77.76 GiB
    size: 77.76 GiB (100.00%) used: 8.68 GiB (11.2%) fs: btrfs block-size: 4096 B
    dev: /dev/sdb6 maj-min: 8:22 label: N/A
    uuid: 4e70d00e-8ac4-431c-89ef-30b2a03e4d8f
  ID-5: /tmp/calamares-root-cbzdge0e/var/log raw-size: 77.76 GiB
    size: 77.76 GiB (100.00%) used: 8.68 GiB (11.2%) fs: btrfs block-size: 4096 B
    dev: /dev/sdb6 maj-min: 8:22 label: N/A
    uuid: 4e70d00e-8ac4-431c-89ef-30b2a03e4d8f
  Alert: No swap data was found.
  ID-1: /dev/dm-0 maj-min: 254:0 mapped: ventoy size: 3.82 GiB fs: iso9660
  ID-2: /dev/sda1 maj-min: 8:1 size: 49.02 GiB fs: ntfs label: Ventoy
    uuid: 66D8AD5FD8AD2DED
  ID-3: /dev/sda2 maj-min: 8:2 size: 32 MiB fs: vfat label: VTOYEFI
    uuid: B228-8EFB
  ID-4: /dev/sda3 maj-min: 8:3 size: 1 GiB fs: vfat label: Clone
    uuid: 33EE-A258
  ID-5: /dev/sda4 maj-min: 8:4 size: 100 MiB fs: vfat label: N/A
    uuid: EAA0-8E1B
  ID-6: /dev/sdb1 maj-min: 8:17 size: 140.22 GiB fs: ntfs label: N/A
    uuid: 2ADAC3D5DAC39B87
  ID-7: /dev/sdb2 maj-min: 8:18 size: 100 MiB fs: vfat label: N/A
    uuid: CA38-D27F
  ID-8: /dev/sdb3 maj-min: 8:19 size: 16 MiB fs: N/A label: N/A uuid: N/A
  ID-9: /dev/sdb5 maj-min: 8:21 size: 4 GiB fs: swap label: N/A
    uuid: 08695f13-d52c-45ef-a2d5-20dd511cabaf
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: IBM NetVista Full Width Keyboard type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 04b3:3025 class-ID: 0301
  Device-2: 1-2:3 info: Logitech M-BT96a Pilot Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 98mA
    chip-ID: 046d:c03d class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.5 C mobo: N/A gpu: nvidia temp: 29 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25%
  Processes: 326 Uptime: 10m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1170 libs: 319 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh (sudo)
  v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25

If you switch from AHCI to RAID in BIOS, all data would be lost. Then you can reinstall Manjaro on RAID.

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.

[HowTo] Provide System Information

  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

It didn’t erase when I switched in my case but the problem with raid is that it uses amd raid controller and windows doesn’t have the proper drivers for that. The only solution is to reinstall windows, but i don’t know if that will fix that because this is a rare case i think.


Why, you have nvidia no other


I was booting from install media when I did that. The install media i mean the second harddisk with ventoy. I was reinstalling manjaro when i pasted that

You have only one RAM module installed.
The CPu has two memory channels.

You have a magnetical HDD installed. These drives are slow.

I have that as second hard drive where it stores the iso images and the home partition. In the ssd i have windows(which runs fine) and manjaro root partition.