After Manjaro-update: Windows boot entry gone

Hi fellows, I need your help:

I’m quite new to Manjaro and I have a Dell XPS13, dual booting Manjaro and Windows in UEFI mode (secure boot off). After updating Manjaro the dualboot entry for booting into Windows is just gone. How can I restore it? I don’t even know how to start solving the problem. I tried to find some similar cases in the forum, but didn’t find anything suitable… :frowning:

When I installed Manjaro (next to Windows), I didn’t have to do anything, the dualboot entries were already made. Do you have any advice? I can provide you more information, if necessary.

Thanks for your help and best regards

sudo update-grub

this should detect your windows partition and create grub entries.

Thanks for your help, I did that, but there is no new entry. It seems that it finds a Windows boot manager, but there is an error “unknown file system”. And even though it states that it creates a new boot menue entry (“Bootmenü-Eintrag für UEFI-Firmware-Einstellungen wird hinzugefügt”), there is nothing now when i boot. Thats my output:

[donato@donato-manjaro ~]$ sudo update-grub
[sudo] Passwort für donato: 
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-5.4-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Warnung: Zur Erkennung anderer bootfähiger Partitionen wird os-prober ausgeführt.
Dessen Ausgabe wird zur Erkennung bootfähiger Programmdateien und Erzeugen neuer Boot-Einträge verwendet.
/usr/bin/grub-probe: Fehler: Unbekanntes Dateisystem.
Windows Boot Manager auf /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi gefunden
/usr/bin/grub-probe: Fehler: Unbekanntes Dateisystem.
Bootmenü-Eintrag für UEFI-Firmware-Einstellungen wird hinzugefügt …
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: Warnung: Unbekannter Gerätetyp nvme0n1.
[donato@donato-manjaro ~]$ 

What is the output of

sudo parted -l

Have you switched off Fast Startup in Windows?

Fast Startup was not switched off. I did that now and re-run “sudo update-grub” again, but it had no effect on the boot entries. See here the output to “parted -l”:

  • 1 is efi
  • 5 is root
  • 6 is swap
  • 7 is home
  • 3 is Windows C:
  • 4 is Windows recovery environment
  • 2 is “Microsoft reserved”
[donato@donato-manjaro ~]$ sudo parted -l
[sudo] Passwort für donato: 
Modell: THNSN5512GPUK NVMe TOSHIBA 512GB (nvme)
Festplatte  /dev/nvme0n1:  512GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  525MB  524MB   fat32           EFI system partition          boot, esp
 2      525MB   660MB  134MB                   Microsoft reserved partition  msftres
 3      660MB   250GB  249GB                   Basic data partition          msftdata
 4      250GB   270GB  20.0GB  ext4
 5      270GB   272GB  2000MB  linux-swap(v1)                                swap
 6      272GB   512GB  240GB   ext4

[donato@donato-manjaro ~]$ 

As you can see, no file system is detected for these partitions. That might be the reason it’s not detected from grub.

Maybe OS prober is disabled?

To restore, execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

No, as it is clearly set up correctly as you can see here:

Well maybe if I could read German.

I am new to this Manjaro too. These Dell laptops do not like dual boot machines, and Windows is not very friendly either. It is in your BIOS that the problem, and the grub menu. When you go into your BIOS it will show Manjaro and no windows boot menu. This has been a nightmare for my Dell Laptop, and Manjaro doesn’t work with my laptop. I have installed it 2 times and both have been failures.

I don’t think that this is true: I have a screenshot from the partitions of my old Antergos, before they shut the project down and I switched to Manjaro (I kept the partitions). The output of fdisk -l looked exactly the same like the parted -l I pasted before (I cannot upload it, my trust level is too low to upload images).

Is there anything else what I can do to fix my boot problem?

When you go into your BIOS it will show Manjaro and no windows boot menu.

What do you mean with that? When I am in my BIOS, I see wether Windows nor Manjaro boot. But in the initial (dual)boot screen, the entry to boot into Windows disappered.

At least after installing Manjaro parallel to Windows, it worked without having any troubles… Any suggestions how I can fix that?

I hope your issue is fixed, if not, you might want to read this here: I want to choose an alternative for grub, any suggestion?

This seems to have worked for that person… I want to choose an alternative for grub, any suggestion? - #7 by realmain