After last update desktop will not load

Hello, I’ve been using Manjaro for a while now, and it worked fine.
That is until I ran an update this week, and now when I start the computer I see the splash screen, it gets stuck for a while then I get a black screen with a mouse cursor. I can then open Konsole by ctrl+alt+t and launch applications that way, but the rest of the desktop environment does not load.

Any idea how to fix this issue?

looks like a messed up update … rerun it again, and if it updates something, reboot and see if it helped

Thanks for your reply, I tried running pacman again to update, it found no updates. Is there a specific command to reinstall previous updates?

go to dolphin, unhide files and rename the .cache folder to .cache.bak, then reboot … if it didnt worked try reinstalling plasma:

sudo pacman -S plasma kio-extras sddm manjaro-kde-settings sddm-breath-theme plasma5-themes-breath

reboot

The issue may be related to a customization you have applied which is now dysfunctional.

If may help if you apply the default plasma theming including desktop settings.

Will try that later today, hopefully. Thanks.

Tried that, still the same thing. it gets stuck at 70% of the progress bar, then goes black with the mouse on screen.

so did you renamed the cache folder?
did you tried this:

I did, and rebooted. Then I tried the second solution.

that’s quite drastic, and I was hoping to avoid it, and only use it as a last resort. Also, could you remind me what’s the command to open the settings from Konsole? I get things mixed with the xfce that I use at work.

systemsettings

you can create a new user in system settings, and then log with it and check if it has also issues

An issue i came across when transitioning from different KDE Plasma versions

tried what’s on this topic, didn’t work.

I did now, and I’m regretting it, now I get no signal when I reach the desktop. I can only open tty now.

created a second user, could not switch to it as the lock screen logout button just ended with no signal.

Guess it’s time to reinstall…