Plasma 5.25.3 - dual screen, Nvidia GPU, funky behavior

While the update itself went fine, can’t stay aside and not mention that since the advent of plasma 5.25 every time i use VirtualBox or Blender while i have a browser opened in another Activity, and then i try to edit something in Inkscape or Gimp (for example) in Work Activity, or i open any GTK+ app, all the context menus and the file dialog of all those opened apps (Qt or GTK+) are behind their main window. I can see them via the Overview, Present Windows or Desktop Grid, but i can’t get them the focus unless i minimize the main application window.

When this pops up in logs:

gdk_window_set_cursor: assertion 'GDK_IS_WINDOW (window)' failed

and also

A backend call failed: No such method 'CreateMonitor' in interface 'org.freedesktop.impl.portal.Inhibit' at object path '/org/freedesktop/portal/desktop' (signature 'ooss')

The entire UI is broken, as mentioned above, and sometimes those messages will spam the log ad nauseam.

The Panel, regardless where is placed, from that moment will cover all windows, even tho is set otherwise, including full screen apps and the System Tray menu will open under whatever application/window is opened. Resolution is to do what i mentioned above, minimize main application window or all and get the use of the Panel menu again, but once an application window is app, all fails to work again.

Once i close them and i start using other applications, things get back to normal till next time. Due to my workflow it happens 90% of the time.

The 5.25.3 did not sort this out for me, and since i was able to reproduce on 2 installs, i gather is something that might affect others too. Would be great if someone else can confirm this, so we could fill a bug report, or maybe point me to something that i might have missed.

@bogdancovaciu I can’t really confirm the behavior you are describing. I work with 2 activities, virtualbox and a permanent panel and 5.25 works fine. However, I’d recommend anyone to perform a Desktop layout reset after upgrading to 5.25, should you not have done so already. No guarantee that it solves your issues.

Dual screen, Nvidia GPU, laptop or desktop pc?

Notebook; internal single screen; Intel GPU Mesa; X11 environment.

Bingo!
I disconnected one of my screens from the GPU, started the PC and i could not reproduce the issue anymore. Shutdown, reconnected the secondary screen, started the system and i could reproduce it again.
One new thing i noticed, once this appears in logs:

Failed to close session implementation: GDBus.Error:org.freedesktop.DBus.Error.UnknownObject: No such object path '/org/freedesktop/portal/desktop/session/1_85/gtk354758237'

i regain the proper functionality, because i closed all the windows, but once i do the same “workflow”, the issue is back.
Not quite sure how to proceed and i’m not sure why is the user@1000.service that is spamming the logs when this happens.

Will move this conversation to its own topic.

Have you tried the same setup with a different user profile? To be more precise: a blank user but with the second monitor attached.

plasma 5.25 remains problematic in several ways. Yesterday a bug was fixed that interfered with logging in from the lock screen . The “present windows group” function ignores windows on the out-of-focus screen with dual monitors. To see more than you want to know, check out the KDE Bugtracking System Main Page.

I did but that way i could not trace the actual issue, and no, is not happening on new user/profile, and i want it to work on my profile :sweat_smile:

That sounds interesting, will look into it at least to understand more.
KWaylandServer has been merged with KWin so kwayland-server package was removed, so that got me a bit confused as i don’t use wayland and i saw no connection with my issue in that regard, but then

:bulb:

Still investigating, so i will not mark this as solved, but inside the ~/.config/kwinrc once i remove lines like:

[Compositing]
GLCore=true
GLTextureFilter=0

and

[Desktops-screen--1]
Id_1=5c37c6d7-73ae-4147-83e8-84050227381f
Number=1
Rows=1

this one has like 20 iterations
or

[DrmOutputs][e1343590-d8a1-5bd2-ba2b-c5fc2f6c1319][e1343590-d8a1-5bd2-ba2b-c5fc2f6c1319]
Mode=1920x1080_59934
Scale=1
Transform=normal

and

[SubSession: 1721a639-a198-4ec8-951e-1b7d116d322f]
active=-1
count=0

all gets back to normal.

Also i compared with a newly created profile while doing all my tweaks, to confirm if i’m on the right track. Funny fact, the new config has 61 lines and old config has 233 lines, both supposedly should do the same thing, but the old one is bonkers.

Still doing reboots and trying to reproduce the issue, but is no longer happening. Will see more tomorrow.

For sure :smiley: ! It was meant for testing purposes in order to eliminate potential causes :wink: .

The same happens with appletsrc. The linking IDs can cause a mess, especially with an install which was done a long time ago (user files don’t get updated). That’s why I suggest a layout reset and in your case maybe do a delete kwinrc at the same time, unless it’s fixed now.

Yeah, no more funky business with this. Either cleaning up manually the ~/.config/kwinrc (only that file) or remove it (while not logged in) to get a new - makes the issue gone.

@LordTermor - we might have to either find a way to transition, or notify users that have older installs about this. For me to reset everything is not an option and i would not propose that unless the desktop session is completely broken or unrecoverable.
Just to regenerate the ~/.config/kwinrc is decent approach for this particular issue, unless of course someone wants to manually edit it on their installs :crazy_face:

1 Like

Yeah, there is no way around doing some .config/.cache spring cleaning every now and then, especially when weird visual things/glitches start happening.

I just had to remove .config/qBittorrent, because after last update columns weren’t resizable anymore, for some reason.

1 Like

Totally understandable. I prefer small changes too, for such configs, or just one file at a time, and keep backups, and the way i do it (no timeshift and friends) allows me to control for myself a new install and have everything ready for my workflow in 30 seconds after install, in case of a catastrophe, but yeah, if something is failing i prefer to touch just that part and renew it. Gladly i did not had to reinstall in long time, except testing ISO releases, but those installs go as they come :rofl:

Anyway, really appreciate your feedback.

1 Like

Indeed. The problem is that it can be hard to pinpoint the problem. :smiley: Especially with plasma - it’s like it has a mind of its own.

Funny thing, just yesterday after these comments I started having random blinking/flickering of opened apps in Task Manager. It’s second time this started happening after a year+ old install.
Hopefully deleting .config/plasma-org.kde.plasma.desktop-appletsrc will fix it…for a year. :smiley:

Some useful documentation of files in case you haven’t seen it yet: GitHub - shalva97/kde-configuration-files: KDE plasma configration files

3 Likes

Yeah, those scripts can be handy. Bookmarked and will investigate at some point.

This thread is a bit old, but the problem is this: 455429 – kwin sometimes composes windows in the wrong order when using the Slide Back effect
So if you disable the slide back effect, it should work again without removing your whole config

1 Like

Never used those effects, i always make sure are disabled on my installs.
I got my answer right here

But i appreciate the input regardless.