After last update - black screen probably because nvidia drivers

It is not the first time it happens to me but this time i can’t figure out by reading other posts.
So before i’ll reinstall Manjaro…any help will be appreciated.
I use Live System to boot and mount my file system using manjaro-chroot -a:
I tried many commands based on this post:

Now this is my situation:

בלוק ציטוט
[manjaro /]# mhwd -li
Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

בלוק ציטוט
[manjaro /]# glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1060 6GB/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 455.45.01
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 455.45.01
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 455.45.01
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
[manjaro /]# mhwd -r pci video-nvidia-390xx
Error: config ‘video-nvidia-390xx’ is not installed!

בלוק ציטוט
[manjaro /]# inxi -G
12Graphics: 12Device-1 Intel 2nd Generation Core Processor Family Integrated Graphics 12driver i915
12v kernel
12Device-2 NVIDIA GP106 [GeForce GTX 1060 6GB] 12driver nvidia 12v 455.45.01
12Display 12server X.Org 1.20.10 12driver nvidia 12note n/a (using device driver) 12FAILED nvidia
12resolution 2560x1440~60Hz
12OpenGL 12renderer GeForce GTX 1060 6GB/PCIe/SSE2 12v 4.6.0 NVIDIA 455.45.01

What error messages do you get? I just had the same problem as you and fixed it by following the post you linked. In my case I solved by booting into kernel 5.4 LTS and ran
sudo pacman -R linux59-nvidia-455xx linux54-nvidia-455xx lib32-nvidia-utils linux414-nvidia-455xx nvidia-455xx-utils. After that I installed nvidia-utils and reinstalled lib32-nvidia-utils linux59-nvidia-455xx linux54-nvidia-455xx linux414-nvidia-455xx. (I have Nvidia GeForce GTX 1060 6GB GPU)

Thank you.
I’ll try it.
But first i need to figure out how to boot into another kernel.

Oh I think your grub menu is hidden when you start your computer. In that case, I think you need to use Live System to boot and mount your root file system. Afterwards, you need to modify your /etc/default/grub and change GRUB_TIMEOUT_STYLE=“hidden” to GRUB_TIMEOUT_STYLE =“menu”. Try now to reboot and see if your grub menu is displayed. If it is, then you can choose advanced options and choose which kernel you have installed and can boot into. Then you can follow the post you have linked.

I hope this helps.

Once i switched to another kernel (5.10) from Grub menu, i finally was able to see Manjaro screen :slightly_smiling_face:
Thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.