After installing Manjaro pc keeps going into bios

hello again
i went through the manual instructions on how to partition and install manjaro.
it says installation complete,but at restart after removing the usb i end up in the bios,and in the boot section there manjaro doesn’t show.
so I’m only able to access manjaro through the usb.
and now i have neither windows nor linux to use.
what went wrong and how can i fix it?

Hi @linub :wink:

Good question… where is my glass globe to look into?

Anyway, a good start would be showing how you have done the partitioning:

sudo parted -l

also a full system summary:

sudo inxi -Fazy


1 Like

When you explain your issue be specific as much as possible and avoid general terms.
Also don’t use terms you assume is what you see, but explain it in long sentences (with proper linefeeds). :wink:

Which instructions did you follow, there are many.

  • A bios screen looks very different as any other thing you will see on your screen.
    Are you 100% sure it is the BIOS aka setup screen of your hardware?
  • It all depends on how you installed an operating system, it does not always show up in the boot section inside the BIOS interface.
  • It could be listed in the boot menu, but you need to select that outside of the bios interface, usually using a function key.

You might have done wrong things and erased your Win… and left with a system unable to boot any OS.

Since we are no telepathist or able to view from your eyes, you need to provide concrete info.

  1. Boot using your LiveUSB of Manjaro
  2. Provide the output of the commands @megavolt above asked for, to begin with.

See this topic on how to provide various info, especially in a way that is correctly formatted on the forum:


Hello both and thank you for answering
i tried to explain the issue to the best of my understanding and knowledge;
-i followed the instructions that are are provided in the official Manajaro PDF available on the installation’s desktop(and on the site too).
-i tried to manually partition in UEFI.
-absolutely sure it’s the Bios,i had to go there before hand to disable fat and secure boot and change it to AHCI instead of Intel RST.
-in the bios there are no boot options listed to choose from or to delete one.
and on system startup pressing(in my case)the ESC key to choose a device to boot from:i have the manjaro usb key(made with ventoy) and the bios.
-i don’t mind i have erased windows,that was my intention,but now i have neither.
-right now i am booted through the live usb.
here are the outputs:

sudo parted -l

Model: SanDisk Ultra (scsi)
Disk /dev/sda: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.0GB  16.0GB  primary               boot
 2      16.0GB  16.0GB  33.6MB  primary  fat16        esp

Model: KINGSTON RBUSNS8154P3512GJ (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      1049kB  538MB  537MB  fat32              boot, legacy_boot, esp
 3      4833MB  512GB  507GB  ext4

for some reason i don’t see the Swap partition i also made
sudo inxi -Fazy

[manjaro@manjaro ~]$ sudo inxi -Fazy
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_KDE_202 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=nonfree nouveau.modeset=0 i915.modeset=1 
  Console: tty 2 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: TUF Gaming FX705GD_FX705GD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX705GD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX705GD.306 date: 05/25/2020 
  ID-1: BAT0 charge: 57.9 Wh condition: 59.2/64.1 Wh (92%) volts: 16.2/15.6 
  model: Simplo SDI ICR18650 type: Li-ion serial: <filter> status: Unknown 
  cycles: 41 
  Info: 6-Core model: Intel Core i7-8750H socket: BGA1440 (U3E1) note: check 
  bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
  stepping: A (10) microcode: DE L1 cache: 384 KiB L2 cache: 9216 KiB 
  L3 cache: 9000 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 800 MHz min/max: 800/4100 MHz base/boost: 2079/8300 volts: 0.8 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
  6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-11:5 chip ID: 13d3:56a2 serial: <filter> 
  Display: server: X.Org 1.20.10 compositor: kwin_x11 
  driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128 size: 382x215mm (15.0x8.5") 
  diag: 438mm (17.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  port: 6000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 491.85 GiB used: 763.2 MiB (0.2%) 
  ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3512GJ 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: E8FK11.C temp: 28 Celsius C scheme: GPT 
  SMART: yes health: PASSED on: 160d 5h cycles: 922 
  read-units: 9,748,084 [4.99 TB] written-units: 16,436,735 [8.41 TB] 
  ID-2: /dev/sda type: USB vendor: SanDisk model: Ultra size: 14.91 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.26 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 11.62 GiB used: 763.2 MiB (6.4%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 46.0 C mobo: 27.8 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 291 Uptime: 41m Memory: 15.49 GiB used: 1.25 GiB (8.1%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1217 lib: 329 
  flatpak: 0 Shell: Bash (sudo) v: 5.0.18 running in: konsole inxi: 3.1.08 

i thought i might have messed the partitioning, but now when trying to reinstall,i only get “manual partitioning” available through the installer and the automatic one does not appear anymore.

Could you provide a screenshot of that BIOS screen, the BIOS boot order, and the available devices to boot from?

1 Like

that’s weired;yesterday night before going to sleep i shuted down the pc,instead of the constant restarts,
and now i do have a few options in the boot menu,
i don’t know how to transfer pictures from my phone in this current “setup”,
but what i have in the list apart from the live usb one are:
-manjaro(the name of my hard drive-Kingston followed by numbers)
-UEFI OS(kingston…)

when trying to boot from either of them,it brings a black screen with an error:
ERROR: resume: hibernation device ‘letters and numbers’ not found

so still only able to boot from usb.

also in the main Bios screen, i supposedly still have a windows option to boot from,but it doesn’t appear in the advanced menu/Boot. nor in the list when booting up the PC.

i managed to get it to work;
at some point i had the option for automatic partition/erase disk
so i chose that
removed before hand all peripherals
removed the USB upon restart
got the Asus logo twice(this was happening also on another laptop with Manjaro)
and got into the OS
checked the bios again and i have two options in boot menu:manjaro and UEFI os.
didn’t bother with that but at least i have what seems to be a functioning os.
apart from the fact i have no sound and didn’t mange to make it work in the audio settings.
i’d appreciate some help with it.

also should i turn back in BIOS fast and secure boot?
and what about reverting the AHCI to INTEL RST,or is it just a Windows thing?

I’ll be back in the morning, i’m glad you got it working now at least, we can check tomorrow if your install is ok or that you should better do it over again :wink:

@linub, Ok lets see where did we left…

You should keep SecureBoot off because you won’t be able to boot Manjaro else.
At least until we fix your UEFI i would keep fast boot off also.

Isn’t that related to RAID setup of your drives?
I would keep it at AHCI…

Ok next i would like you to post the output of these commands:

  1. efibootmgr -v
    This will show us the UEFI boot entries that we might need to clear out of old unused entries.
  2. sudo fdisk -l
    This will give us info about what partition tables and partition types you have on your drives.
1 Like

hello TriMoon
i’m sorry,i just saw your reply,
i was overwhelmed by the Manjaro installation and new to how the Forum and notifications function.

everything is working fine now so I’d rather not mess with anything,
but running your command,i see there is still a windows boot entry;

BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002,0000
Boot0000* Windows Boot Manager
Boot0001* Manjaro
Boot0002* UEFI OS

$ efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002,0000
Boot0000* Windows Boot Manager  VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* Manjaro       HD(1,GPT,5c7ce076-0a10-5845-ae0d-b39b044c2a21,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* UEFI OS       HD(1,GPT,5c7ce076-0a10-5845-ae0d-b39b044c2a21,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

$ sudo fdisk -l
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: KINGSTON RBUSNS8154P3512GJ              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 0D0E2910-3578-F84B-B18D-599922988E95

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      4096     618495    614400   300M EFI System
/dev/nvme0n1p2    618496  981751960 981133465 467.8G Linux filesystem
/dev/nvme0n1p3 981751961 1000206899  18454939   8.8G Linux swap

if decide at some point removing it,i saw the command should be:

sudo efibootmgr -b 0000 -B


sudo ls /boot/efi/EFI

shows only boot Manjaro,no windows.

and BTW why do i have both Manjaro and ‘UEFI OS’?