After changing monitors, the desktop scaling is too large

Hi, after changing my 1440x900 monitor to a 1080p one (using my hdmi port) the scaling is very large despite being set at only 100%.

Any ideas on how to fix it?

Edit: Also the “move to monitor” option isn’t there any more when right clicking the icon in the task bar.

Edit 2: Also when click the “start” menu it appears on the wrong monitor.

provide formated output of:
inxi --admin --verbosity=7 --filter --width
is this a fresh install?
if no, did it started to happen after the recent update?
try switching kernels to 5.15 and 5.10 and try with them
set your monitor into normal scale, then change it to 1080 and check logs in ksystemlogs and post the formated output here

Here’s the output of the first command.

  Kernel: 5.16.18-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=3a0f8b3a-d085-4c2b-993a-e302bc16fc74 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: MSI product: MS-7845 v: 1.0
    serial: <superuser required>
  Mobo: MSI model: Z87-GD65 GAMING (MS-7845) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.12
    date: 05/19/2015
  Device-1: hidpp_battery_0 model: Logitech Wireless Gaming Mouse
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 15.57 GiB used: 4.6 GiB (29.5%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-4770K bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3499 high: 3500 min/max: 800/3500 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3500 2: 3500 3: 3500
    4: 3499 5: 3500 6: 3500 7: 3500 8: 3500 bogomips: 56021
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: driver: nvidia
    v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1380 class-ID: 0300
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 5760x2160 s-dpi: 304 s-size: 481x180mm (18.94x7.09")
    s-diag: 514mm (20.22")
  Monitor-1: DP-1 pos: primary,left res: 3840x2160 hz: 30 dpi: 52
    size: 1872x1053mm (73.7x41.46") diag: 2148mm (84.56") modes: N/A
  Monitor-2: HDMI-0 pos: primary,right res: 1920x1080 hz: 60 dpi: 305
    size: 160x90mm (6.3x3.54") diag: 184mm (7.23") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    vendor: driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
  Sound Server-1: ALSA v: k5.16.18-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros Killer E220x Gigabit Ethernet
    vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 04:00.0 chip-ID: 1969:e091 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 3-13:5 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 4.31 TiB used: 1.12 TiB (26.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1103 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: DB6Q scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DL003-9VT166
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5900 serial: <filter> rev: CC45 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Toshiba model: DT01ACA200
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 223.27 GiB size: 218.71 GiB (97.96%)
    used: 23.46 GiB (10.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 3a0f8b3a-d085-4c2b-993a-e302bc16fc74
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 8F98-9096
  ID-3: /home raw-size: 420.12 GiB size: 412.46 GiB (98.18%)
    used: 88.95 GiB (21.6%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: Home
    uuid: 9606105b-f284-455c-813e-e80914cad9fa
  ID-4: /run/media/calvin/2TB Storage raw-size: 1.82 TiB
    size: 1.82 TiB (100.00%) used: 1.01 TiB (55.6%) fs: ntfs dev: /dev/sdc1
    maj-min: 8:33 label: 2TB Storage uuid: B658DA5A58DA1947
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Holtek Mechanical Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 04d9:1830 class-ID: 0300
  Device-2: 3-4:3 info: Logitech Cordless Mouse Receiver type: Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c537 class-ID: 0300
  Device-3: 3-11:4 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-4: 3-13:5 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2a class-ID: e001
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 57.0 C mobo: 27.8 C gpu: nvidia temp: 44 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 41%
  Processes: 297 Uptime: 1h 2m wakeups: 6 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1384 pacman: 1370 lib: 401
  flatpak: 8 snap: 6 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: yakuake inxi: 3.3.15

This install is like a month old if that, this was caused when I removed my old monitor and plugged in this 1080p one, it happened immediately after I rebooted after plugging in the new monitor.

My monitor is already set to normal scale and 1080p, should I change them, then change them back or just post the ksystemlog output?
I just had a look at ksystemlog and I don’t know how to provide it’s output.

I’ll try changing kernels (after googling how to do that) and get back to you.

i misunderstod you, i thought you changed your resolution, but you replace your monitors… you can change kernels from system settings/ kernel, install the 5.17 and the 5.15, reboot and in the grub menu (taping esc during boot) in advanced options select the desired kernel

I see Wayland and you’re using nvidia. Probably best to log out and log back in but use Session Plasma X11

I also have a 750Ti and as far as I’m concerned, Wayland with Nvidia isn’t ready for prime-time use.

1 Like

Can i have a look at the /etc/X11/mhwd.d/nvidia.conf file ?

I tried the other kernels and it’s still the same.

Here’s the nvidia.conf file

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 510.54

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

As far as using x11 I think I already am, I use auto login so I’ve never actually seen what option is being used by default but if I log out and try to log in using wayland I get an error about an sddm greeter file not being writable so I assume I’ve been using x11 this whole time.

Oh and just in case it’s important I have two monitors.

check system settings/ display and monitor/ display configuration, and check the ‘resolution’ and ‘scale’ options… try different one, and then return to defaults, and see… if it doesnt work, go to compositor and uncheck ‘enable on startup’ then reboot and check the screen… youll have to enable again the compositor by pressing alt + shift + f12

None of that worked I’m afraid, I imagine starting fresh and reinstalling manjaro would work. I’m thinking about doing that.

yes maybe as a last option… post the output of these:
mhwd -l
mhwd -li

mhwd -l output

> 0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
    video-nvidia-390xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

mhwd -li output

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

try installing free drivers:
sudo mhwd -a pci free 0300
if everything went well, reboot

The driver installed fine but after rebooting the scaling is still huge :frowning:

post again output of:
mhwd -li
and screenshot of system settings/ manjaro/ hardware configuration section

mhwd -li output

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

so lets try uninstalling the nvidia drivers:
sudo mhwd -r pci video-nvidia
if everyhing went well, reboot

Wow, I didn’t think this was gonna be solved but the scaling is normal now :smiley:

Thank you!

wait were not done yet… now go to system settings/ hardware configuration and click on the auto install proprietary drivers button, if everything went well, reboot … we will see if with installed nvidia drivers the issue remains solved

Hmm, the install failed giving this output:

> Using config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation GM107 [GeForce GTX 750 Ti]
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: eglexternalplatform will be installed before its nvidia-utils dependency

Packages (9) egl-wayland-2:1.1.9+r3+g582b2d3-1  eglexternalplatform-1.1-2  lib32-nvidia-utils-510.60.02-1  libxnvctrl-510.60.02-1  linux510-nvidia-510.60.02-2  linux515-nvidia-510.60.02-3  linux516-nvidia-510.60.02-2  linux517-nvidia-510.60.02-4  nvidia-utils-510.60.02-1

Total Installed Size:  742.58 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 nvidia-utils-510.60.02-1-x86_64 downloading...
 linux515-nvidia-510.60.02-3-x86_64 downloading...
 linux516-nvidia-510.60.02-2-x86_64 downloading...
 lib32-nvidia-utils-510.60.02-1-x86_64 downloading...
 libxnvctrl-510.60.02-1-x86_64 downloading...
 egl-wayland-2:1.1.9+r3+g582b2d3-1-x86_64 downloading...
 eglexternalplatform-1.1-2-any downloading...
checking keyring...
checking package integrity...
error: libxnvctrl: signature from "Mark Wagie <>" is unknown trust
:: File /var/cache/pacman/pkg/libxnvctrl-510.60.02-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] error: nvidia-utils: signature from "Mark Wagie <>" is unknown trust

:: File /var/cache/pacman/pkg/nvidia-utils-510.60.02-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] error: lib32-nvidia-utils: signature from "Mark Wagie <>" is unknown trust

:: File /var/cache/pacman/pkg/lib32-nvidia-utils-510.60.02-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package)

Errors occurred, no packages were upgraded.
Error: pacman failed!
Error: script failed!

Done ...

run this command:
sudo pacman-key --refresh-keys
it could take some minutes, and ignore the possible errors, when its done refreshing, install again the nvidia drivers, and reboot