After changing monitors, the desktop scaling is too large

It seemed like we were so close, but after the reboot the scaling is too large again :frowning:

so post the output again of:
mhwd -l
mhwd -li

mhwd -l output

0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
    video-nvidia-390xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

mhwd -li output

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

lets try install also this:
sudo mhwd -i pci video-modesetting
if everything went well, reboot

It installed and I rebooted.

and? did it fix it?

Oh sorry, I thought we’d have do more after that, no it’s still the same.

so uninstall the nvidia drivers:
sudo mhwd -r pci video-nvidia
and install the older version:
sudo mhwd -i pci video-nvidia-470xx
if everything went well, reboot

Done it, everything is still huge though.

so try uninstalling the 470:
sudo mhwd -r pci video-nvidia-470xx
and install the oldest:
sudo mhwd -i pci video-nvidia-390xx
if everyhting went well, reboot
if you still have issues uninstall the 390:
sudo mhwd -r pci video-nvidia-390xx
install latest with:
sudo mhwd -a pci nonfree 0300
reboot and we try installing optimus, where youll be running on integrated gpu… and wait till someone more competent responds to your nvidia.config

No it didn’t work, so I guess I’ll wait.

so you are now running the lates nvidia? we can try installing hybrid drivers, although theyre not listed as available for your system from mhwd -l
so uninstall nvidia:
sudo mhwd -r pci video-nvidia
try installing hybrid:
sudo mhwd -i pci video-hybrid-intel-nvidia-prime
if there were not errors/ warnings, reboot

Still no luck I’m afraid. The scaling is still wrong after doing that.

Have you tried logging in as a new/different user, and does the problem still persist? If not, then it’s almost certainly a local config file that’s the culprit.

So if the switching users dont work, install optimus manager and optimus manager qt, reboot… Then right click on the manager icon, and click on integrated/ intel, then click on settings, and select at startup integrated/ intel…
Also you could try downloading latest manjaro kde iso, select boot with proprietary drivers, snd check in the liveusb session the scaling issue…

I tried a new user and it was the same, the scaling issue happens even on the login screen.

I installed those two Optimus programs but neither one did anything when I ran them, I did get an error which I would post but my system won’t boot now so I can’t access it (on my phone currently).

I tried the liveusb, using the open source drivers didn’t have the problem but the proprietary ones did.

Strangely, it was after trying the liveusb that my system won’t boot, it gets stuck on a screen saying " /dev/sda2 clean, [bunch of numbers] files, [bunch of numbers] blocks".

I read that this caused by Nvidia driver which seems right considering I’m having issues with it. I also thought that maybe install those Optimus programs might have caused it but I installed them from the aur and I don’t know how to remove them from the tty.

Edit, I figured out how to uninstall Optimus but that wasn’t preventing the system from booting.

Edit 2, I also removed the Intel prime driver and that also didn’t fix the boot failure.

Edit 3, I removed every driver except video-linux and the system still won’t boot.

Edit 4, it seems manjaro just despises that 1080p monitor, I booted the liveusb with the proprietary drivers and the scaling is normal. I’m just going to reinstall manjaro, it really isn’t worth all this.

Thats unfortunate that it didnt work… Good news is that booting usb with proprietary worked without issues… Let us know if in the new install the scale issue is resolved

No, booting the liveusb with proprietary drivers still had the same issue, I only resolved it by going back to my old monitor. Which I just realised I didn’t mention in my previous edit

Just about to start the reinstall.

@brahma I think you should try to be careful when instructing people seeking for help, because it’s been multiple threads I retain myself to reply when you are, to see what is going to happen. You’re not careful at all and kinda YOLO random things. Please don’t. It is great to try to help, but you should be sure of what you’re suggesting. I don’t think people want to reinstall their system.

@FractalChaos If you can boot to live USB, then you should be able to fix the mess you did on your system. in the live environment try to chroot then simply remove what you installed.

//EDIT: reinstalling will not fix the issue. I think the issue here is that when using the Nvidia driver it doesn’t use the same scale (probably not using same first monitor or something like that), but this should be configurable somewhere (not sure yet, but anyway for now you need to fix the broken system).

If youre going to reinstall, maybe try different linux distro, for example kde neon or fedora kde, if you want to stay on kde… You can try also manjaro gnome live usb on the new monitor and check the scaliing issue there