After a fresh install no wifi or bluetooth available

I have installed on a Microsoft Surface in a seperate partition.

I have tried most of the available kernels since the original one on the fresh install was causing issues and even older ones.

I have also tried installing the headers and also the extramodules to no available despite this being the usual remedy in such issues.

As a side note: during the install I had it plugged into the wired network for faster install in case it had to get any other updates.

Note: Previously I had no issues with a dual partition of Linux Minto out of the box.

provide system info:
inxi -Faz
use formatting, click this icon in editor: </> and copy the output there

Here is the information as requested:

``perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_GB.UTF-8",
        LC_IDENTIFICATION = "en_GB.UTF-8",
        LC_MEASUREMENT = "en_GB.UTF-8",
        LC_MONETARY = "en_GB.UTF-8",
        LC_NAME = "en_GB.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LC_PAPER = "en_GB.UTF-8",
        LC_TELEPHONE = "en_GB.UTF-8",
        LC_TIME = "en_GB.UTF-8",
        LANG = "en_SE.UTF-8"

    are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

  Kernel: 6.0.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-6.0-x86_64
    root=UUID=b0ce9968-d187-4ec0-a132-575dc519debd rw quiet

  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux

  Type: Laptop System: Microsoft product: Surface Book
    v: 124000000000000000000000D:0B:09F:1C:03P:38
    serial: <superuser required> Chassis: type: 9
    serial: <superuser required>
  Mobo: Microsoft model: Surface Book serial: <superuser required>
    UEFI: Microsoft v: 92.3748.768 date: 05.04.2021

  ID-1: BAT1 charge: 14.7 Wh (100.0%) condition: 14.7/17.9 Wh (82.2%)
    volts: 8.6 min: 7.5 model: SMP X906972 type: Li-ion
    serial: <filter> status: full cycles: 723
  ID-2: BAT2 charge: 39.5 Wh (100.0%) condition: 39.5/51.0 Wh
    (77.5%) volts: 8.6 min: 7.5 model: SMP X906980 type: Li-ion
    serial: <filter> status: full cycles: 729

  Info: model: Intel Core i7-6600U bits: 64 type: MT MCP
    arch: Skylake gen: core 6 level: v3 built: 2015 process: Intel 14nm
    family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB
    desc: 2x256 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1650 high: 2800 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 500 2: 2800
    3: 500 4: 2800 bogomips: 22408
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3

  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache
    flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass
    disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user
    pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled

  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Microsoft
    driver: i915 v: kernel arch: Gen-9 process: Intel 14n
    built: 2015-16 ports: active: HDMI-A-2,eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1916
    class-ID: 0300

  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver:
    X: loaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3000x3188 s-dpi: 96
    s-size: 792x842mm (31.18x33.15") s-diag: 1156mm (45.51")

  Monitor-1: HDMI-A-2 mapped: HDMI-2 pos: primary,top-right
    model: Samsung serial: <filter> built: 2020 res: 1920x1080 dpi: 26
    gamma: 1.2 size: 1872x1053mm (73.7x41.46") diag: 801mm (31.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400

  Monitor-2: eDP-1 pos: bottom-l model: Panasonic VVX14P048M00
    serial: <filter> built: 2015 res: 3000x2000 hz: 60 dpi: 263
    gamma: 1.2 size: 290x190mm (11.42x7.48") diag: 343mm (13.5")
    ratio: 3:2 modes: 3000x2000
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6
    Mesa 22.1.7 direct render: Yes

  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor
    Imaging Unit driver: ipu3-imgu alternate: ipu3_imgu
    bus-ID: 00:05.0 chip-ID: 8086:1919 class-ID: 0480
  Device-2: Intel CSI-2 Host driver: ipu3-cio2 alternate: ipu3_cio2
    bus-ID: 00:14.3 chip-ID: 8086:9d32 class-ID: 0480
  Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k6.0.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes

  Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless
    driver: mwifiex_pcie v: 1.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 11ab:2b38 class-ID: 0200
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-1.1.4:5 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp0s20f0u1u1u4 state: up speed: 1000 Mbps duplex: full
    mac: <filter>

  Local Storage: total: 3.87 TiB used: 17.53 GiB (0.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZFLV256HCHP-000MV size: 238.47 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: BXV75M0Q temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Western Digital
    model: WD My Passport 2626 size: 3.64 TiB block-size:
    physical: 4096 B logical: 512 B type: N/A serial: <filter>
    rev: 1031 scheme: GPT

  ID-1: / raw-size: 140.61 GiB size: 137.35 GiB (97.68%) used: 17.49
    GiB (12.7%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 35.1
    MiB (13.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1

  Alert: No swap data was found.

  System Temperatures: cpu: 48.0 C pch: 40.5 C mobo: N/A
  Fan Speeds (RPM): N/A

  Processes: 187 Uptime: 4m wakeups: 1 Memory: 7.68 GiB used: 3.32
  GiB (43.2%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1282 libs: 347 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.21``

Can you edit your comment, it’s just a giant wall of text, very hard to read. Thanks.

Yes I agree, have amended hope that is better, thanks.

pls outputs

sudo dmesg | grep wifi
ip link

Hey here is the information:

  1. sudo dmesg | grep wifi
[    4.171786] mwifiex_pcie 0000:03:00.0: quirk reset_d3cold enabled
[    4.171876] mwifiex_pcie 0000:03:00.0: enabling device (0000 -> 0002)
[    4.172120] mwifiex_pcie: PCI memory map Virt0: 00000000c028606a PCI memory map Virt2: 0000000088d6244c

[    4.185156] mwifiex_pcie 0000:03:00.0: Direct firmware load for mrvl/pcie8897_uapsta.bin failed with error -2

[    4.185163] mwifiex_pcie 0000:03:00.0: Failed to get firmware mrvl/pcie8897_uapsta.bin
[    4.185166] mwifiex_pcie 0000:03:00.0: info: _mwifiex_fw_dpc: unregister device
[    4.186886] mwifiex_pcie 0000:03:00.0: performing cancel_work_sync()...
[    4.186890] mwifiex_pcie 0000:03:00.0: cancel_work_sync() done

  1. ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

2: enp0s20f0u1u1u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:e0:4c:68:00:05 brd ff:ff:ff:ff:ff:ff

installing linux-firmware-marvell fixes this?

sudo pacman -S linux-firmware-marvell

reboot and check ip link or dmesg again

Thanks for the info.

So I tried the fix:

  1. Bluetooth is on now and I can add headphones but the sound keeps jumping.

  2. WIFI is now showing the available networks, but it is not connecting to either my home WIFI network or a mobile hotspot.

On the WIFI it didn’t get a response back from the router.

But my mobile works fine and wired is fine.

I am currently on the bleeding edge kernel (linux60 )so think I will bump it down to (linux519) and see if that works.

Update: WIFI still fails to connect on linux519 kernel (tried rebooting modem also).

post output from:
rfkill list
and are you dual booting with windows?

and which model is it exactly?
(searx search brings different results)
Microsoft Surface Book 3 ?
Microsoft Surface Pro 4 ?

Yes I am dual-booting.

Have Windows 11 and Manjaro, previously Linux Mint.

I have the original Microsoft Surface Book.

0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

so probalby fast startup is not disabled in windows, so disable it in windows

I have seen that fix before probably in setting up Linux Mint but will double check the state.

It is still disabled.

disable/turn off bluetooth and try wifi…
if it didnt help, try this:
sudo modprobe -r mwifiex_pcie
sudo modprobe mwifiex_pcie
test wifi

As of writing, mwifiex will crash after second suspend (s2idle) on upstream kernels. This issue is fixed on linux-surface kernels. If you need to try upstream kernels, I left note below.

Disable d3cold on wifi:

echo 0 | sudo tee "/sys/bus/pci/devices/0000:03:00.0/d3cold_allowed" # wifi is located at `03:00.0` on SB1

or here…

Wifi is known to be unreliable when bluetooth is enabled. A workaround is to disable bluetooth in the BIOS.

That didnt work.
I wonder if I should try a different kernel then? Currently on 519.

try what lila suggests: