Activate NVIDIA GPU/download latest drivers

For Steam game you just need to add launch option in game properties (right click, properties, launch options)

prime-run %command%

The game will launch with dedicated GPU with the hybrid driver installed.

1 Like

I guess it is worth noting, for clarity, that such a method is specific to STEAM.

‘%command%’ is a variable STEAM recognizes, where %command% means the game in question.
The suggestion is specific to that.
As far as I know, %command% does not mean anything anywhere else.

1 Like

I don’t know why you add precision to what was already established.

Because we have posts like

(but now the last 2 are rather unnecessary :wink:)

No.i added this on steam not in lutris

1 Like

Additionally to what cscs just posted, it would be in your favor if you make better sentences, explain WAY more what you do, what doesn’t work, what works, and so on, if I would be caricatural I would say you reply as if you were on Twitter when you should reply as if you were writing essays, so that everyone understand exactly what is going on with your issue.

Example, this post I’m replying to, what are you talking about exactly, what are you replying to, what did you do exactly, what works or doesn’t work when you did that, how did you try to check it works or doesn’t work?

I’m sorry you are right.I just avoid talking too much because my english is very bad but i will try to make you understand.First of all i have my specs displayed in my account but i will mention it here once again.I have a 11th Gen Intel® Core™ i7-11800H @ 2.30GHz × 16 and a nvidia RTX3050 TI laptop gpu.Manjaro runs perfectly fine but when it comes to 3D graphics (like playing games) it runs through the intel graphics.I would like to run games with Nvidia graphics but i do not know how it works in manjaro.Prime-run %command% makes games not to open so this solution it does not work at least for me.There is not any option in the nvidia settins to switch to NVIDIA graphics as you can see in the following screenshot

Lutris due to some steam issues wont detect any steam games either (if i could play the games through lutris i could configure this from lutris but i can’t)

So my question is
1->How to switch to Nvidia graphics
2->How to download the latest drivers for nvidia (the current driver does not seem to be the latest one)

Also i did not understand very well these instructions → Configure Graphics Cards - Manjaro because my english is bad

Let start over. To verify that you actually have the proper setup and that it is working you can give the output of the following commands from terminal:

give proper system information with inxi -Fazy
list the available video drivers with mhwd -l
list the installed video drivers with mhwd -li
list the card used by default (should be Intel) glxinfo | grep renderer
list the card used by offloading (should be Nvidia) prime-run glxinfo | grep renderer

PS: for each command, put three backticks before and after the terminal output that you copy/paste here, for the output to be properly formatted and readable, example:

terminal output here

  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=ee77e999-e0fd-4801-9d3d-3a52858229c3 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506HE_FX506HE
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX506HE v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX506HE.310 date: 11/25/2021
  ID-1: BAT1 charge: 41.2 Wh (100.0%) condition: 41.2/48.1 Wh (85.6%)
    volts: 12.8 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: Full
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x34
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 3698 high: 4285 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1835 2: 4009 3: 4118
    4: 3672 5: 4285 6: 3702 7: 3739 8: 3139 9: 4080 10: 3663 11: 3943 12: 4094
    13: 3313 14: 4206 15: 3569 16: 3816 bogomips: 73744
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: ASUSTeK driver: i915
    v: kernel bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 0000:01:00.0
    chip-ID: 10de:25a0 class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-7:3 chip-ID: 322e:202c class-ID: 0e02
  Display: x11 server: compositor: gnome-shell driver:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa
    resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.4
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:2d:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp45s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
  Local Storage: total: 476.94 GiB used: 26.15 GiB (5.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GD3JX013N
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 41000C20 temp: 34.9 C scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 26.15 GiB (5.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 50.0 C mobo: 27.8 C
  Fan Speeds (RPM): cpu: 3400
  Processes: 416 Uptime: 1h 36m wakeups: 8461 Memory: 15.37 GiB
  used: 5.17 GiB (33.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: N/A Packages: 1163 pacman: 1134 lib: 299 flatpak: 22 snap: 7 Shell: Zsh
  v: 5.8 running-in: gnome-terminal inxi: 3.3.12

> 0000:01:00.0 (0300:10de:25a0) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:2d:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:00:02.0 (0300:8086:9a60) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_NV_float_buffer, 
    GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer, GLX_MESA_swap_control, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)
OpenGL renderer string: NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2

I send all the information in the order you send the commands,hope this information helps!

At first sight, it seems to me that it is all in order, so you should be able to use the Nvidia card on demand.

So start Steam normally (do not add Steam in Lutris or whatever you tried to do before, just open Steam from the application menu).
Right click on one of your game in your Library, and then go to Properties → General
From here you should see at the bottom the Launch Options, simply copy and paste exactly that:

prime-run %command%

Close the game Properties windows, start your game, it should use the Nvidia video card for this game now.

Try and report.

1 Like

i just did that,i added → prime-run %command% as you said.I closed the properties window and i pressed START THE GAME.The game starts and it close right after 1 second

Try another game.

I already tried this in several games but i got the same result.

And does it work with nothing in the Launch Options? Also is this Linux games or Windows games with Proton?

Yes,all games can open normally if the “lunch options” is left blank.I do not run games with steam proton,it can run natively only with steam (at least these games i play) also when i try to do prime-select nvidia i got this result


I don’t know what prime-select is.

I don’t know then if it works only without the prime-run launch option. I don’t see what is wrong. You may try to close Steam and start it from terminal with steam and you can see the Steam log directly in terminal, maybe you can see what is wrong when the game doesn’t launch.

Also maybe some magic behind the scene with your card makes it automatically switch to Nvidia without adding any Launch Options in Steam, it may be possible to verify with a demanding game, and see the performance you have with no Launch Option.

ERROR: object '/home/sayolev/.var/app/com.valvesoftware.Steam/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored

this is the error from the steam log when i try to run a game with prime-run %command%

This is normal.

What is not normal is that you removed Steam and installed it from an external source… Flatpak I guess.

Use the real Steam. Check if your issues go away with the real Steam.