Accessing a shared Windows folder over LAN via Dolphin filemanager?

Hello, everyone! I’m pretty much brand-new to Manjaro and I’m enjoying the journey, but it’s a little rocky on the learning curve.

I’ve been able to setup up a few things for myself after some web searches, but this one has me stumped.

I have a specific file folder on a junky Windows 10 PC that I’m using as a file host just to share over my personal LAN (no internet connected to it). I’m able to set it up just fine for connecting with my other Windows PCs, and I’d like to be able to access it from my Pinebook Pro (this machine). I’ve already got the permissions set how I want them on Windows, but I can’t seem to get access to it from Manjaro using the Dolphin file manager. I’ve made a little progress. For instance, using “nmblookup -A [IP_address_here]” I’m able to see that there is in fact a shared folder there. But when I try to access it from Dolphin using smb://[Host_name]/[shared_folder_name], it takes a while to respond, at which point it gives me a login window asking for user and password. Since my network has no internet access and no personal data for anyone to steal, I decided not to require passwords in Windows to access the folder. I’ve tried just using my Pinebook’s name as my username and leaving the password empty only to be greeted by the login window again. I’ve also tried following the instructions found in the thread from the link below;

However, I haven’t been able to get any of this to work. If there’s anyone out there who could help me out (please be gentle, I’m a n00b), I’d be grateful.

Thanks in advance!

Search and ye shall find Search results for 'samba' - Manjaro Linux Forum

XY problem

So you problem is really not Manjaro Linux but the fact that you want to access without password.

Change the share on the Windows box to use credentials.

Thank you for the quick response!

Just finally got a chance to tinker with the Windows host. I wasn’t able to find a way to set it the shared folder to have a password without making the network visible to outside devices, so I tried setting up a separate windows profile with the required permissions.

From there, I tried booting up my Pinebook Pro, logging into Manjaro, then opened up Dolphin. From there, I went to the address bar at the top of the window, typed in the target drive, starting of course with “smb://” prefix. As before, I was greeted with the login window, at which point I tried using the profile name and password that I had just set up through Windows on the host machine. Obviously, I’ve missed something important, because it just takes a moment, then pops up the login window again.

I should be able to figure this out! My IQ is almost up to room temperature! Lol!

If you no longer need to use your Windows10 system and are simply using it as a file sharing server, you can try to install Manjaro on that PC, and then you can try to share files using ksmbd and sshfs, the former is the Windows file sharing service’s native Linux implementation. The latter relies on ssh and works almost out of the box.

Make sure your files don’t get lost when you install Manjaro, for example, by making a backup.

I refrained from commenting about that, but since the gates are open…
If the computer is only going to be used as a file server, there are way more fitting operating systems than Manjaro.

There are stuff designed to be filesevers/nas with nice web interfaces and all, I just have never used any of them so I can not leave any recommendation.
I’m old school, so I would probably just set up a headless debian server, a samba (or nfs) server and be done with it.
Using win10 as a file server is not the best.

There are a couple of other ways to do this .
Get an external drive and copy the files to it and then hook that drive to your linux pc.
Copy the files to the cloud somewhere,
Install linux on the windows computer.

So, the reason I don’t want to install Linux on that machine is because I use it as my file hosting PC for all of the machines in my house. All of my Windows machines, most of which are Windows 10, one of which is Windows 8.1 (it’s pretty old), are able to access it fine. And I’m still working on a solution to access it with my Linux Mint laptop. But the laptop/netbook that this particular thread is concerning is a Pinebook Pro, which limits my options for Linux distros. Of those that will boot on it, Manjaro feels the most robust and useful for my purposes.

Continuing on the subject of making my file host a Linux PC, I’ve read in other places (and experienced it a little myself) that Windows simply doesn’t know what to do with ext2/ext3/ext4 formatted drives, and I’m concerned that would lock out my Windows machines from having access.

Being able to access from Manjaro doesn’t have to be pretty, I just would like to be able to do it.

Oh, and when I saw Bedna’s post starting with

I just KNEW he was about to go after the IQ comment I made, lol. I don’t know that I could’ve resisted the temptation! :smiley:

There is so much that is wrong with the statements in your last post.

But what it does tell me you do not have enough knowledge to understand.

You realize like 95% of all internet servers run on linux right?
Do you think your windows computer will care if those servers use ext4?

Read up on samba and ask on a windows forum how to set that up if you refuse to listen to the advice we give here.

Not much more we can do.

If you get a samba server (v3) set up and configured correctly (with user and password) on your windows computer, feel free to come back and ask how to connect, that is super easy.

Hint, since youbuse win10, IIRC, you need to add a user account in windows and make sure v3 of samba is running.

Good luck

One more comment from me on this.
I purchased a NAS drive for what you are doing.

Which will access any SMB share being Windows or Samba hosted.

Did try to let both Username and Password fields empty and click on OK button,

If it doesn’t work, you need to type the name and password of an account created on that Windows machine whith enough rights to access that shared folder.
You can check “Remember password” to save typed credential to KWallet.


You, sir, are entirely correct. I may have bitten of more than I can chew for the time being. I appreciate the fact you can be blunt without being cruel. I think I’m going to go do some more research on samba to better understand it. When I get a better handle on how it all works, I’ll try to come back and let you guys know the end result.

1 Like

The topmost result in the search link I posted earlier you will find the necessary information to successfully connect a client to any SMB share.

Use the links at the first part to navigate the topic e.g.

To enable anonymous sharing on a Windows box use a search engine

You took that the right way even though I was riiiiight on the border of what is not toxic, but you took it the right way, phew.

I really urge you to look into using linux as the server instead.

  1. It is easier and takes less resources from your system (less power consumption = less electricity cost)
  2. You learn a little bit more of linux.
  3. You can install other things on that server like a backup server, maybe a plex server, perhaps a dns sinkhole is something that can interest you, etc etc.
  4. It’s WAY cooler to have a linux server than a win10 “server”. xD
  5. You can utter the phrase “I use both debian and Arch”. (joking here)

Shrink the partition you use win10 on and install a headless debian server (no graphical desktop, only terminal) separately, tons of guides for that. That way you get to keep your win10 available with dual boot.
Then all you have to do is this: Install and configure Samba on Debian – Instruction
You only do the first part then use manjaro to connect (do not do the client part of the tutorial)

I’m 100% sure people here will help you out, (maybe not with the debian install) linux is something we know here, windows, not so much. (well, there is knowledge here, but it’s not what the forum is for)

To get it to play with your other windows machines maybe you have to do some more stuff to your config, but inside the tutorial I posted above there is this link to help you out. Configuring Samba | Serverspace

Hi. It usually helps if you use Credential Manager in Windows to create a Windows Credential to store the login details of the Linux user you wish to have access.

The username might best be entered using workgroup\username format. After that, reboot both machines and attempt to connect again.

Here’s a basic tutorial for Credential Manager, if it’s needed.


I appreciate your experience and advice, sir. However, given my specific situation, I think changing that machine to Linux will cause me more headaches that it might solve.

However, I have finally solved my particular issue, and almost entirely by accident.

What I had been doing, once I got samba installed on my Pinebook Pro running Manjaro, was opening the Dolphin file manager. From there, I would go to the address bar at the top and type in “smb://FILEHOST/SHAREDFILES/” and press enter. This would delay for about a full minute with a “loading” message, then present me with the login window. At this point, I was using the account name and password I’d specifically made in Windows for my other machines to access the shared folder. And every time I tried this under Manjaro, the login would wait a minute or two “loading”, then pop up the login again.

I was just about ready to give up and abandon all hope.

However, because I’m fascinated with seeing which of the various Linux distros I can manage to get booted on my Pinebook Pro, I flashed a MicroSD card with Kali ARM. Since the Pinebook Pro can boot from MicroSD, I popped it into the Pinebook and hit the power button. Once it went through it’s initial OS setup, I was in Kali.

I poked around for a bit, ooh-ing and awe-ing at the various features (because it’s fun to learn), then out of curiosity, I connected to my LAN to see what would happen if I tried accessing that “daggum Winders” folder (pardon my Texan accent) through the Thunar file manager (native manager for Kali).


Same thing.

So, in frustration, I gave up on the whole //FILEHOST/SHAREDFILES/ address syntax and decided to just go old school on it. I looked up my host machine’s IP on the LAN. With those digits in hand, I attacked Thunar, viciously typing it out in the Thunar address bar.

Of course, the login window appeared, but I didn’t have much hope. Punched in the username and password just to be greeted again with…

Holy crap, it freakin’ worked?!?

After testing the limits of my access, I quickly shut down the Pinebook, removed the MicroSD card (with Kali), then booted back up under Manjaro. Connected to the network, opened Dolphin, went to type in the address bar…


Smashed the enter key. (Of course, the "x"s are supposed to be numbers, but you knew that.)

Got the login window again. Typed my Windblows username & password…

And I’m in like Flynn! Heck-to-the-freakin’-yeah!

So, long story made longer, I was vastly overthinking it. As per my usual. However, I don’t think I would have made it even half the distance to success if you guys hadn’t been throwing ideas at me.

So, thank you all, sincerely. I can finally mark this one as SOLVED.

May God bless you and give you a very Merry Christmas!

That Idiot Newbie, TexSixguns

1 Like

Please do so the thread closes.
Select the post you think is closest to the solution and press the solution button :white_check_mark: :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.