About building a BSPWM edition over i3wm edition


I want to replicate BSPWM edition on my laptop with a roundabout. Since currently there is no up-to-date official BSPWM build, I went with i3 edition minimal ISO and installed these packages over:

bspwm-ruler bspwm-manjaro bspwm-scripts bspwm-wallpapers manjaro-bspwm-settings

Then I pulled default configs from /etc/skel.

This seems to be a good start but I still miss somethings, like pacfzf and yayfzf. Are there any more packages to get me default BSPWM edition experience? I can of course just copy those scripts from my main machine but it would be nice if I can just download them.

By the way, it’s a minor issue but running rofi with super button alone doesn’t work, super + shift + space combination is working though. How can I fix this?

Thanks and have a nice day.

So why not build the BSPWM ISO?

Actually I’d love to but I don’t have that kind of time (and knowledge). I just want to replicate my current workflow. If I manage that I also want to reinstall my main system on an NVMe disk. Going with i3 edition could be easier but I love BSPWM more than i3.

You can install up to date version of bspwm edition from manjaro-architect from any manjaro iso, i3 included. The edition is not maintained at the moment, so it is possible that there are errors. Really, bspwm is so modular and unix-like, that this is the easiest option. If you want to install bspwm environment from scratch or from i3 edition, you are welcome to do so and it is likely to result in something nice, if you have patience. But if you just want to replicate bspwm edition defaults, it is easiest to just install bspwm edition.

A tip: You can install it on top of your existing i3 installation if you mount your partitions without formatting them. Then create a new user account, and you will have the bspwm edition experience.


Thanks for the reply.

So in this case, just using the ISO I have (I think it was version 20.0.1) and then update would be the shortest way. I haven’t thought using the old ISO and if it will be the same output with the architect I might just go with that.

Installing from scratch would also be nice (and that way I can learn about BSPWM more) but currently I want to do these as fast as possible.

I don’t know how rofi is used or started in BSPWM.
Apparently it is bound to this specific key combination.
You could probably easily change that.

This is just anecdotal but may be helpful:
I have an Archlabs installation - they use rofi bound to the Super key in all their editions.
They do that by running ksuperkey from ~/.xprofile - like this:

ksuperkey -e 'Super_L=Alt_L|F1' &

this generates the key combination Alt_Left + F1 when the left Super key (Windows key) is pressed
and that is then used to trigger rofi when the Super key is pressed, instead of having to use a key combination.
You could probably do the same for the super + shift + space combination
Don’t know whether that would be the most elegant solution.

I use Xfce and for me, what rofi does and what the Xfce whisker menu does is redundant, so I adapted it to trigger the Whisker menu instead of rofi with the Super key.

Have a look through the contents of the manjaro-bspwm-settings, what get’s installed to /etc/skel
and see where and how that key combination is defined - and change it to what you want?

Hi. You can find a list of packages for Manjaro bspwm edition here:

EDIT. Some of them are for minimal edition (marked >basic) and some for full edition (marked >extra)

1 Like

These are controlled by sxkhd on BSPWM. There is a part where this mentioned in sxkhdrc file:

# Triggered by just tapping LEFT super key
super + shift + space
	rofi -show

but it doesn’t say how this achieved. There is no .xprofile either, though I’m guessing it could be something similar.

I’ll check the other files under /etc/skel. Thanks.

Thank you. This will be very useful for a comparison.

Same trick as Archlabs, but with xcape instead of ksuperkey.

1 Like

Instead bspwm-mate is very broken and several packages need to be updated

Made a small fix needed

The process isn’t so complicated after all, iso-profiles are no longer packaged so they need to be downloaded and configured manually

sudo pacman -S --needed git manjaro-tools-iso-git manjaro-tools-iso-git manjaro-tools-base-git
mkdir dev
cd dev
git clone https://gitlab.manjaro.org/profiles-and-settings/iso-profiles

copy /etc/manjaro-tools/* into $HOME/.config/manjaro-tools

Edit $HOME/.config/manjaro-tools/iso-profiles.conf as

Build the iso with command

buildiso -p bspwm


Thanks. It seems easy enough.

With this way, will it have up-to-date kernel too or just a fixed version of latest BSPWM build?

All packages needed will be downloaded at the latest version present in the repository

1 Like


I’m getting this error when I try buildiso command.

==> ERROR: /root/dev/iso-profiles is not a valid iso profiles directory!

Also there wasn’t an iso-profiles.conf file so I created one. Maybe I did something wrong?

run_dir needs to be a absolute path, eg /home/[user]/dev/iso-profiles/
(at tleast that is how it is configured on my system and I do not remember if this is intentional)


Thank you that fixed the issue.
Downloading now.

@Lolix By the way, is this ISO for manjaro-architect install only? Because I cannot find any other installer. architect installer is actually cool but I don’t want to choose from 13k packages right now. :slight_smile:

Yes, if you want to install it with Calamares, add calamares to the package list.

I assume I should do that on buildiso step.

Thanks, will do and try again.

I think everything on buildiso step is automatic, I cannot change anything there. So I looked up around and tried to add calamares to Package-Desktop file under $HOME/dev/iso-profiles/community/bspwm. Apparently it didn’t work. I cannot download calamares with live system either.

I assume I should add it before starting buildiso command but couldn’t find any other place.

How can I add calamares to ISO?

I tried to buildiso again and somehow it has calamares now, will try the installation soon.

Edit 2:
The ISO boots with open source driver but cannot boot with Nvidia driver (lightdm fails to start). How can I fix this, should I build another ISO?

Edit 3:
I went with open source driver, then change to proprietary driver. Also I liked the idea of building personal ISOs (this was new to me). I might play with it a little bit more. :slight_smile: It’s like easy way of architect installer, do everything outside of the install and install it like another edition. There are a couple of broken parts but I was going to rice it anyway so it’s all nice.

Thanks again for all the replies.